Comand ngt 2.5 replacement - Mercedes Benz SLK Forum

SLK R171 General Discussion SLK 200, SLK 280, SLK 300, SLK 350, SLK 55 AMG

 6Likes
  • 1 Post By jimfishboy
  • 1 Post By G0RSQ
  • 2 Post By Sneaky Pete
  • 1 Post By Sneaky Pete
  • 1 Post By jimfishboy
 
LinkBack Thread Tools
#1 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2019
Location: Aylesbury,bucks,uk
Vehicle: 2009 SLK280 tip auto,obsidian black
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Comand ngt 2.5 replacement

Hi all,
This is my first post so please be patient
Having just purchased my SLK 280 Uk rhd, i wanted to upgrade the head unit, a friend has successfully done this on his clk, so i have read all the posts i can find but it was all a bit confusing so i thought give it a go.

So my car has a comand ngt 2.5 i think , the mercedes number is bz9860 a171 900 12 00 80

I purchased a Kenwood DMX 7017DABS head unit
and
Connects2 CTKMB07 Complete Head Unit Replacement Kit

so now to the issues
1). i cannot find a permanent live anywhere, looking at the posts here i thought i could pull it from the AGW unit, but i dont think i have one, i have looked in the passenger footwell but its empty.
I got the switched live from the cigarette lighter socket, but i cant find a permanent live anywhere

2). I wired the permanent live to the switched live so i could test the unit.
Hey presto it all seemed to work... but
No AM/FM radio , i guess its a powered Ariel , i have an Ariel power out on the kenwood but where does it go ??

3). The MFD display appears to not work at all, the information is there but MPG, Miles travelled etc., never update.
im guessing that its something to do with the MOST ring, the original head unit had these connections, but the supplied leads from connects 2 unit just blank these off in the iso converter. can i get these functions back or are they issued from the original head unit? is it possible to link the in and out MOST? its not a deal breaker but MPG and travel time info would be nice, i know the satnav and audio MFD displays wont work, but thought the other screens would be ok.

4). Cannot get the steering wheel functions to work, i connected the can bus unit supplied by Connects2 , cut the short wires and left on connectes , and connected the Kenwood steering wheel control wire blue/yellow to Key 1 as advised but nothing, no up/down volume .

Hope someone can advise, sorry if its a repeat but i did look at the previous posts,
Many thanks in advance
regards
Attached Images
File Type: jpg ngt 2.5 a.jpg (70.2 KB, 5 views)
File Type: jpg ngt 2.5 b.jpg (63.1 KB, 6 views)
File Type: jpg ngt 2.5 c.jpg (54.8 KB, 6 views)
File Type: jpg ba 1.jpg (69.3 KB, 5 views)

Last edited by jbanks15; 1 Week Ago at 05:44 PM.
jimfishboy is offline  
Sponsored Links
Advertisement
 
#2 Old 1 Week Ago
Super Moderator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 89,588
Country:
Chats: 38
Mentioned: 428 Post(s)
Tagged: 5 Thread(s)
Quoted: 6355 Post(s)
Thanks: 3,209
Thanked 10,888 Times in 8,259 Posts
For the models of year 2009 all head units were upgraded to NTG 2.5 system. NTG 2.5 systems is equiped with a built in amplifier
NTG 2.5 systems all have Bluetooth telephone systems within the head unit.

your datacard is posted
did you look at it?
comand aps with 6 disc changer


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#3 Old 1 Week Ago
Super Moderator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 89,588
Country:
Chats: 38
Mentioned: 428 Post(s)
Tagged: 5 Thread(s)
Quoted: 6355 Post(s)
Thanks: 3,209
Thanked 10,888 Times in 8,259 Posts
@Sneaky Pete
@mchild
@efair
@i860
@VII7


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
 
#4 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2019
Location: Aylesbury,bucks,uk
Vehicle: 2009 SLK280 tip auto,obsidian black
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
not so sure

Yep i saw it was 6 cd changer, but i dont think i have this, there is a single dvd slot in the head unit with a sd card slot above, i have looked in the boot(trunk) and glove box but no cd changer ??
jbanks15 likes this.
jimfishboy is offline  
#5 Old 1 Week Ago
Super Moderator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Valrico, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 89,588
Country:
Chats: 38
Mentioned: 428 Post(s)
Tagged: 5 Thread(s)
Quoted: 6355 Post(s)
Thanks: 3,209
Thanked 10,888 Times in 8,259 Posts
Quote:
Originally Posted by jimfishboy View Post
Yep i saw it was 6 cd changer, but i dont think i have this, there is a single dvd slot in the head unit with a sd card slot above, i have looked in the boot(trunk) and glove box but no cd changer ??
have you read that book...what's it called? oh yes, the owner's manual?


put cd/dvd in that slot...does it not ask for more?

I am talking about the old oem head unit

NOT your new one....


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#6 Old 1 Week Ago
Registered Users
 
G0RSQ's Avatar
 
Join Date: Oct 2017
Location: Northwest England, Near Liverpool
Vehicle: SLK 350 2007, Auto, Silver, Red leather, SmartTop, COMAND, AirScarf, Heated Seats, grin factor
Other Toys: MG TF and 2 x Ducati 750's (MGB under long term restoration!)
Posts: 435
Country:
Chats: 0
Mentioned: 23 Post(s)
Tagged: 0 Thread(s)
Quoted: 147 Post(s)
Thanks: 19
Thanked 73 Times in 50 Posts
Quote:
Originally Posted by jimfishboy View Post

I purchased a Kenwood DMX 7017DABS head unit
and
Connects2 CTKMB07 Complete Head Unit Replacement Kit

so now to the issues
1). i cannot find a permanent live anywhere, looking at the posts here i thought i could pull it from the AGW unit, but i dont think i have one, i have looked in the passenger footwell but its empty.
I got the switched live from the cigarette lighter socket, but i cant find a permanent live anywhere

You should not need to find any "Lives", as the Connects2 will provide them all for you. It uses the CAN Bus to detect the correct modes, and generates the voltages on the ISO Plugs.



Plug the connector that went into the old radio into the connects2 plug, and the Kenwood interface cable should plug into the ISO sockets on the Connects2 unit. Should be plug and play!


Quote:
No AM/FM radio , i guess its a powered Ariel , i have an Ariel power out on the kenwood but where does it go ??
Correct. The old NTG2.5 probably produced this feed, so check wire colour coding at old connector. When I used a Connects2 kit this wire was in the ISO connector, but I didnt need it as I had an audio gateway, which still powered the antenna.


Quote:
3). The MFD display appears to not work at all, the information is there but MPG, Miles travelled etc., never update.
im guessing that its something to do with the MOST ring, the original head unit had these connections, but the supplied leads from connects 2 unit just blank these off in the iso converter. can i get these functions back or are they issued from the original head unit? is it possible to link the in and out MOST? its not a deal breaker but MPG and travel time info would be nice, i know the satnav and audio MFD displays wont work, but thought the other screens would be ok.
I think you do need the MOST ring connected, but not sure. However what do you mean by " but the supplied leads from connects 2 unit just blank these off in the iso converter".

Are they actually blanked off? Have you left them in the original plug, that you plugged into the Connects2? If so this is not correct, and they must be linked together. Search for DIY solutions, but on eBay, plenty of cheap comercial solutions to link these together. The plug normally clips out of the connector (a plug in the plug!) and this then plugs into the eBay MOST link



Quote:
4). Cannot get the steering wheel functions to work, i connected the can bus unit supplied by Connects2 , cut the short wires and left on connectes , and connected the Kenwood steering wheel control wire blue/yellow to Key 1 as advised but nothing, no up/down volume .
Which loops did you cut? Only J1 and J2?


maybe you need one of the special cables for your radio?
Maybe because MOST is broken it doesnt work?


I have found the Connects2 kits to be very straight forward, and (almost) plug and play!
jbanks15 likes this.
G0RSQ is offline  
#7 Old 1 Week Ago
Registered Users
 
Join Date: May 2012
Location: Netherlands, Eindhoven area
Vehicle: 2008 SLK 350 Designo-Platinum Black exterior Designo Black/Chablis interior
Other Toys: 2004 Triumph Thunderbird Sport
Posts: 2,074
Country:
Chats: 0
Mentioned: 245 Post(s)
Tagged: 0 Thread(s)
Quoted: 523 Post(s)
Thanks: 25
Thanked 459 Times in 415 Posts
MFD and steering wheel controls use CAN to transmit/receive commands/data, MOST should have nothing to do with it.
Comand NTG1 uses a blue wire to switc on the RF amplification circuits in the antenna amp in the trunk. Couldn't find this wire with Comand NTG2.5. Wire diagram for the antenna amp with the FL version only show, 1 brown wire to ground, a green wire for remote CL to the rear SAM and 1 red/brown wire for +12 V to the rear SAM. And of course coax for RF signals to the Comand in the dash. So my guess is it is constant powered on. Bit puzzled.
Here's a layout of the connectors on the back of the Comand https://www.mbslk.de/files/artikel/r...5%20COMAND.pdf
I'm an OEM guy so can't be of much help with the Kenwood/Connects2 stuff. Sorry.
jbanks15 and EDIII like this.
Sneaky Pete is online now  
#8 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2019
Location: Aylesbury,bucks,uk
Vehicle: 2009 SLK280 tip auto,obsidian black
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Many thanks for the info, im looking into it
jimfishboy is offline  
#9 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2019
Location: Aylesbury,bucks,uk
Vehicle: 2009 SLK280 tip auto,obsidian black
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
hi,
many thanks for the info
point 1
The radio did not power up just using the quadlock connector, the yellow wire appeared to have 12 when unplugged but pulled down to 3.6v when connected, i abandoned this and have the ignition wire from the cigarette lighter, and have found a spare fuse slot in the cabin fusebox which has a permanent 12v so all this now works fine
point 2
thanks i will check for the Ariel power as you suggested
point 3
today the MFD appears to be working, the trip and since reset screens now show correct data, just 1 screen showing miles appears to randomly be counting up, but the main mileage screen is working fine so no worries. I didnt know the most was on a sub plug i just plugged the quadlock into the supplied adaptor so they are not linked but as i say the mfd appeard to be somewhat working without the most ring being looped
point 4
steering wheel controls still not working,
correct i cut link 1 and link 2
the Kenwood has a 3.5 jack for steering wheel input as well as the blue/yellow wire but i was advised i did not use it, so im a bit confused as to why its not working

Many thanks again for the info. i will keep trying and post the results
best regards
jimfishboy is offline  
#10 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2019
Location: Aylesbury,bucks,uk
Vehicle: 2009 SLK280 tip auto,obsidian black
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
ah,
no owners manual with the car,
its coming from germany, but head unit is out now so cannot test, if its all in the head unit im impressed as its just a double din unit, but i cant test it, so no worries.
Im just confused why the most is connected if i have no remote amp or cd, the mfd appears to be can bus, but maybe its used elsewhere
thanks
jimfishboy is offline  
#11 Old 1 Week Ago
DAS/STAR Registered Owner
 
Marco06's Avatar
 
Join Date: Jan 2008
Location: France
Vehicle: R171 55 AMG Obsidian Black - 2004
Other Toys: Fiat Doblo' (professional)
Posts: 368
Country:
Chats: 11
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 95
Thanked 141 Times in 71 Posts
Garage
Hello !



You sell your Comand NTG 2.5 ?


BR


Marco, France

slk 55 amg black - 2004
Marco06 is offline  
#12 Old 1 Week Ago
Registered Users
 
Join Date: May 2012
Location: Netherlands, Eindhoven area
Vehicle: 2008 SLK 350 Designo-Platinum Black exterior Designo Black/Chablis interior
Other Toys: 2004 Triumph Thunderbird Sport
Posts: 2,074
Country:
Chats: 0
Mentioned: 245 Post(s)
Tagged: 0 Thread(s)
Quoted: 523 Post(s)
Thanks: 25
Thanked 459 Times in 415 Posts
Quote:
Originally Posted by jimfishboy View Post
ah,

Im just confused why the most is connected if i have no remote amp or cd, the mfd appears to be can bus, but maybe its used elsewhere
thanks

Your datacard shows option 386 Comfort Telephone and 518 Media Interface. They are on the MOST ring and will cease to function with removal of the Comand.
But these functions are replaced I guess, with the new Kenwood.
jbanks15 likes this.
Sneaky Pete is online now  
#13 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2019
Location: Aylesbury,bucks,uk
Vehicle: 2009 SLK280 tip auto,obsidian black
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
maybe
i need to get the new unit up and running first
i will advise
regards
jimfishboy is offline  
#14 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2019
Location: Aylesbury,bucks,uk
Vehicle: 2009 SLK280 tip auto,obsidian black
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Yep,
i think you are correct
jimfishboy is offline  
#15 Old 1 Week Ago
Registered Users
 
Join Date: Jun 2019
Location: Aylesbury,bucks,uk
Vehicle: 2009 SLK280 tip auto,obsidian black
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Update on the install,
This has been a baptism of fire....
i now know a bit more info.
The connects2 kit i purchased states SLK 2004-2010 but... there were many head units fittted and i dont think the connects2 loom supplied is compatible with the comand ntg 2.5. Having the correct pinouts for the NGT2.5 and comparing them to the quadlock/iso conversion leads makes me suspect that they are incorrect. for example the connects lead puts the yellow live wire onto pin 16, but the original quadlock has a thin pink wire ( MOST wakeup ) on this pin.
So i am waiting for a response from them, but my advice would be, check very carefully the compatibility of any 3rd party leads before you upgrade
i will keep you updated, many thanks to all for the info
jbanks15 likes this.
jimfishboy is offline  
#16 Old 1 Week Ago
Registered Users
 
Join Date: May 2012
Location: Netherlands, Eindhoven area
Vehicle: 2008 SLK 350 Designo-Platinum Black exterior Designo Black/Chablis interior
Other Toys: 2004 Triumph Thunderbird Sport
Posts: 2,074
Country:
Chats: 0
Mentioned: 245 Post(s)
Tagged: 0 Thread(s)
Quoted: 523 Post(s)
Thanks: 25
Thanked 459 Times in 415 Posts
Quote:
Originally Posted by jimfishboy View Post
Update on the install,
This has been a baptism of fire....
i now know a bit more info.
The connects2 kit i purchased states SLK 2004-2010 but... there were many head units fittted and i dont think the connects2 loom supplied is compatible with the comand ntg 2.5. Having the correct pinouts for the NGT2.5 and comparing them to the quadlock/iso conversion leads makes me suspect that they are incorrect. for example the connects lead puts the yellow live wire onto pin 16, but the original quadlock has a thin pink wire ( MOST wakeup ) on this pin.
So i am waiting for a response from them, but my advice would be, check very carefully the compatibility of any 3rd party leads before you upgrade
i will keep you updated, many thanks to all for the info
Connects2 website lists the CKTMB24 as designed for the R171 facelift vehicle.....
I think you're right in your thinking that the ..07 is not the right one for you and you need the ....24 version.

https://connects2.com/products/installation-kits/vehicle/Mercedes/SLK
Sneaky Pete is online now  
#17 Old 1 Week Ago
Registered Users
 
Panasoffkee's Avatar
 
Join Date: Jan 2011
Location: Lake Panasoffkee,FL
Vehicle: 2006 SLK 55 AMG BLK\BLK\BLK
Other Toys: Sebring 5000, Harley Nostalgia, Titan Pheonix, 1964 Corvette 427, 1953 Chevy Truck, 1979 Corvette
Posts: 55
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 1
Thanked 5 Times in 4 Posts
Garage
Germans don't speak Chinese.
Panasoffkee is offline  
#18 Old 6 Days Ago
Registered Users
 
Join Date: Jun 2019
Location: Aylesbury,bucks,uk
Vehicle: 2009 SLK280 tip auto,obsidian black
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Almost there

Update on the replacement
Connects2 are less than useless. Finally they say that they do not have an answer for the NTG2.5 replacement. So this is what i have now.
I have rewired the iso to quadlock loom, everything now works fine, i have steering wheel controls, correct speaker connections, reversing camera and all the power is supplied from the original loom , no need for the additional live or acc wire.
head unit looks great, i have spotify and apple car play, hands free and my full contacts list( the NTG unit only loaded half of my contacts).
Siri works fine so no need for linquatronic.

The only issue i have is that i have no FM/AM reception, i have the Ariel lead into the original white fakra plug, does anyone have any ideas why this should not work. Im not sure if the antenna needs an additional supply to wake it up, i have tried pin 7 on the original white quadlock plug (elec ant) but this did not work.
Any suggestions??
Many thanks.

If anyone wants to know the mods, i can post full instructions
jimfishboy is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R171 SLK Class Cars > SLK R171 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.