Revs goes insane after accelerating. - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 1Likes
  • 1 Post By slk320chick
 
LinkBack Thread Tools
#1 Old 10-18-2013
Registered Users
 
arfan_m's Avatar
 
Join Date: Sep 2013
Location: Cambodia
Vehicle: 1999 SLK 230 Kompressor
Posts: 10
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Garage
(Thread Starter)
Angry Revs goes insane after accelerating.

Hey guys, I have a problem with my SLK.

Whenever I accelerate hard, it would go up to 110kmh but it won't go any higher and the gear wouldn't change unless I take my foot off the pedal. Also after that, when I decelerate to zero, the rev would go up and down crazily and I would have to restart it for it to become normal again . sometimes it would die as well.

I've been looking around the forum for this problem but I'm still not sure.

Could it be the MAF? or the k40 relay? Or possibly the spark plugs? I have not replaced the spark plugs yet.

Thanks in advance! Highly appreciate it guys.

Last edited by arfan_m; 10-19-2013 at 06:08 AM.
arfan_m is offline  
Sponsored Links
Advertisement
 
#2 Old 10-18-2013
Registered Users
 
BarrySLK280's Avatar
 
Join Date: Aug 2013
Location: Kent, UK
Vehicle: 2009 MB SLK 280 Auto
Other Toys: Ford Fiesta 1.5Tdci Econetic Titanium
Posts: 790
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 13 Post(s)
Thanks: 26
Thanked 89 Times in 72 Posts
Garage
Smile

Sorry to learn about your problem. I am no expert on this sort of stuff, but it sounds to me like an electrical issue in the 'brains' of the car.

I can guarantee that a knowledgeable and helpful forum member who understands about these things will be along soon to offer a more intelligent and informed reply than mine !

Hope you get it sorted.

Barry
BarrySLK280 is offline  
#3 Old 10-18-2013
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,602
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Thanks: 555
Thanked 570 Times in 502 Posts
https://www.slkworld.com/slk-r170-gen...ngine-rpm.html
one possibility

Search the forum for high rpm 170 to possibly find other solutions.
BarrySLK280 likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
 
#4 Old 10-18-2013
Registered Users
 
Join Date: Sep 2010
Location: Manila, Philippines
Vehicle: 2003 Slk 200 kompressor
Posts: 268
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 21
Thanked 29 Times in 20 Posts
That kinda happened to me, check out this thread

https://www.slkworld.com/slk-r170-gen...e-problem.html

The esp/BAS in my car was broken which created the speedo problem. I know the pre facelift doesn't have esp, so maybe you can check the equivalent electronic part for it in your car.
Jayzen is offline  
#5 Old 10-19-2013
Registered Users
 
arfan_m's Avatar
 
Join Date: Sep 2013
Location: Cambodia
Vehicle: 1999 SLK 230 Kompressor
Posts: 10
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
Garage
(Thread Starter)
Okay, I looked into all possible solutions and thank you all for it!

No, I did not have the gear on 4th but on D.

Also there weren't any check engine light or ASP light or anything like that.

After looking at symptoms, today I decided to go to the dealer to get error code reading. I got p0170 and p0130. So I got the MAF and throttle actuator cleaned and the error didn't come up ever since. I tried accelerating after it got cleaned and the car is more responsive than before. Later today I'll accelerate harder to see if the problem is still there.

But thank you all for the solutions!
arfan_m is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rattling/tapping noise at low revs joslowe New Members Introduce Yourself Here 15 04-11-2012 10:12 AM
2000 SLK 230 - Problem with car accelerating Nickie New Members Introduce Yourself Here 11 07-13-2011 10:52 PM
Totally Insane!!!!! N4PWJ Off Topic 11 06-14-2007 04:19 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.