Xenon Flicker - Bulb, Ballast or Ground? - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 5Likes
  • 2 Post By EPerk
  • 1 Post By Kyngfish
  • 2 Post By Kyngfish
 
LinkBack Thread Tools
#1 Old 09-26-2013
Registered Users
 
Join Date: Sep 2011
Location: Miami Florida
Vehicle: 2004 SLK 32 AMG - Silver
Posts: 90
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 18
Thanked 8 Times in 6 Posts
(Thread Starter)
Xenon Flicker - Bulb, Ballast or Ground?

My Xenons will flicker occasionally (factory xenons). Both sides flicker, and then usually right after, the passenger side Xenon will go out. I turn the lights off then on, and both lights come on. This has happened intermittently for more than 2 years. Sometimes it won't happen for 6 months or more, but as soon as the Xenon flicker comes back, I know I'm going to have the problem soon.

I've got new Xenon bulbs on order - I decided to get the best I could get, because someone in another forum suggested that might be an issue. Another issue could be a ballast. I'll swap around the ballasts once I replace the tail light, if the issue continues.

This seems much more prevalent with Bimmers, and I've seen a lot on the Bimmer forums about it. One possible solution mentioned is that a bad ground in the tail-light can cause the headlights to have an issue, something about the circuit resetting. Does anyone know where the ground for the tail-lights are?

Fact is, I haven't had this issue for going on 6 months, but I recently replaced the tail-lights because of a bulb-out error I was getting with the brake lights, now, all of a sudden, the problem is back. Could be coincidence, but when I was having the bulb-out tail light error, I never had the xenon error, and vice versa, as though they were linked. I think it's worth checking out.
Kyngfish is offline  
Sponsored Links
Advertisement
 
#2 Old 09-26-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,141
Country:
Chats: 38
Mentioned: 458 Post(s)
Tagged: 5 Thread(s)
Quoted: 6492 Post(s)
Thanks: 3,232
Thanked 11,022 Times in 8,381 Posts
moving your thread to the r170 general discussion section


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#3 Old 09-26-2013
Premium Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: Daily driver 1998 SLK230 243,xxx miles
Posts: 3,505
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Thanks: 960
Thanked 527 Times in 415 Posts
Garage
You should have the alternator checked.
I had a similar problem with my cars lights flickering, I checked the battery connections & fuses, it ended up being the alternator was bad.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Vario roof
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

R170 & R171
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
SLK 230 320 32AMG
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
leapyfish is offline  
The Following User Says Thank You to leapyfish For This Useful Post:
 
#4 Old 09-26-2013
Registered Users
 
Join Date: Sep 2011
Location: Miami Florida
Vehicle: 2004 SLK 32 AMG - Silver
Posts: 90
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 18
Thanked 8 Times in 6 Posts
(Thread Starter)
Word

Leapyfish, I had actually considered that, but it's a good point. I think it's worth a try, the only thing is, only the passenger side light goes out, but I think Autozone can check an alternator right? How many miles does an alternator usually get?
Kyngfish is offline  
#5 Old 09-26-2013
Registered Users
 
ajberrow's Avatar
 
Join Date: Sep 2013
Location: Nant-y-moel, S Wales
Vehicle: 2001 R170 230K
Other Toys: 1953 BSA B31 motorcycle, Spirit TA kit car age unknown
Posts: 734
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 143
Thanked 75 Times in 67 Posts
Garage
When this occurred on my motorcycle, it was a ballast, which eventually failed.

Other threads on here have shown that it can be any of the three things you've listed, so some testing is required :

Swap bulbs side to side.

1. Same bulb flickers - likely to be the bulb.

2. Other bulb flickers - problem is in the ballast or the wiring.

3. Neither bulb flickers - goodness knows - leave it as it is until something else happens!
ajberrow is offline  
#6 Old 09-26-2013
Registered Users
 
EPerk's Avatar
 
Join Date: Sep 2013
Location: Montgomery, Alabama
Vehicle: 1999 SLK 230 Kompresser
Other Toys: 2000 Nissan Altima GLE
Posts: 78
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 5
Thanked 6 Times in 6 Posts
Garage
Quote:
Originally Posted by ajberrow View Post
3. Neither bulb flickers - goodness knows - leave it as it is until something else happens!
That is called RCOS... "Right Combination of Sh**"

efair and ajberrow like this.
EPerk is offline  
#7 Old 09-26-2013
Registered Users
 
Join Date: Sep 2011
Location: Miami Florida
Vehicle: 2004 SLK 32 AMG - Silver
Posts: 90
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 18
Thanked 8 Times in 6 Posts
(Thread Starter)
hmm

Sounds good, just for kicks, any idea where the tail light ground is on the SLK? Is it the screws themselves? I've followed the wiring there, but I don't see anything grounding to the quarter panel or anything.
Kyngfish is offline  
#8 Old 09-26-2013
Registered Users
 
Join Date: Sep 2010
Location: Manila, Philippines
Vehicle: 2003 Slk 200 kompressor
Posts: 268
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 21
Thanked 29 Times in 20 Posts
Quote:
Originally Posted by Kyngfish View Post
My Xenons will flicker occasionally (factory xenons). Both sides flicker, and then usually right after, the passenger side Xenon will go out. I turn the lights off then on, and both lights come on. This has happened intermittently for more than 2 years. Sometimes it won't happen for 6 months or more, but as soon as the Xenon flicker comes back, I know I'm going to have the problem soon.

I've got new Xenon bulbs on order - I decided to get the best I could get, because someone in another forum suggested that might be an issue. Another issue could be a ballast. I'll swap around the ballasts once I replace the tail light, if the issue continues.

This seems much more prevalent with Bimmers, and I've seen a lot on the Bimmer forums about it. One possible solution mentioned is that a bad ground in the tail-light can cause the headlights to have an issue, something about the circuit resetting. Does anyone know where the ground for the tail-lights are?

Fact is, I haven't had this issue for going on 6 months, but I recently replaced the tail-lights because of a bulb-out error I was getting with the brake lights, now, all of a sudden, the problem is back. Could be coincidence, but when I was having the bulb-out tail light error, I never had the xenon error, and vice versa, as though they were linked. I think it's worth checking out.
Do you have the automatic leveling system for the headlights? Mine started to do the flickering when the leveling system failed. It's not the alternator for me because I already bought a new alternator, but it might be for yours. it might be the grounding for the tail lights, but I bought new tail lights and still there are some occasional flickering. (Same with yours, no flickering for months then back again but mine is the drivers side) What I noticed is that I usually have the flickering after I hit a huge pothole or a bumpy road. I am thinking that some wiring might be loose or the bulbs are already near its end. I'm planning to have them replaced, or the head light assembly replaced with the pre facelift headlights without the leveler. Because the post facelift headlights are too expensive! Lol, mercedes quoted me 1800 dollars for one side only.
Jayzen is offline  
#9 Old 09-27-2013
Registered Users
 
Join Date: Sep 2011
Location: Miami Florida
Vehicle: 2004 SLK 32 AMG - Silver
Posts: 90
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 18
Thanked 8 Times in 6 Posts
(Thread Starter)
Update

For kicks I removed the headlights and checked everything out. The insulation on the wiring inside the headlight looks like it was made in the seventies and it's cracked to heck, when I get some time I'm going to fix the insulation. I removed the Xenon bulbs and switched sides. Sure enough the driver's side Xenon flickered and went out this evening, which leads me to believe it's a bulb and not a ballast or wiring.

The new bulbs are on order, I bought the Philips D2R, which are supposed to be the ones to get. They arrive Saturday. We'll see.
ajberrow likes this.
Kyngfish is offline  
#10 Old 10-07-2013
Registered Users
 
Join Date: Sep 2011
Location: Miami Florida
Vehicle: 2004 SLK 32 AMG - Silver
Posts: 90
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 18
Thanked 8 Times in 6 Posts
(Thread Starter)
Just as a followup, the bulb stopped going out when I replaced the set. So far they seem to be rock-solid. Only one bulb was going out, though as a pre courser to the bulb extinguishing, sometimes both of them would flicker at the same time, like a blink. This issue also appears resolved. No idea why they would flicker at the same time, but whatever.
curro101 and ajberrow like this.
Kyngfish is offline  
#11 Old 10-08-2013
Registered Users
 
Firm's Avatar
 
Join Date: Feb 2011
Location: Mississauga
Vehicle: 2001 SLK320
Other Toys: 78 MGB, 84 Camaro, 85 Trans Am, 96 Firebird, 00 Sonoma, 06 Escalade
Posts: 320
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 20
Thanked 34 Times in 20 Posts
Garage
Good followup. I had the exact same issue, also resolved by a new set of quality bulbs. For future reference it's probably easiest to try new bulbs before messing with anything else. I now keep a spare set of bulbs for the next time this problem rires it's ugly head.
Firm is offline  
#12 Old 10-08-2013
Registered Users
 
Join Date: Sep 2011
Location: Miami Florida
Vehicle: 2004 SLK 32 AMG - Silver
Posts: 90
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 18
Thanked 8 Times in 6 Posts
(Thread Starter)
Also

Yeah, and actually as a word to Xenon users out there. I tried the Philips D2R bulbs first, and the dimensions are definitely not the same. The base is a bit shorter, and for some reason fits really tight onto the igniter, I had to destroy the bulb and the base in order to save my igniter. Avoid the Philips bulbs and get the OEM which is OSRAM or the GE ones I got.

Also, the auto parts systems ALL say the SLK takes the D2S bulb, but it doesn't the notches won't match up and the bulb won't fit. You can make it fit by cutting the notch, but you'll end up blinding people, D2S bulbs aren't set up for that kind of headlight.
Kyngfish is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Xenon bulb change!! MDS General Modifications R171 12 11-09-2017 09:47 AM
My headlights slk320chick SLK R170 General Discussion 17 05-25-2013 09:01 AM
Xenon trouble? DIY Ben348 SLK R171 General Discussion 6 11-10-2011 11:24 AM
Headlight out - ballast, bulb, both? thtguy General Discussion 3 04-29-2010 06:35 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.