Check Engine Light.... tonight...omg end of the world drama - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 8Likes
Reply
 
LinkBack Thread Tools
#1 Old 09-02-2013
Registered Users
 
Join Date: Nov 2012
Location: Staten island
Vehicle: 1998 slk 230 kompressor
Other Toys: 2005 Ducati monster 620, 2002 mini cooper s, 2004 Ducati superbike 749, 1984 hunter 27', 1980 c&c 24
Posts: 42
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
(Thread Starter)
Check Engine Light.... tonight...omg end of the world drama

Hey guys

so my 98 slk 230 komp, was doing great until this afternoon when i left work and noticed i actually had a light on....the yellow light of death..check engine...oh no!!!...never really had this light on any of my cars..but since i've been reading about this car for a while..i figured this is going to happen to me eventually due to the dreaded MAF sensor.

never the less..i kept going down the highway ...car sounds fine...the engine doesn't sound the smoothest but doesn't sound bad...then i'm like if i remember half the time this light is MAF..so just keep it calm..go to Autozone get the code pulled and see what happens..

i get the codes pulled and i got the following

p0410
p0170

the 410 sounds like MAF...
the other one 0170..i'm like what...the diagnostic says..possible bad o2 sensor/ fuel injector problem, MAF, BLA BLA BLA..

so i remember watching how to clean your MAF on youtube and saw a guy using electrical contact cleaner..and spraying the crap out of his thing and done....in anycase...before i even mess with this....i figured i would consult the guru's...

1. are these codes kinda hand in hand?
2. How often should you clean the MAF or replace it?
3. should i be cleaning it with the electrical contact cleaner?
4. what are some other possible problems or ideas..
5. Should i be driving it at all?


i was going to get a idler pulley changed on saturday as well as/ oil change/ and trans (fluid/filter,plug), fuel filter too and replace the dampner for kicks and giggles...but this kinda killed my mood for maintenance as i don't know weather to be ok or not....also some dude at autozone..you know the local genious said that it could be a air pump that went bad...i don't know.....you guys be the ones to diagnose...

Last edited by jbanks15; 09-06-2013 at 08:33 PM.
Jcornet is offline  
Sponsored Links
Advertisement
 
#2 Old 09-02-2013
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,602
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Thanks: 555
Thanked 570 Times in 502 Posts
Look up the codes in my sig link then do some forum searching


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
The Following User Says Thank You to slk320chick For This Useful Post:
#3 Old 09-02-2013
Registered Users
 
Join Date: Nov 2012
Location: Staten island
Vehicle: 1998 slk 230 kompressor
Other Toys: 2005 Ducati monster 620, 2002 mini cooper s, 2004 Ducati superbike 749, 1984 hunter 27', 1980 c&c 24
Posts: 42
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
(Thread Starter)
what is a sig link?

can i drive the car?
Jcornet is offline  
 
#4 Old 09-03-2013
Registered Users
 
Join Date: Jan 2013
Location: Greenville SC
Vehicle: 2008 E320 Bluetec(sold 11/14), 2001 SLK 320, 2013 E350
Other Toys: 1972 MGB, 2004 Volvo V70
Posts: 287
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 2
Thanked 37 Times in 33 Posts
Garage
A sig link are the hyper links to information at the end of her e-mail. The check engine light (on all of the time when car is running) is related to fuel management and/or emissions systems. If car is running normally you can drive it.
CarolinaBluetec is offline  
#5 Old 09-03-2013
Registered Users
 
Join Date: Jul 2013
Location: Medford, New York
Vehicle: 2000 SLK230
Posts: 100
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 7
Thanked 9 Times in 5 Posts
Garage
thunderstorm is offline  
The Following User Says Thank You to thunderstorm For This Useful Post:
#6 Old 09-03-2013
Registered Users
 
Join Date: Nov 2012
Location: Staten island
Vehicle: 1998 slk 230 kompressor
Other Toys: 2005 Ducati monster 620, 2002 mini cooper s, 2004 Ducati superbike 749, 1984 hunter 27', 1980 c&c 24
Posts: 42
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
(Thread Starter)
so according to this...

P0170 Fuel Trim Malfunction (Bank 1) ) check vaccum leaks first or
P0171 System too Lean (Bank 1) ) faulty MAF (mass air flow) sensor
P0410 Secondary Air Injection System Malfunction

what does that even mean...what is secondary air injections system?


Jcornet is offline  
#7 Old 09-03-2013
Registered Users
 
Join Date: Jul 2013
Location: Medford, New York
Vehicle: 2000 SLK230
Posts: 100
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 7
Thanked 9 Times in 5 Posts
Garage
Quote:
Originally Posted by Jcornet View Post
so according to this...

P0170 Fuel Trim Malfunction (Bank 1) ) check vaccum leaks first or
P0171 System too Lean (Bank 1) ) faulty MAF (mass air flow) sensor
P0410 Secondary Air Injection System Malfunction

what does that even mean...what is secondary air injections system?


You should take it a good mechanic. Since your car is 1998, I would assume its not under any warranty. Don't take it to the Mercedes Dealership.

Other than that, you should ask Tolak to help you
Tolak likes this.
thunderstorm is offline  
#8 Old 09-03-2013
Registered Users
 
Join Date: Apr 2013
Location: Crystal Beach, Ontario
Vehicle: 2001 SLK 3.2 V-6
Other Toys: 2012 Infiniti EX35
Posts: 280
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 29
Thanked 47 Times in 22 Posts
Send a message via Skype™ to Simprof
On other car I have owned I found over the years that one code being the MAF or whatever can caurse other codes to be thrown. If you can clear all the codes (no check engine light) then run or drive the car and as soon as the Check Engine Light comes back on read the code again, hopefully it'll only show where the problem is coming from..

It works for me most times..
Tolak likes this.
Simprof is offline  
#9 Old 09-03-2013
Registered Users
 
Join Date: Jul 2013
Location: Medford, New York
Vehicle: 2000 SLK230
Posts: 100
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 7
Thanked 9 Times in 5 Posts
Garage
http://www.youtube.com/watch?v=oZrFv77l9nQ

A new MAF sensor is really expensive.
thunderstorm is offline  
#10 Old 09-03-2013
Registered Users
 
Join Date: Nov 2012
Location: Staten island
Vehicle: 1998 slk 230 kompressor
Other Toys: 2005 Ducati monster 620, 2002 mini cooper s, 2004 Ducati superbike 749, 1984 hunter 27', 1980 c&c 24
Posts: 42
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
(Thread Starter)
how do i clear the code without a computer thing?
Jcornet is offline  
#11 Old 09-03-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
First point is to clean the MAF sensor, as you've already worked out.
Not sure about using contact cleaner; I would use a carb cleaner, which is oil-based and will not have any silicone in the spray. (This is the important bit)

You'll find that if you have a security torx bit (T20?) you can take out the sensor from the sleeve, and so can clean it with more detail, but if you don't, there is no problem cleaning the sensor from outside the carrier.

The problems about air flow can be from poor information.
If the performance (and smoothness of running) doesn't improve, or the faults don't go away, then we revisit.
Let us know how you get on; Speak again soon
Jcornet likes this.
Tolak is offline  
The Following User Says Thank You to Tolak For This Useful Post:
#12 Old 09-03-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
Clearing codes

Quote:
Originally Posted by Jcornet View Post
how do i clear the code without a computer thing?
Two types of codes; some clear themselves, and some latch, so they have to be cleared.
Most of the engine ones clear automatically; they will be remembered, but will not keep the CEL lit.

If you need to read the codes, then you will need the 38-pin connector, and associated system. Search for "38-pin" and a thread by Tiralarc57 is the best concentration of info I've seen.
Tolak is offline  
#13 Old 09-06-2013
Registered Users
 
Join Date: Nov 2012
Location: Staten island
Vehicle: 1998 slk 230 kompressor
Other Toys: 2005 Ducati monster 620, 2002 mini cooper s, 2004 Ducati superbike 749, 1984 hunter 27', 1980 c&c 24
Posts: 42
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
(Thread Starter)
So i cleaned the maf...with crb maf cleaner..it was already spotless in there...drove home with no results..i never cleared the codes...now what? The check valve? The fuse thing? What to check for?
Jcornet is offline  
#14 Old 09-06-2013
Registered Users
 
Join Date: Aug 2013
Location: Atlanta, GA
Vehicle: 2001 SLK 320
Posts: 161
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 39
Thanked 28 Times in 19 Posts
I am currently having same issue w/o the 0410 code. I put in a bottle of techron and cleaned the MAF. Drove it 120 miles before the CEL went off. I am still having some issues but the CEL has remained off.

I do not know if the CEL would go off immediately if it was just a dirty MAF or it is takes a while to "re-set" itself.
DIYGirl is offline  
#15 Old 09-07-2013
Registered Users
 
ajberrow's Avatar
 
Join Date: Sep 2013
Location: Nant-y-moel, S Wales
Vehicle: 2001 R170 230K
Other Toys: 1953 BSA B31 motorcycle, Spirit TA kit car age unknown
Posts: 734
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 143
Thanked 75 Times in 67 Posts
Garage
Quote:
Originally Posted by Jcornet View Post
how do i clear the code without a computer thing?
I don't think you can, but one of these has been recommended to me as a good diagnostic tool that will also clear the error codes :

Autel EU702

You will need to check with the seller that it will work correctly with US versions of the car.

Haven't finished reading the thread, so someone else may have got to this point already
ajberrow is offline  
#16 Old 09-07-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
Quote:
Originally Posted by ajberrow View Post
I don't think you can, but one of these has been recommended to me as a good diagnostic tool that will also clear the error codes :

Autel EU702

You will need to check with the seller that it will work correctly with US versions of the car.

Haven't finished reading the thread, so someone else may have got to this point already
Just a note; since you have a pre-facelift R170, you will not be able to use OBD2.
The light should only be lit when the problem is active.
The codes will be remembered so the correct tool can read them after the event, so it does not have to be recreated on the workshop floor to allow diagnostics.
So once you've done the repair, clear the faults, so before and after are not confused, and then try again.
(So DIYGirl had the fault and lamp come straight back when she cleaned the MAF, but when running Techron, after 120 miles, has cleared the lamp)

However, these code readers do support different protocols, and so with a 38-pin adapter, you can get to the different systems, and read/reset them. (See the thread mentioned above, as started by Tiralarc57.)
Tolak is offline  
#17 Old 09-07-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
Quote:
Originally Posted by DIYGirl View Post
I am currently having same issue w/o the 0410 code. I put in a bottle of techron and cleaned the MAF. Drove it 120 miles before the CEL went off. I am still having some issues but the CEL has remained off.

I do not know if the CEL would go off immediately if it was just a dirty MAF or it is takes a while to "re-set" itself.
For the full story, see this thread.
Tolak is offline  
#18 Old 09-07-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
Quote:
Originally Posted by Jcornet View Post
So i cleaned the maf...with crb maf cleaner..it was already spotless in there...drove home with no results..i never cleared the codes...now what? The check valve? The fuse thing? What to check for?
I suspect that the next stage might be Techron, as mentioned in DIYGirl's thread.
Certainly Jeff recommends it. My only reservation is to be sure to change the oil shortly after you've run the treated tank through the car.

See here for a great offer
Tolak is offline  
#19 Old 09-07-2013
Registered Users
 
Join Date: Nov 2012
Location: Staten island
Vehicle: 1998 slk 230 kompressor
Other Toys: 2005 Ducati monster 620, 2002 mini cooper s, 2004 Ducati superbike 749, 1984 hunter 27', 1980 c&c 24
Posts: 42
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
(Thread Starter)
After running more errands today light has come off!!! Which means even though my MAF wasnt oily/greasy... It was dirty.... i guess i just couldnt see it...Thank u all
Tolak likes this.
Jcornet is offline  
#20 Old 09-07-2013
Registered Users
 
Join Date: Nov 2012
Location: Staten island
Vehicle: 1998 slk 230 kompressor
Other Toys: 2005 Ducati monster 620, 2002 mini cooper s, 2004 Ducati superbike 749, 1984 hunter 27', 1980 c&c 24
Posts: 42
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 10
Thanked 1 Time in 1 Post
(Thread Starter)
bad news my light has come on again...is it now confirmed that yes it is the MAF sensor? and when looking for just the insert what exactly is the part number..i couldn't get the thing off with my torque strews due to the peg in the middle of the hole...
Jcornet is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light on... Control Module Performance?!! PLEASE HELP!! ebenk SLK R171 General Discussion 12 04-25-2013 12:49 AM
check engine light + car wobbles + engine gargles miller SLK R171 General Discussion 13 04-24-2013 04:41 PM
Check Engine light lit, then gone away (SLK 32AMG) jonathan SLK R170 General Discussion 0 03-06-2013 08:15 AM
Holly Holmer the Check Engine Light just came on Berliner Heckflosse Off Topic 0 07-26-2012 01:05 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.