Yaw Rate Sensor - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 2Likes
Reply
 
LinkBack Thread Tools
#1 Old 08-06-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
Yaw Rate Sensor

Hello everyone

I own a 2003 slk230. For a couple of months my Bas/Esp light has been coming on after the car feels like it's dragging for a couple of seconds.
I read some posts about this problem, and have tried the following:

1. changed the brake light switch myself, above brake pedal. However I noticed it has six slots, but only five wires from my car? could this be an issue?

2. Have taken it to a mercedes certified mechanic, to diagnose. He said it's the Yaw rate sensor and quoted $800 USD for part and labor.
After locating it in the center console, I realized it's easy and I think I can do it myself, do I need to calibrate and how? after changing? Also I am debating to buy new or used part the cost is 250used and 600new. No real income at this time so really trying to economize. Does anyone have an idea where I can buy a used one where they in case its deffective I can get a refund within a reasonable time frame?

3. Now also my SRS light is on, would someone please give me advise on this.

Thanks in advance for all your help.
mayrabontiel is offline  
Sponsored Links
Advertisement
 
#2 Old 08-06-2013
Registered Users
 
Join Date: Jan 2013
Location: Greenville SC
Vehicle: 2008 E320 Bluetec(sold 11/14), 2001 SLK 320, 2013 E350
Other Toys: 1972 MGB, 2004 Volvo V70
Posts: 287
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 2
Thanked 37 Times in 33 Posts
Garage
The dragging you feel is the ESP applying the brake. Your mechanic had to read codes to verify the failure. Yes, the part is $660 (little cheaper online) with 1.5 hours standard labor charge to install. No, it does not require any special programming. You can get used ones on Ebay for about $200, but make sure it has at least 30 or 60 days "money back guarantee" and use Paypal. SRS light needs the codes read.
CarolinaBluetec is offline  
The Following User Says Thank You to CarolinaBluetec For This Useful Post:
#3 Old 08-06-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
SRS lamp

The SRS lamp is related to the airbag and seat-belt pre-tensioners.
Both of these systems have explosive components, so can only be investigated once all electrical power has drained from the car (disconnect the battery for at least 15 minutes).
But you won't be able to diagnose without battery.
So, as mentioned, you have to get the codes to work out what is wrong, and then you can investigate the failed component, and its associated wiring.

Not a system to mess with.
Good hunting.
JaysonM likes this.
Tolak is offline  
The Following User Says Thank You to Tolak For This Useful Post:
 
#4 Old 08-06-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,613
Country:
Chats: 0
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Thanks: 226
Thanked 379 Times in 265 Posts
Garage
Quote:
Originally Posted by mayrabontiel View Post
Hello everyone

I own a 2003 slk230. For a couple of months my Bas/Esp light has been coming on after the car feels like it's dragging for a couple of seconds.
I read some posts about this problem, and have tried the following:

1. changed the brake light switch myself, above brake pedal. However I noticed it has six slots, but only five wires from my car? could this be an issue?

2. Have taken it to a mercedes certified mechanic, to diagnose. He said it's the Yaw rate sensor and quoted $800 USD for part and labor.
After locating it in the center console, I realized it's easy and I think I can do it myself, do I need to calibrate and how? after changing? Also I am debating to buy new or used part the cost is 250used and 600new. No real income at this time so really trying to economize. Does anyone have an idea where I can buy a used one where they in case its deffective I can get a refund within a reasonable time frame?

3. Now also my SRS light is on, would someone please give me advise on this.

Thanks in advance for all your help.
1. Perhaps, if you post your VIN, we can locate exact part numbers for you. E.g. the brake light switch had some revisions. There are 3 different part numbers for it =) Do you still have receipt for it so we can compare?
2. What I read about Yaw rate sensor is that these are a little different form pre- and post- facelift models. On the post-facelift models the yaw sensor and lateral movement sensor have been incorporated so it's a little different part. Again by having your VIN will be able to pull out exactly what you need. The yaw sensors doesn't seem to fail too often so some people suggest buying a used one.
3. You definitely need to read the codes to become more specific. Usually your local autoparts store will do it for you. Or you can purchase a code reader and use your smartphone app to read codes and then it'll be more clear.
JaysonM is offline  
#5 Old 08-07-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
Hi and thanks for your reply

The brake light switch part is #0015456409 from autohauz
the code on my invoice from my mechanic shows: C1120-001
and finally my VIN WDBKK49F33F283558

Thank you
mayrabontiel is offline  
#6 Old 08-07-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,687
Country:
Chats: 38
Mentioned: 470 Post(s)
Tagged: 5 Thread(s)
Quoted: 6538 Post(s)
Thanks: 3,245
Thanked 11,081 Times in 8,435 Posts
Here is your datacard

I will let JaysonM find the parts you discussed
Attached Files
File Type: pdf KK49F33F283558.pdf (7.3 KB, 74 views)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#7 Old 08-07-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
Yes I will try your suggestion today, about the battery.

Thanks
mayrabontiel is offline  
#8 Old 08-07-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
Thanks Jeff.

Have to step out for a moment. Will take a look later
mayrabontiel is offline  
#9 Old 08-09-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
Quote:
Originally Posted by mayrabontiel View Post
...
the code on my invoice from my mechanic shows: C1120-001
Not something I have person knowledge about, and your Indy seems to have found the code.
See also here
You might want to try disconnecting the yaw sensor; it should then fail immediately (giving the lamp) but would not cause any dragging (because it is failed)

Let us know how this works.
Tolak is offline  
#10 Old 08-09-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
Thanks will post results when I try this.
mayrabontiel is offline  
#11 Old 08-09-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,613
Country:
Chats: 0
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Thanks: 226
Thanked 379 Times in 265 Posts
Garage
Quote:
Originally Posted by mayrabontiel View Post
Hi and thanks for your reply

The brake light switch part is #0015456409 from autohauz
the code on my invoice from my mechanic shows: C1120-001
and finally my VIN WDBKK49F33F283558

Thank you
I apologize for the delay.
Here's some info
The brake light switch you've is a 2nd revision and was replaced by the latest part # A 001 545 9509
It doesn't mean that you got the faulty unit but there's a possibility that these units fail since the part has been revised 3 times. Let's hope it doesn't fail =)
And for the Yaw Rate Sensor - this part has also been revised 3 times...
The latest part # is A 003 542 23 18
1st revision says "Lambda Probe", 2nd - Yaw Rate Sensor, and 3rd is named "Sender unit"
Lots of models share the same components and I've seen used ones on Ebay for $250. The Chrysler Crossfire even shares the same component =)
Here's the link in case you need it:
http://www.ebay.com/itm/04-CHRYSLER-...c7f7c4&vxp=mtr
JaysonM is offline  
#12 Old 08-09-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,613
Country:
Chats: 0
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Thanks: 226
Thanked 379 Times in 265 Posts
Garage
Post

Found a very nice DIY on how to replace "Lateral Movement (Acceleration) Sensor" or otherwise known as "Transversal-Acceleration Sensor"
The "Yaw Rate Sensor is located in the same area". Notice it's located to the left of the above mentioned senor. Rectangular-shaped box held by two bolts.

Sounds really easy to do. Just need to remove the middle panel.
http://www.benzworld.org/forums/r170...eleration.html
and direct link to PDF
http://www.benzworld.org/forums/atta...ent-sensor.pdf

As I said most people say the Yaw rate sensor is not common to fail often and lots of MBs use this part so my guess would be it's safe to use a good-sourced used part.
JaysonM is offline  
#13 Old 08-09-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
Quote:
Originally Posted by JaysonM View Post
Found a very nice DIY on how to replace "Lateral Movement (Acceleration) Sensor" or otherwise known as "Transversal-Acceleration Sensor"
The "Yaw Rate Sensor" is located in the same area. Notice it's located to the left of the above mentioned sensor. Rectangular-shaped box held by two bolts.
Sounds really easy to do. Just need to remove the middle panel.

As I said most people say the Yaw rate sensor is not common to fail often and lots of MBs use this part so my guess would be it's safe to use a good-sourced used part.
The hacker in me is twitching; once you have confirmed you can drive the car without the sensor(s), I can't help thinking that for a car of this era (and so many relays), they did not move into the solid state accelerometers, and will have some relatively simple mechanical sensor (moving ball, damped, with spring?) and so I suspect it can also easily be repaired. So it is worth a try to mend the sensor that is broken (you're only going to throw it away, after all) and could well save yourself money.
At the very least, take loads of pictures so we can all be educated.
Anon
JaysonM likes this.
Tolak is offline  
#14 Old 08-09-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
Yes I would like to try to fix the sensor myself, but prior to going to the expense of buying another. However I did already remove it and looked at it, and put it back... was all I could do because the box itself is sealed completely there doesn't seem to be a way to open. Anyways I fixed the SRS light. thanks, MB
mayrabontiel is offline  
#15 Old 08-10-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
Quote:
Originally Posted by mayrabontiel View Post
Yes I would like to try to fix the sensor myself, but prior to going to the expense of buying another. However I did already remove it and looked at it, and put it back... was all I could do because the box itself is sealed completely there doesn't seem to be a way to open. Anyways I fixed the SRS light. thanks, MB
So, splitting this up;
Does the car drive OK (not in limp home mode) with teh yaw sensor disconnected? If so, we can play with it without disabling the car.

Sealed box? That mean's it's easy to repair, and they don't want you to find out! Double check it is not just a snug fit. If it is sealed, then there will be a joint/glue line which is the best place to cut your way in.
BTW, since we intend to put it back together, it is worth avoiding the use of the hammer!
And since this is a subtle force measurement system, watch out for small springs and the like. I'm expecting to find that there are normally closed switches at each end of the movement of a ball, and that one of these switches is making poor contact.

(Interesting side test, before you strip it out. Take car to an open area, and whizz around in a small circle, in each direction, to trigger the yaw sensor. if at the next power up, the symptom has gone away, then this is a switch issue, and you will be trying to clean some contacts within the yaw sensor)

Finally, what did you do to cure your SRS lamp?
Happy hunting.
Tolak is offline  
#16 Old 08-12-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
A seller on EBAY has a Yaw rate sensor part # 0035422418 Q01 for about $150 USD incl. shipping and is also willing to refund if it's not a fit. Catch is is one digit different from the correct part and is coming from England. The other seller which is the correct one is $220 and is coming from Lithuania.....??? Help
mayrabontiel is offline  
#17 Old 08-12-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,613
Country:
Chats: 0
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Thanks: 226
Thanked 379 Times in 265 Posts
Garage
Quote:
Originally Posted by mayrabontiel View Post
A seller on EBAY has a Yaw rate sensor part # 0035422418 Q01 for about $150 USD incl. shipping and is also willing to refund if it's not a fit. Catch is is one digit different from the correct part and is coming from England. The other seller which is the correct one is $220 and is coming from Lithuania.....??? Help
Part numbers are the same it's just the last Q01 vs Q02... Probably because they were fitted onto different cars or might be just another revision.
Have you asked what car was that sensor removed from?
JaysonM is offline  
#18 Old 08-13-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
No this one has 24 instead and came off a clk. the one you told me should be 23 in between
mayrabontiel is offline  
#19 Old 08-13-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
Yes the car drives but I only drive in the streets not highway. Since it feels the dragging after a few minutes of driving and bas/esp light comes on the dash. I also noticed a light coming on latelly on the dash, which looks like a lightbulb. Checked all the fuses for the lights and they seem to be ok.
Anyways I would really like to brake the YAW Sensor open, and find out what the problem is, do you think I can take it to a TV repaiman to test all circuits and sawter if any loose?, hee, hee...I am curious what it would be. But I will try the L and R spin first. I found a local YAW sensor for $180 30day warantee. I will order tomorrow. Ok Thanks and keep in touch.
mayrabontiel is offline  
#20 Old 08-13-2013
Registered Users
 
Join Date: Dec 2010
Location: California
Vehicle: 2003 slk 230
Posts: 23
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 6
Thanked 0 Times in 0 Posts
(Thread Starter)
Oh Sorry forgot to tell about the SRS. I thought I PM you on this and asked you to post it for the community. I got my fuse tester and went thru the entire box/es. Found #2 blinking so I replaced it. #1 was somewhat loose. pushed it In as much as I could. Also disconnected the negative on Battery for about 4hrs. And that did it SOOOO Happy!
mayrabontiel is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
'Fault Code 004 - Airbag Driver Side' slk 230 1997 ebslk1997 SLK R170 General Discussion 3 05-16-2013 10:32 PM
Yaw sensor part number help Rocketdog SLK R170 General Discussion 3 03-26-2012 08:58 PM
check engine light on - oxygen sensors out? benz_bolek General Discussion 12 07-27-2010 10:19 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.