Fault code P201D-004 - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 03-06-2018
Registered Users
 
Join Date: Aug 2015
Location: United Kingdom
Vehicle: SLK 230K 2002
Posts: 22
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 3
Thanked 2 Times in 2 Posts
(Thread Starter)
Fault code P201D-004

Hi all,

I've got a 230k 2002, runs like a dream and I use it daily in all weather!

Recently it came up with the engine management light which turned out to be a MAF fault. That was replaced and all was well except...

On cold start, it would start and run fine but if I drove it from cold, it had a hell of a hesitation. Pushing the pedal down further pushed it passed it and when it got warm, the problem was less noticeable to the point it disappeared.

Now today, the engine management light is back on.. fault code is P201D-004:

Self adaption of mixture formulation, Mixture is too rich at idle speed P0172

Did a search on the problem but coming up with various possibilities.. anyone else had this issue or know what it could be?

Cheers
latz is offline  
Sponsored Links
Advertisement
 
#2 Old 03-06-2018
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,315
Country:
Chats: 0
Mentioned: 594 Post(s)
Tagged: 0 Thread(s)
Quoted: 913 Post(s)
Thanks: 155
Thanked 520 Times in 481 Posts
Do all of your injectors sound relatively the same if you listen with an automotive stethescope? Was it an OEM MAF you installed, or a knock-off? And do you have a way to test the fuel pressure at the rail?
efair is offline  
#3 Old 03-07-2018
Registered Users
 
Join Date: Aug 2015
Location: United Kingdom
Vehicle: SLK 230K 2002
Posts: 22
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 3
Thanked 2 Times in 2 Posts
(Thread Starter)
Thanks for the reply. The MAF was bought from a reputable part chain here, not Mercedes. The CEL for the MAF and any codes have gone since it's replacement.

All injectors sound the same, the car runs perfectly, it's just the stutter at low revs and start off speed. Haven't tested fuel pressure, not sure that would be a problem as it's running rich and drives well throughout the rev range (with exception to this issue).

It honestly feels like an accelerator pedal issue, like the potentiometer in the pedal has failed but I'm guessing that would give a different code, not the one I have got. I have tried the pedal reset procedure but that didn't seem to make the issue go away.
latz is offline  
 
#4 Old 03-07-2018
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,315
Country:
Chats: 0
Mentioned: 594 Post(s)
Tagged: 0 Thread(s)
Quoted: 913 Post(s)
Thanks: 155
Thanked 520 Times in 481 Posts
Well I'm totally guessing. It's possible you have a pedal issue but I don't see why it would be related to engine temp. And I definitely don't see how the pedal could cause running too rich.
efair is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
P0155 fault code ( 02 sensor heating ) SLK3202000 SLK R170 General Discussion 9 06-11-2017 04:46 AM
SLK R171 not starting duncanadamsxxx SLK R171 General Discussion 12 04-06-2017 04:53 AM
unknown OBD2 fault code: P2350 miller SLK R171 General Discussion 11 05-24-2013 11:39 AM
'Fault Code 004 - Airbag Driver Side' slk 230 1997 ebslk1997 SLK R170 General Discussion 3 05-16-2013 10:32 PM
Vario Roof Fault - Code B1271 tomkeeling SLK R170 General Discussion 5 10-09-2010 07:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.