Cruise Control failed - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 7Likes
  • 1 Post By ixion
  • 1 Post By Hui Sweetcheong
  • 1 Post By ixion
  • 2 Post By PaPa Bear
  • 1 Post By ixion
  • 1 Post By kapitand
 
LinkBack Thread Tools
#1 Old 02-19-2018
Registered Users
 
ixion's Avatar
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2013 Smart Car in Blue.
Posts: 353
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 0
Thanked 57 Times in 36 Posts
(Thread Starter)
Question Cruise Control failed

Went out for a drive in my SLK yesterday for the first time in 2 weeks.

Discovered that the Cruise Control was not working although the orange light on the stalk comes on when pushed in.

Checked - -
Tyre Pressures - ok
Fuses (2) [ Under Hood & Side of Dashboard ] ok
No fault lights on instrument panel
No codes thrown when checked with my Magic box.
Brake Lights working normally

Can anyone think of anything else easy to check or am I off for a visit to my Indy .

Mike
ps33fount likes this.
ixion is offline  
Sponsored Links
Advertisement
 
#2 Old 02-19-2018
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: SLK350/C200AMG(Bluebadger),MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 23,207
Country:
Chats: 0
Mentioned: 271 Post(s)
Tagged: 0 Thread(s)
Quoted: 2282 Post(s)
Thanks: 1,973
Thanked 1,473 Times in 1,359 Posts
Garage
Not a brains, as you know.


But doesn't the speed sensor come into play here?

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is online now  
#3 Old 02-19-2018
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: SLK350/C200AMG(Bluebadger),MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 23,207
Country:
Chats: 0
Mentioned: 271 Post(s)
Tagged: 0 Thread(s)
Quoted: 2282 Post(s)
Thanks: 1,973
Thanked 1,473 Times in 1,359 Posts
Garage
I'm no expert, but I bet at least one of these guys will drop by with the relevant info:



@Mn car guy
@efair
@stu32
@savcom
@Turdo2
@Padgett

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is online now  
 
#4 Old 02-19-2018
Registered Users
 
Join Date: Nov 2013
Location: Southern Wisconsin
Vehicle: 2001 SLK320
Other Toys: Areobatic Biplane (20+years and I'm still alive)
Posts: 29
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 4 Times in 4 Posts
Check if the roof works.(.lets see...bonnet in the front...boot in the back...drop head??? above?). Like the cruise control, the top function needs to know the wheel speed. This will help rule in/out sped sensors and reluctor rings.
kapitand is offline  
#5 Old 02-19-2018
Registered Users
 
Join Date: Dec 2012
Location: Atlanta, GA USA
Vehicle: '99 SLK 230 R170
Posts: 3
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Please check battery voltage with engine off for at least 2 hours. I've seen low voltage cause CD to stop working with battery voltage below 12.1 volts. Even with engine running and alt output close to 14.2, CC measures only battery output voltage. You need 12.6-13.2 on egg me off voltage.
mitchkranes is offline  
#6 Old 02-20-2018
Premium Member
 
Hui Sweetcheong's Avatar
 
Join Date: Dec 2015
Location: Malaysia
Vehicle: Merc SLK 200 (171) 2008. Right hand drive - Japanese spec
Other Toys: Self balancing personal transporter, elec bike, etc
Posts: 325
Country:
Chats: 0
Mentioned: 8 Post(s)
Tagged: 0 Thread(s)
Quoted: 74 Post(s)
Thanks: 73
Thanked 30 Times in 29 Posts
Hi
Good day.

I had this problem before.

And the cause of it was the steering angle sensor malfunction.
There was no repair but to change the angle sensor.
When the angle sensor malfunction, the ESP also doesn't work.

I costed me about USD 400.00

Thank you & have a nice day
Avel Du likes this.
Hui Sweetcheong is offline  
#7 Old 02-20-2018
Registered Users
 
ixion's Avatar
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2013 Smart Car in Blue.
Posts: 353
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 0
Thanked 57 Times in 36 Posts
(Thread Starter)
Thanks to all who gave suggestions -

Check if the roof works - I had the roof down when I found the problem. Just checked it again - Works OK

Check battery voltage - I Just fitted (3 weeks ago ) a New Varta AGM battery. Just in case I put a DMM across the terminals. Result - 12.4v. Then I remembered to take a terminal off (Open Circuit Test) - Result 12.9v

Steering angle sensor malfunction - This should give me an EPS fault light + code. Neither present.

Have just rung the Indy & have an appointment on Thursday.

Will let you know the Cause & Cure then.

Mike
Avel Du likes this.
ixion is offline  
#8 Old 02-20-2018
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spŕin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,744
Country:
Chats: 0
Mentioned: 109 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,297 Times in 1,138 Posts
Garage
Wasn't pressing the stalk in for the speed limiter, not the cruise control, or was the orange light comment just to say there was life there?

When was it last working? Have you changed tyres since then?


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
curro101 is offline  
#9 Old 02-21-2018
Registered Users
 
PaPa Bear's Avatar
 
Join Date: Aug 2017
Location: Central Victoria
Vehicle: 1999 SLK230
Other Toys: What ever i have in my hand at the time
Posts: 197
Country:
Chats: 0
Mentioned: 4 Post(s)
Tagged: 0 Thread(s)
Quoted: 35 Post(s)
Thanks: 3
Thanked 24 Times in 16 Posts
Garage
I use cruse on my 99 230 all the time, if you push the stalk in it turns on speed limiting, and turns the light on and cruse off

If your is the same as mine you dont need to turn it on like a lot of vehicles, it is on by default.
If the light is on press the stalk in again to go back from speed limit to cruse, and the light should go off.

Then once at the speed you what just lift up the stalk and you are done, to manualy disingage pess stalk backwards (towards front of car )

Hope that makes sence, but as i said not sure your's is the same but that is how the 99 version works.

By the way i have found a nice feature in the slk cruse control is that it will drop down a gear when going down a hill to stop you going overspeed, how that is a nice touch

Cheers from down under
Australian and devilman9050 like this.
PaPa Bear is offline  
#10 Old 02-21-2018
Premium Member
 
devilman9050's Avatar
 
Join Date: Sep 2016
Location: Leicester
Vehicle: 2003 SLK230
Other Toys: ML280, CBR600
Posts: 342
Country:
Chats: 0
Mentioned: 53 Post(s)
Tagged: 0 Thread(s)
Quoted: 137 Post(s)
Thanks: 13
Thanked 69 Times in 46 Posts
Garage
Hi Ixion,
I'll second what PaPaBear said:

Pull towards: Activate at a previously set speed
Push up: set speed or increase current speed in 1mph increments
push down: decrease speed in 1mph increments
push away: turn off
push stalk in: set speed limiter

https://www.manualslib.com/manual/10...age=137#manual

I'm pretty sure the 320 would be the same as the 230, I can't see why they'd make it any different?

Cheers

Dez

Fancy seeing what your SLK can do on the track, and getting a bit of hazardous driving training?

Come along to the track day at Rockingham on the 9th September 2018:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
devilman9050 is offline  
#11 Old 02-23-2018
Registered Users
 
ixion's Avatar
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2013 Smart Car in Blue.
Posts: 353
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 0
Thanked 57 Times in 36 Posts
(Thread Starter)
Hi,

Getting back to you about my problem.

Car delivered back with Cruise Control still not working.

The Indy found no Codes with his Star - DAS unit.

After discussion we decided to replace the Switch Unit on the Steering Column. Has to come from Germany (5 days) so fitting end of next week.

If that does not work ???.


Does anyone know if a Problem in the Front SAM could cause this problem ??

Mike
Avel Du likes this.
ixion is offline  
#12 Old 02-24-2018
Registered Users
 
Join Date: Nov 2013
Location: Southern Wisconsin
Vehicle: 2001 SLK320
Other Toys: Areobatic Biplane (20+years and I'm still alive)
Posts: 29
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 4 Times in 4 Posts
My cruise control failed while at highway speed. It just fell out of cruise.

Cause: A toothed sensor ring on the left rear axle cv shaft had failed. A section of the ring fell out. Even though the other three wheels were sending speed data, it was enough to kill the cruise control.

While you are waiting for the switch, pull the rear wheels. A speed ring is located on the wheel end of each CV axle. You can see it just enough to inspect it as you turn the axle.

The rings are pressed on, and develop rust underneath, cracking the ring. New rings are not available in the US. Get one or two from a UK ebay source. Around $14 US. They can be tapped in place with a light hammer.
Avel Du likes this.
kapitand is offline  
#13 Old 03-25-2018
Registered Users
 
ixion's Avatar
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2013 Smart Car in Blue.
Posts: 353
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 0
Thanked 57 Times in 36 Posts
(Thread Starter)
Unhappy UPDATE on Cruise Control Problem

My Cruise Control Saga Continues -

SO FAR - My Indy Mechanic has

1/Checked all the fuses and and Relevant Wiring.

2/ Replaced the Cruise Control Switch Assy.

3/ Changed the K40 for a new one (He happened to have one waiting to co on another SLK) He Then put mine back on the my Car.

4/I am now waiting for Control Module Combo Relay No - 170 545 02 05 (170 545 02 32) Which i've bought second hand and will arrive Wednesday

Indy has said "Very unusual to have Cruise Control Fail & no Fault Codes Seen"

I am not going to let this beat me. But I dread to think of the Hours racked up so far.

Anyone else had a Flash of inspiration about my Problem ??

Regards

Mike



ixion is offline  
#14 Old 05-01-2018
Registered Users
 
ixion's Avatar
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2013 Smart Car in Blue.
Posts: 353
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 0
Thanked 57 Times in 36 Posts
(Thread Starter)
Unhappy My cruise control failure

Re MY CRUISE CONTROL FAILURE

Does anyone with a STAR System know what you can CODE with it in respect of the CRUISE CONTROL

My Chassis No is - WDB1704492F217411

I am still trying to sort this problem and already have spent half a fortune on Labour Costs.

Mike
ixion is offline  
#15 Old 05-27-2018
Registered Users
 
ixion's Avatar
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2013 Smart Car in Blue.
Posts: 353
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 0
Thanked 57 Times in 36 Posts
(Thread Starter)
Cruise Control finally working again.

Fourth visit to Indy who found it was the wire in the main Fuse Box (Fuse 10) was not making a connection.

Not something normally expected.
ixion is offline  
#16 Old 05-27-2018
Registered Users
 
Join Date: Dec 2017
Location: Cape Town
Vehicle: 2009 SLK 2Look
Other Toys: Ford Fiesta Titanium 3Dr, Porsche 944S2
Posts: 292
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 100 Post(s)
Thanks: 3
Thanked 11 Times in 11 Posts
I have cruise control but only checked it the once - it works. I have voice control - that also works. My GPS Navigation also works. My steering wheel buttons work also - All Work! My problem is finding a place to go for the nav, operating the cruise control and voice control for the CD shuttle. And finding some one to phone via my hands free - any ideas?

Thanks - !
Gimme Shelter is offline  
#17 Old 05-27-2018
Registered Users
 
Join Date: Dec 2017
Location: Cape Town
Vehicle: 2009 SLK 2Look
Other Toys: Ford Fiesta Titanium 3Dr, Porsche 944S2
Posts: 292
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 100 Post(s)
Thanks: 3
Thanked 11 Times in 11 Posts
Quote:
Originally Posted by devilman9050 View Post
Hi Ixion,
I'll second what PaPaBear said:

Pull towards: Activate at a previously set speed
Push up: set speed or increase current speed in 1mph increments
push down: decrease speed in 1mph increments
push away: turn off
push stalk in: set speed limiter

https://www.manualslib.com/manual/10...age=137#manual

I'm pretty sure the 320 would be the same as the 230, I can't see why they'd make it any different?

Cheers

Dez
Did some one spot an elephant?
Gimme Shelter is offline  
#18 Old 05-27-2018
Premium Member
 
devilman9050's Avatar
 
Join Date: Sep 2016
Location: Leicester
Vehicle: 2003 SLK230
Other Toys: ML280, CBR600
Posts: 342
Country:
Chats: 0
Mentioned: 53 Post(s)
Tagged: 0 Thread(s)
Quoted: 137 Post(s)
Thanks: 13
Thanked 69 Times in 46 Posts
Garage
Quote:
Originally Posted by Gimme Shelter View Post
Did some one spot an elephant?
An elephant?

Sent from my SM-G950F using Tapatalk

Fancy seeing what your SLK can do on the track, and getting a bit of hazardous driving training?

Come along to the track day at Rockingham on the 9th September 2018:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
devilman9050 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Common and easy to do DAS 'tweaks' Seanhump DAS/STAR Coding 103 08-25-2019 04:55 AM
Adding cruise control to a manual '99 never2late99 SLK R170 General Discussion 7 09-21-2018 04:49 PM
Cruise control r170 200k '98 astarjack SLK R170 General Discussion 1 09-24-2017 07:49 PM
Acronyms, TLA's and other abbreviations Seanhump General Discussion 3 11-20-2014 06:06 PM
Speedtronic to limit valet drivers speed? nmslk General Discussion 9 01-03-2008 07:27 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.