RESOLVED - Vario roof pump stops/starts - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 4Likes
  • 1 Post By jbanks15
  • 2 Post By slksocket
  • 1 Post By jbanks15
 
LinkBack Thread Tools
#1 Old 02-19-2018
Registered Users
 
Join Date: Feb 2018
Location: Hampshire
Vehicle: 2004 slk200 r170 auto
Other Toys: motorcycles
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
(Thread Starter)
RESOLVED - Vario roof pump stops/starts

Hi have a problem with the vario roof pump.Have searched the web for info but can find no
reference to this particular behavior.

The Vario Top open operating sequence:
1 All the side windows are lowered
2 The trunklid is unlocked and opened
3 The top is unlocked and retracted
4 The 2-piece hat shelf is raised, and
the cover sections at the sides are closed
5 The top is lowered into the trunk and
the hat shelf returns to its lowered position.
7 The trunklid is closed and locked
8 The front side windows are raised

On operating the roof switch to open or close the roof, the pump runs for approx 2-3 seconds and stops, the roof moves a few inches, continual operation of the roof switch repeats the process.
Roof switch is illuminated but not flashing. On opening the roof the operation stalls at the end of sequence 5, on further operation of the roof switch the roof appears to be pushed further into the trunk but it cannot as it is bottomed out. Sequence 7+ 8 never completes.
Complete closing of the roof can be accomplished with repeated operation of the roof switch, however now
the front windows cannot be raised by roof switch or window switches.

Have checked fuses, battery voltage, pump relay, door and trunk switches, switch s69/11,pump fluid and leaks.
Any info on why the pump keeps stopping and why the windows do not work?
many thanks.

Last edited by Avel Du; 02-21-2018 at 12:53 AM.
slksocket is offline  
Sponsored Links
Advertisement
 
#2 Old 02-19-2018
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,792
Country:
Chats: 38
Mentioned: 471 Post(s)
Tagged: 5 Thread(s)
Quoted: 6547 Post(s)
Thanks: 3,246
Thanked 11,089 Times in 8,443 Posts
Until the experts jump in, have you checked these 2 troubleshooting guides?

https://www.slkworld.com/slk-r170-cla...leapyfish.html

https://www.slkworld.com/slk-r170-cla...ostic-aid.html
slksocket likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 02-19-2018
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,315
Country:
Chats: 0
Mentioned: 594 Post(s)
Tagged: 0 Thread(s)
Quoted: 913 Post(s)
Thanks: 155
Thanked 520 Times in 481 Posts
I've never heard of these exact symptoms before. Just to be clear, when opening the roof, the pump is intermittent even when you're pulling the switch back constantly? And the red light illuminates constantly?

These are just wild guesses:

1) Bad relay (this can be easily replaced - it's next to the pump).
2) Bad thermo switch in the pump (the pump has a temp sensor to shut the pump off when it detects high heat).

Usually the pump runs continually during the open/close cycle - any stoppage partially through is not expected.

The pump receives constant power on the large Red/Yellow wire - you might start checking there while operating. The solid red wire is the control, it should receive power whenever the control unit wants the pump operated - you might check there next.
efair is offline  
The Following User Says Thank You to efair For This Useful Post:
 
#4 Old 02-20-2018
Registered Users
 
Join Date: Feb 2018
Location: Hampshire
Vehicle: 2004 slk200 r170 auto
Other Toys: motorcycles
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
(Thread Starter)
Thanks for replies, Windows and roof were working fine until after I had the roof half open checking out a water leak with engine off.
When finished I let the roof close under its own weight, upon using roof switch to fully close the roof the problem started.
Have read the trouble shooting guide - really useful.
You have to operate the roof switch each time for the pump to run a few seconds . Have checked the relay, removed cover and cleaned contacts, the pump stops even when cold so don't think its the thermo switch.
Its like there is an over current trip or a large voltage drop perhaps a fault in the N10/3.
Any other idears welcome.
Will check the relay wires today and post back.
slksocket is offline  
#5 Old 02-20-2018
Registered Users
 
Join Date: Feb 2018
Location: Hampshire
Vehicle: 2004 slk200 r170 auto
Other Toys: motorcycles
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 2
Thanked 2 Times in 2 Posts
(Thread Starter)
Just an update - Thanks to efair for suggesting the relay wires.
Roof now working, the cause was a large voltage drop on the terminal crimp to the pump relay coil.
I think what was happening the pump draws a fair bit of current with a drop in voltage this combined with the drop
across the crimp was enough for the relay to drop out.
For the windows I went back to basics and rechecked the fuses this time with a meter
( I did them visually it looked Ok ) and found fuse 9 faulty, this was stopping the roof sequence from completing
and the window motors from working.
jbanks15 and Avel Du like this.
slksocket is offline  
#6 Old 02-20-2018
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,792
Country:
Chats: 38
Mentioned: 471 Post(s)
Tagged: 5 Thread(s)
Quoted: 6547 Post(s)
Thanks: 3,246
Thanked 11,089 Times in 8,443 Posts
Is this forum and its expert members great or what?!!!
Idiot101 likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
R170 Vario Roof pump runs, top inop - FIX/TIP jballhanger SLK R170 General Discussion 13 08-04-2019 03:45 AM
Tweaks and Fixes ccslk General Modifications R171 3 06-22-2017 10:48 AM
r170 vario roof odd issue ii3 SLK R170 General Discussion 23 08-20-2016 02:00 PM
SLK 230 Vario Roof Pump Ramon SLK R170 General Discussion 7 11-12-2012 04:35 PM
Another IC Pump Install rfourt AMGs 4 05-13-2012 01:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.