98 Slk 230 having some major issues. Need help finding the problem - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 1Likes
  • 1 Post By Padgett
 
LinkBack Thread Tools
#1 Old 01-01-2018
Registered Users
 
Join Date: Jun 2014
Location: Miami FL
Vehicle: 1998 SLK 230
Posts: 5
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
98 Slk 230 having some major issues. Need help finding the problem

Hello everyone,

So recently my 1998 slk 230 has been acting up. It has about 120,000miles on it. It all started when the transmission was having a hard time shifting gears. It was having a hard time going from first to second and second to third. It then started not downshifting as well. It has got to the point now where it won't come out of first gear.

As that problem persisted the electrical system seems to be failing. I dont know if its an alternator failure or what. But i have to jump the car almost every time when trying to see what wrong with it. I have checked the battery and had it charged at a near by auto store which they tell me there is no problem with the battery. After driving around for 10 min after getting the battery charged the cars srs, abs lights, check engine lights and the head lights and instrument lights got extremely dim.

I pulled the codes from the car and received these
P0455
P0700
P0715
P0410
P0440
P0560
P1742-62

If anyone has any recommendations to see what the problem is or where i can start looking that would be greatly appreciated. Also if it is electrical would that cause the transmission to act up like that or is that a whole different problem? Any information would help

Thanks in advance
ajmontea is offline  
Sponsored Links
Advertisement
 
#2 Old 01-01-2018
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: SLK350/C200AMG(Bluebadger),MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 23,241
Country:
Chats: 0
Mentioned: 271 Post(s)
Tagged: 0 Thread(s)
Quoted: 2284 Post(s)
Thanks: 1,980
Thanked 1,476 Times in 1,362 Posts
Garage
Trans.
Has the fluid ever been changed?
The fact that they charged the battery and things went wrong again 10mins later may mean the battery.

SLKs need an excellent battery, good is not good enough.

Check fuses.
Check K40.

Are your codes from the full DAS/STAR system?
If not, I suggest getting that done first.

It's possible that you have more than one failure here.

Have a read of the R170 diys. Link near the bottom of my signature.

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is online now  
#3 Old 01-01-2018
Registered Users
 
Join Date: Jun 2014
Location: Miami FL
Vehicle: 1998 SLK 230
Posts: 5
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
The transmission fluid hasnt been changed any time recently or since ive had the car which has been almost three years.

Im not sure if the car got the full DAS/Star system. A friend of mine had one of the computers and connected it through the 16 pin connector on the driver side. We were unable to put it on the 32 pin because he didnt have the connector for that.

Ill start checking all the fuses and K40 relay, a well as change the battery. Im just trying to isolate the problem before taking it to the shop so i dont get robbed!

Thanks for the help!
ajmontea is offline  
 
#4 Old 01-01-2018
6007.us
 
Padgett's Avatar
 
Join Date: Mar 2017
Location: Orlando
Vehicle: '01 SLK320 Lazulithe Blue, '00 SLK230 Bahama Blue (needs interior parts)
Other Toys: Too many others. See web page.
Posts: 2,594
Country:
Chats: 0
Mentioned: 287 Post(s)
Tagged: 0 Thread(s)
Quoted: 573 Post(s)
Thanks: 0
Thanked 157 Times in 144 Posts
OK the below may help with the P0xxx codes but those are just the standard OBD-II codes and not the Merc internal which you need (and I'll bet on 30-40 stored since the battery was disconnected). Really need to see those but just off the top it sounds like a major bus & secondary air pump issues plus a lot of little stuff. Many codes ending in "0" are a generic code referring to a subsystem.

What you need is someone with a Merc DAS/STAR reader (C3 should be fine) or something equal since I suspect you have the 38 pin connector.

Good luck.

ps except from the SM for teaching is permitted under Fair Use.
Attached Files
File Type: pdf DTCCodes170l.pdf (56.0 KB, 8 views)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Padgett is offline  
#5 Old 01-01-2018
Registered Users
 
Join Date: Jun 2014
Location: Miami FL
Vehicle: 1998 SLK 230
Posts: 5
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Thanks, Ill try to get that test done as soon as possible
ajmontea is offline  
#6 Old 01-01-2018
6007.us
 
Padgett's Avatar
 
Join Date: Mar 2017
Location: Orlando
Vehicle: '01 SLK320 Lazulithe Blue, '00 SLK230 Bahama Blue (needs interior parts)
Other Toys: Too many others. See web page.
Posts: 2,594
Country:
Chats: 0
Mentioned: 287 Post(s)
Tagged: 0 Thread(s)
Quoted: 573 Post(s)
Thanks: 0
Thanked 157 Times in 144 Posts
Should mention that the real way to find out what is happening is to run a scanner, record what it found, clear all codes, then see what comes back.
Australian likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Padgett is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
SLK 230 Inspection Checklist slk230_itch SLK R170 General Discussion 56 06-27-2019 11:24 AM
Updrading From SLK 230 R170 to SLK R171 austaccomm Australia 7 12-30-2012 09:44 PM
SLK X 2 (long post) -1- SLK R171 General Discussion 29 04-01-2007 11:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.