Which Microswitch? - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 05-07-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
Which Microswitch?

So This weekend i had a dreaded top problem. My top went down fine, we drove to a drive in, it started to drizzle and so I went to put the top up, and the trunk opened but the top did not go up. when i went to put the trunk back down the button started to blink and the trunk stayed up. The hydraulics are working fine with no leaks, so i know that this is not the problem. That leads to the lock cyclendar in the roof not working correctly(?) or a microswitch. I have the top up manually, but I need to get it fixed an am willing to go to in Indy shop to have it fixed right, i just want to give them something to start with.

first of all could it be a problem with the roof lock actuator getting stuck in the locked position when the top os down?

which Microswitch would give me this problem?

any help would be great so I can cut down on the labor rate of diagnosing the problem with the top. If its something easy I wouldnt mind doing it myself.

Also how would you go about getting the roof to work again automaticly?

As always your help is wonderful.
pemsland is offline  
Sponsored Links
Advertisement
 
#2 Old 05-07-2013
MrG
Registered Users
 
Join Date: Aug 2011
Location: Texas
Vehicle: Black '02 SLK320
Other Toys: F250 4x4 Power Stroke Diesel, 22' boat
Posts: 246
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 56
Thanked 53 Times in 35 Posts
Garage
I'd start with the 'trunk open' switch. It's fairly easy to get to on the right hand side by the tail light.
MrG is offline  
#3 Old 05-07-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
Yea but if that one didnt work, then the top wouldnt go down also right?
pemsland is offline  
 
#4 Old 05-07-2013
MrG
Registered Users
 
Join Date: Aug 2011
Location: Texas
Vehicle: Black '02 SLK320
Other Toys: F250 4x4 Power Stroke Diesel, 22' boat
Posts: 246
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 56
Thanked 53 Times in 35 Posts
Garage
It would have if the switch failed on that cycle. I assume all was working fine until you put the top down?
MrG is offline  
#5 Old 05-07-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
Well sparadocically it had issues going down, but I attributed those to the microswitches in the roof and greased those and seemed to work..

How do I test that switch now with the top manually up?

Thanks for the good insight.
pemsland is offline  
#6 Old 05-07-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
becuase at first the top just had some sparodic issues going down, and never going up, then i lubed the roof microswitches, and then twice it had the issue of not coming back up, the second being the time that i had to do it manually.
pemsland is offline  
#7 Old 05-07-2013
MrG
Registered Users
 
Join Date: Aug 2011
Location: Texas
Vehicle: Black '02 SLK320
Other Toys: F250 4x4 Power Stroke Diesel, 22' boat
Posts: 246
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 56
Thanked 53 Times in 35 Posts
Garage
Sorry. I assumed this was the first problem you had
MrG is offline  
#8 Old 05-08-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
so anyone have an idea of where to start?
pemsland is offline  
#9 Old 05-08-2013
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,334
Country:
Chats: 0
Mentioned: 599 Post(s)
Tagged: 0 Thread(s)
Quoted: 919 Post(s)
Thanks: 155
Thanked 527 Times in 487 Posts
I'd start by cleaning all the microswitches.
efair is offline  
#10 Old 05-08-2013
Premium Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: Daily driver 1998 SLK230 243,xxx miles
Posts: 3,505
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Thanks: 960
Thanked 527 Times in 415 Posts
Garage
Check the wiring for things like this https://www.slkworld.com/slk-r170-cla...d-my-roof.html
leapyfish is offline  
#11 Old 05-16-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
Took it in to my Indy guy, and he hooked it up to the computer. There was just a simple fauly code for low voltage. He said ti was caused by the top using to much power with the engine not running, which causes random fault to keep the top from working. i never got the exact code number, but I have used it now for a week and no problems since then. It was a lot cheaper than replacing all microswitches and still having problem.
pemsland is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
r170 roof troubleshooting question: hydraulic pump silent silver99slk230 SLK R170 General Discussion 10 02-14-2019 10:43 PM
Partition MicroSwitch Problem error "close trunk partition" Th3120ck SLK R171 General Discussion 23 07-02-2013 07:45 PM
boot closure microswitch Pucklephil SLK R171 General Discussion 2 06-29-2010 06:04 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.