bas esp/ abs/speedo - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 3Likes
  • 2 Post By jbanks15
  • 1 Post By Turdo2
 
LinkBack Thread Tools
#1 Old 12-21-2017
Registered Users
 
Join Date: Dec 2017
Location: texas
Vehicle: 2001 320 slk
Posts: 14
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
bas esp/ abs/speedo

well guys the bas esp and abs light is on , the speedo quit working, cleaned the speedo sending ring , and it worked for a bloock and quit, just changed the left and right sensors, no change..also have the po500 light on , it did not change either...pulled the brake switch...brake lights work and the other plug seems to operate when the sensor is pressed...pressing it opens one set, and closes the other....ideas?what else would give a 500 code plus bas esp and abs light?....thanks...
Sponsored Links
Advertisement
 
#2 Old 12-21-2017
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,757
Country:
Chats: 38
Mentioned: 471 Post(s)
Tagged: 5 Thread(s)
Quoted: 6545 Post(s)
Thanks: 3,246
Thanked 11,084 Times in 8,438 Posts
Send up the bat signal!

@Mn car guy
@efair
@stu32
@savcom
@Turdo2
@Padgett
Avel Du and RLander like this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 12-21-2017
Premium Member

 
Turdo2's Avatar
 
Join Date: Apr 2013
Location: Kansas
Vehicle: 1999 SLK 5.4 M113 V8 6-speed Manual
Other Toys: Ram 2500, '74 Plymouth Duster, W140 300 SE
Posts: 1,360
Country:
Chats: 0
Mentioned: 434 Post(s)
Tagged: 1 Thread(s)
Quoted: 361 Post(s)
Thanks: 0
Thanked 87 Times in 77 Posts
Garage
Sounds straight forward to me - speed sensor issue.

there are a couple of finicky little parts inside the assembly that bolts to the transmission - alignment of that little cog is also pretty critical. did you pull enough of the assembly out to look at the condition of the gear?
jbanks15 likes this.
Turdo2 is offline  
 
#4 Old 12-21-2017
Registered Users
 
Join Date: Dec 2017
Location: texas
Vehicle: 2001 320 slk
Posts: 14
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
manual 6 speed..does it have a sensor too?
#5 Old 12-21-2017
Registered Users
 
Join Date: Dec 2017
Location: texas
Vehicle: 2001 320 slk
Posts: 14
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Send up the bat signal!....?
#6 Old 12-21-2017
Premium Member
 
savcom's Avatar
 
Join Date: Nov 2015
Location: Wiltshire, UK
Vehicle: 2002 Blue SLK320 known as 'Silkie"
Other Toys: 2010 Grey BMW F10 528i
Posts: 2,574
Country:
Chats: 0
Mentioned: 491 Post(s)
Tagged: 0 Thread(s)
Quoted: 609 Post(s)
Thanks: 167
Thanked 299 Times in 242 Posts
Garage
Send a message via Skype™ to savcom
Quote:
Originally Posted by [email protected] View Post
Send up the bat signal!....?
Nearest I could find to a Mercedes-shaped searchlight....



Quote:
Originally Posted by [email protected] View Post
manual 6 speed..does it have a sensor too?
There isn't a direct signal to measure on the instrument cluster when the BAS/ASR light illuminates - that's done as a signal over the CAN bus. I have a copy of the wiring diagram and diagnostic info for the BAS/ESP module which should help you piece together what's happening and what has failed. PM me your email address and I'll drop the details to you right away. Please be quick - I'm not near my computer from Saturday for a week. (Happy Holidays by the way)

Savcom

Now : Silkie - 2002 Lazulithe Blue Mercedes Benz SLK320
Also
: 2011 Sophisto Grey BMW F10 528i SE


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Brings a smile to my face whenever I drive her



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Previous :
1965 Triumph Herald 12/50 ... 1972 Austin 1300 ... 1982 Volvo 265GLE ...

1987 Volkswagen Caravelle ... 1997 Rover 214si ... 2002 BMW E39 530D

If I've helped you sort your problem(s) out, click the 'Thanks' button on the right hand side under my signature.
savcom is offline  
#7 Old 01-10-2018
Registered Users
 
Join Date: Dec 2017
Location: texas
Vehicle: 2001 320 slk
Posts: 14
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
wheel speed sensor, speddometer, po500

Guys, still have a p0500 a code on the 2001 320...any more ideas, changed the the two front ones checked both back ones..they had about 19 ohms each and were the same...any other connectors before they go where ever? do they have a relay or what else would make the vss on the md 808 show vss equals zero?....
#8 Old 01-10-2018
TFP
Registered Users
 
TFP's Avatar
 
Join Date: Mar 2016
Location: Wales UK
Vehicle: 02 SLK32 AMG
Posts: 512
Country:
Chats: 0
Mentioned: 12 Post(s)
Tagged: 0 Thread(s)
Quoted: 151 Post(s)
Thanks: 37
Thanked 72 Times in 65 Posts
Garage
Assuming you've gone through the suggestions in your other thread ................

Have you you gone through a drive cycle after clearing all the codes with your scanner ?
Firstly check that all the connections at the vehicle speed sensors are solid, clear all the codes, and then take her out for some mixed driving.
Gently at first, and if the CEL hasn't come back on and she's properly warmed up, give her some beans.

Oh, and a fully charged battery is a must on the R170
TFP is offline  
#9 Old 01-11-2018
Registered Users
 
Join Date: Dec 2017
Location: texas
Vehicle: 2001 320 slk
Posts: 14
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
battery fully charged, trying to clear the code so i can attempt a drive cycle..without speed, i dont think it can do a drive cycle....id like to find where the speed sensors lead so i can furthur trouble shoot it....
#10 Old 01-12-2018
Registered Users
 
Join Date: Jul 2017
Location: Lanikai Hawaii
Vehicle: 1999 SLK 230 Bahama Blue
Posts: 62
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 12
Thanked 4 Times in 4 Posts
I had the exact same thing with the same code and it turned out to be the K40 after trying everything under the sun including inspecting and re-soldering (looked perfect) the old K40 ... I went to an indie for the diagnostic after replacing abs sensors pump etc.
Naja is offline  
#11 Old 01-13-2018
Registered Users
 
Join Date: Dec 2017
Location: texas
Vehicle: 2001 320 slk
Posts: 14
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
well, i can shotgun it by buying another k 40,,,any one know what functions the other two ecu s next to the k 40 perform, i understand at least one cannot be just changed with out programing..is that true?
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Is it the ESP Module? 2nd Opinion Appreciated Waiheke Tires, Wheels, Brakes & Suspension 8 04-02-2019 06:17 PM
3 malfunctions: ABS, BAS and ESP with power steering getting unserviceable benlapi SLK R171 General Discussion 24 08-18-2017 04:54 PM
BAS ESP Light ian320 SLK R170 General Discussion 8 11-05-2014 11:19 AM
ESP Defective, BAS Defective fleep SLK R171 General Discussion 12 04-20-2010 06:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.