P0410 code help...Fuse and relay locations for 2001 SLK320 - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 6Likes
  • 1 Post By Australian
  • 1 Post By stu32
  • 4 Post By AndyW
 
LinkBack Thread Tools
#1 Old 12-20-2017
Registered Users
 
AndyW's Avatar
 
Join Date: Dec 2014
Location: Washington, USA
Vehicle: 2001 SLK320
Other Toys: 2008 335i
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 30
Thanked 4 Times in 4 Posts
(Thread Starter)
P0410 code help...Fuse and relay locations for 2001 SLK320

So I got a 0410 code - secondary air pump issue. And in trying to start simplest (fuse) to most expensive (entire air pump), I discovered I could not find a working writeup on the fuse or relay for the secondary air pump on an slk320.

So, after scouring this forum and others I have discovered several things:

1. There are differences between the SLK320 and 230 fuse boxes (for understandable reasons)
2. There is more data on fuses for the 230 than 320 (again, understandable due to population)
3. A lot of the helpful pics and diagrams are no longer visible due to Dropbox being ridiculous.

As such, would appreciate help in mapping my fuses. The first one is easy...it is the traditional box on the drivers side (US) in the engine bay and still has the card. Pic below.



The second one in the drivers side dashboard is also easy but definitely doesn't have the secondary air pump fuse.

I did open the wiring box on the passenger side, but no card and would like to verify the circled items(hoping they are the secondary air pump fuse and relay!). Pic below.



Any help appreciated. Thx!
AndyW is offline  
The Following User Says Thank You to AndyW For This Useful Post:
Sponsored Links
Advertisement
 
#2 Old 12-20-2017
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,453
Country:
Chats: 38
Mentioned: 466 Post(s)
Tagged: 5 Thread(s)
Quoted: 6510 Post(s)
Thanks: 3,233
Thanked 11,057 Times in 8,411 Posts
https://www.slkworld.com/165914-post13.html

https://www.google.com/search?q=merc...ih=789&dpr=1.2


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
The Following User Says Thank You to jbanks15 For This Useful Post:
#3 Old 12-20-2017
6007.us
 
Padgett's Avatar
 
Join Date: Mar 2017
Location: Orlando
Vehicle: '01 SLK320 Lazulithe Blue, '00 SLK230 Bahama Blue (needs interior parts)
Other Toys: Too many others. See web page.
Posts: 2,589
Country:
Chats: 0
Mentioned: 287 Post(s)
Tagged: 0 Thread(s)
Quoted: 569 Post(s)
Thanks: 0
Thanked 157 Times in 144 Posts
Isn't the air pump the 40A fuse in the problematic relay box ? Think is the one you circled.
Attached Images
File Type: jpg relaybox.jpg (68.6 KB, 29 views)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Padgett is offline  
The Following 2 Users Say Thank You to Padgett For This Useful Post:
 
#4 Old 12-21-2017
Registered Users
 
AndyW's Avatar
 
Join Date: Dec 2014
Location: Washington, USA
Vehicle: 2001 SLK320
Other Toys: 2008 335i
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 30
Thanked 4 Times in 4 Posts
(Thread Starter)
Quote:
Originally Posted by Padgett View Post
Isn't the air pump the 40A fuse in the problematic relay box ? Think is the one you circled.
Awesome...that pic is the first confirmation I have seen for those fuses, thx! Do you know where the associated relay is?

EDIT: Disregard my question...I see the relay is also on that pic. Thx very much!
AndyW is offline  
#5 Old 12-21-2017
Premium Member
 
Australian's Avatar
 
Join Date: Sep 2012
Location: South Australia
Vehicle: SLK 320 2002
Other Toys: Just a shopping trolley.
Posts: 561
Country:
Chats: 0
Mentioned: 214 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Thanks: 13
Thanked 50 Times in 49 Posts
Just to share my experience with my P0410 code. Mine turned out to be poor solder joints on the K40 relay. Just alongside the relay mentioned.

Good luck with it.
Idiot101 likes this.
Australian is offline  
The Following User Says Thank You to Australian For This Useful Post:
#6 Old 12-21-2017
Registered Users
 
Join Date: Sep 2017
Location: North Wales
Vehicle: SLK32 AMG 2002 Brilliant Silver
Other Toys: Ginetta G32
Posts: 846
Country:
Chats: 0
Mentioned: 344 Post(s)
Tagged: 0 Thread(s)
Quoted: 92 Post(s)
Thanks: 17
Thanked 68 Times in 57 Posts
Garage
Drop the whole relay board out as per Padgetts picture (just unplug wiring and it lifts out) and re-new the soldering on the board as mentioned above, also clean relay contacts.
Hopefully all will be good when you put back together.
Avel Du likes this.
stu32 is offline  
The Following 2 Users Say Thank You to stu32 For This Useful Post:
#7 Old 12-21-2017
Registered Users
 
AndyW's Avatar
 
Join Date: Dec 2014
Location: Washington, USA
Vehicle: 2001 SLK320
Other Toys: 2008 335i
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 30
Thanked 4 Times in 4 Posts
(Thread Starter)
Thx, All. The solder joints looked to be generally OK but a couple looked a little cracked, so I re-soldered all the major ones and the resistor ones...and it is definitely working now. I can hear the secondary air pump clearly when the engine starts. (wondering if it has been out a while). I love this forum.
AndyW is offline  
#8 Old 07-07-2019
Registered Users
 
Join Date: Jun 2019
Location: Indiana
Vehicle: 2001 SLK 320
Posts: 1
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Send a message via Skype™ to slong@kiva.net
Hello Gents,
So I too have these issues but mines a bit different. add 12 volts to Pumps makes a healthy pump sound. Fuse is fine and it I tap the contact on the relay the pump works fine. But why is my pump not running while the car is running and I get the dreaded p0410 alone with the p0100. Mas air flow sensor. I cleaned the MAS airflow twice. Solder joints look fine by the way. What am I missing?

Thanks,
#9 Old 07-07-2019
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,453
Country:
Chats: 38
Mentioned: 466 Post(s)
Tagged: 5 Thread(s)
Quoted: 6510 Post(s)
Thanks: 3,233
Thanked 11,057 Times in 8,411 Posts
Quote:
Originally Posted by [email protected] View Post
Hello Gents,
So I too have these issues but mines a bit different. add 12 volts to Pumps makes a healthy pump sound. Fuse is fine and it I tap the contact on the relay the pump works fine. But why is my pump not running while the car is running and I get the dreaded p0410 alone with the p0100. Mas air flow sensor. I cleaned the MAS airflow twice. Solder joints look fine by the way. What am I missing?

Thanks,
this thread is at least 2 years old
always better to start a new thread

Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Florida!

Join the gang! Your 1st thread should be your introduction so we can welcome you properly so post an introduction in the ‘New members introduce yourself here’ section. Click this: https://www.slkworld.com/new-members-...yourself-here/

If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable or to ‘edit’, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members as we welcomed you to obtain your needed posts to PM/edit. You can always pm a moderator.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment or use the 'quote' button so we know who you are asking or replying to or referencing.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
FREE!! Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
https://www.slkworld.com/vehicle-data...-datacard.html

Thank you
Jeff
Founding Member/Super Moderator


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
R171 Fuse and relay locations and pics and descriptions jbanks15 SLK R171 Class DIY 14 04-11-2019 07:04 PM
Fitting Daytime Running Lights (DRLs) plus LED fogs and how to wire them. mike350 SLK R171 Class DIY 14 10-30-2017 01:53 AM
Secondary air pump problem?? trixter SLK R171 General Discussion 183 06-10-2016 04:26 PM
K40 Relay Module - Fuse F5 Brenkenobi SLK R170 General Discussion 5 06-30-2015 06:03 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.