1998 SLK230 in limp mode - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 12Likes
Reply
 
LinkBack Thread Tools
#1 Old 11-21-2017
Registered Users
 
cbrbo's Avatar
 
Join Date: Nov 2017
Location: Seminole, Fl
Vehicle: 1998 SLK 230
Other Toys: Bike, Boats
Posts: 30
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
(Thread Starter)
1998 SLK230 in limp mode

I have a R170 stuck in limp mode had the codes pulled
013 Speed Sensor N3 Y3/611
09 Speed Sensor N3 Y3/611

65 Control Module N15 /3
161 Control Module N15 /3.

All the research I have done points to the plate and 13 pin connector, I have searched the forums and it seems to be the solution.

I was wondering where is a good place to get the parts from for a fair price.
I am looking at this one and also was wondering what others have used.

https://www.fcpeuro.com/products/mer...on-service-kit

@Mn car guy
@efair
@stu32
@savcom
@Turdo2


Bob
1998 SLK 230
114k automatic
jbanks15, LIL DON SLK and Avel Du like this.
cbrbo is offline  
Sponsored Links
Advertisement
 
#2 Old 11-21-2017
Premium Member
 
savcom's Avatar
 
Join Date: Nov 2015
Location: Wiltshire, UK
Vehicle: 2002 Blue SLK320 known as 'Silkie"
Other Toys: 2010 Grey BMW F10 528i
Posts: 2,575
Country:
Chats: 0
Mentioned: 493 Post(s)
Tagged: 0 Thread(s)
Quoted: 610 Post(s)
Thanks: 167
Thanked 299 Times in 242 Posts
Garage
Send a message via Skype™ to savcom
Quote:
Originally Posted by cbrbo View Post
I have a R170 stuck in limp mode had the codes pulled
013 Speed Sensor N3 Y3/611
09 Speed Sensor N3 Y3/611

65 Control Module N15 /3
161 Control Module N15 /3.

All the research I have done points to the plate and 13 pin connector, I have searched the forums and it seems to be the solution.

I was wondering where is a good place to get the parts from for a fair price.
I am looking at this one and also was wondering what others have used.

https://www.fcpeuro.com/products/mer...on-service-kit

@Mn car guy
@efair
@stu32
@savcom
@Turdo2


Bob
1998 SLK 230
114k automatic
114K and no transmission fluid change? If your dipstick cover is black plastic then the odds are the fluid has not been changed at all. That kit looks fine. It's not worth getting a cheap kit - you'll end up having to do the job again in 20,000 miles or so. The kit you show is not a bad price and providing you can get the car on a ramp - or better still a full car lift - then it's not too difficult a job to do. Also, check the transmission fluid isn't wicking along the cable and interfering with the transmission control unit too. You can check this by looking behind the metal panel in the passenger footwell and making sure the cables to N15 are bone dry. If the fluid has got into the controller you can disconnect it, open it and clean it out. You should be ok, but these have been known to failas a result of fluid ingress. Don't use brake cleaner on the cable, TCU or plug if you do find it is wicking because brake cleaner will soften the insulation on the cables and could dissolve the case of the TCU. Use a proper electrical contact cleaner instead and drain the dirty fluid away thoroughly before re-assembling it.

You should also get a dipstick for the fluid so you know when you've added enough when you refill as overfilling the box will not help you!!

Hope this helps - and you get it all sorted.
jbanks15, Idiot101 and stu32 like this.

Now : Silkie - 2002 Lazulithe Blue Mercedes Benz SLK320
Also
: 2011 Sophisto Grey BMW F10 528i SE


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Brings a smile to my face whenever I drive her



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Previous :
1965 Triumph Herald 12/50 ... 1972 Austin 1300 ... 1982 Volvo 265GLE ...

1987 Volkswagen Caravelle ... 1997 Rover 214si ... 2002 BMW E39 530D

If I've helped you sort your problem(s) out, click the 'Thanks' button on the right hand side under my signature.
savcom is offline  
#3 Old 11-21-2017
Registered Users
 
cbrbo's Avatar
 
Join Date: Nov 2017
Location: Seminole, Fl
Vehicle: 1998 SLK 230
Other Toys: Bike, Boats
Posts: 30
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
(Thread Starter)
That does help a lot, is there a part or list vendor you would recommend? I really only want to do this as few times as possible.

Thanks
Bob
LIL DON SLK and savcom like this.
cbrbo is offline  
 
#4 Old 11-21-2017
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,888
Country:
Chats: 38
Mentioned: 472 Post(s)
Tagged: 5 Thread(s)
Quoted: 6560 Post(s)
Thanks: 3,246
Thanked 11,096 Times in 8,449 Posts
fyi Savcom is in the UK


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#5 Old 11-21-2017
Premium Member
 
savcom's Avatar
 
Join Date: Nov 2015
Location: Wiltshire, UK
Vehicle: 2002 Blue SLK320 known as 'Silkie"
Other Toys: 2010 Grey BMW F10 528i
Posts: 2,575
Country:
Chats: 0
Mentioned: 493 Post(s)
Tagged: 0 Thread(s)
Quoted: 610 Post(s)
Thanks: 167
Thanked 299 Times in 242 Posts
Garage
Send a message via Skype™ to savcom
Quote:
Originally Posted by cbrbo View Post
That does help a lot, is there a part or list vendor you would recommend? I really only want to do this as few times as possible.

Thanks
Bob
That kit has all you need - and the dipstick link I sent you is also from the same company. Providing the parts are OEM that should be good enough.

There's a walk-through of what you need to do on PelicanParts. You may need to look up how to change the plate in addition to this..

Now : Silkie - 2002 Lazulithe Blue Mercedes Benz SLK320
Also
: 2011 Sophisto Grey BMW F10 528i SE


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Brings a smile to my face whenever I drive her



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Previous :
1965 Triumph Herald 12/50 ... 1972 Austin 1300 ... 1982 Volvo 265GLE ...

1987 Volkswagen Caravelle ... 1997 Rover 214si ... 2002 BMW E39 530D

If I've helped you sort your problem(s) out, click the 'Thanks' button on the right hand side under my signature.
savcom is offline  
#6 Old 11-21-2017
Registered Users
 
Join Date: Sep 2017
Location: North Wales
Vehicle: SLK32 AMG 2002 Brilliant Silver
Other Toys: Ginetta G32
Posts: 846
Country:
Chats: 0
Mentioned: 347 Post(s)
Tagged: 0 Thread(s)
Quoted: 92 Post(s)
Thanks: 17
Thanked 68 Times in 57 Posts
Garage
Also have a look at this thread but I think confirms everything @savcom has already mentioned but with the addition of the K40 relay module?

https://www.slkworld.com/slk-r170-gen...tor-plate.html
jbanks15 and LIL DON SLK like this.
stu32 is offline  
The Following User Says Thank You to stu32 For This Useful Post:
#7 Old 11-21-2017
Registered Users
 
cbrbo's Avatar
 
Join Date: Nov 2017
Location: Seminole, Fl
Vehicle: 1998 SLK 230
Other Toys: Bike, Boats
Posts: 30
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
(Thread Starter)
I odered the kit, I am looking forward to learning all about this car. After tranny is fixed I will look at performance mods.
Bob
LIL DON SLK likes this.
cbrbo is offline  
#8 Old 11-21-2017
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,888
Country:
Chats: 38
Mentioned: 472 Post(s)
Tagged: 5 Thread(s)
Quoted: 6560 Post(s)
Thanks: 3,246
Thanked 11,096 Times in 8,449 Posts
Quote:
Originally Posted by cbrbo View Post
I odered the kit, I am looking forward to learning all about this car. After tranny is fixed I will look at performance mods.
Bob
not a lot of performance mods for your 230
pulley is probably the only one


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#9 Old 11-21-2017
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,321
Country:
Chats: 0
Mentioned: 597 Post(s)
Tagged: 0 Thread(s)
Quoted: 914 Post(s)
Thanks: 155
Thanked 522 Times in 482 Posts
I buy a lot from FCP, they're good.

Right kit, but as noted a failed TCU might need replacement if it's spoiled by a wicking pilot bushing.
efair is online now  
#10 Old 11-21-2017
Premium Member

 
Turdo2's Avatar
 
Join Date: Apr 2013
Location: Kansas
Vehicle: 1999 SLK 5.4 M113 V8 6-speed Manual
Other Toys: Ram 2500, '74 Plymouth Duster, W140 300 SE
Posts: 1,362
Country:
Chats: 0
Mentioned: 437 Post(s)
Tagged: 1 Thread(s)
Quoted: 361 Post(s)
Thanks: 0
Thanked 87 Times in 77 Posts
Garage
I just covered a bunch of transmission stuff on my last post in my SLK430 thread. I had limp-home mode issues as well.

https://www.slkworld.com/performance-...8-swap-11.html

If you are stuck in 2nd gear, you will need to get your TCU codes erased or it will still be stuck in Limp mode.
Turdo2 is offline  
#11 Old 11-22-2017
Registered Users
 
Join Date: Mar 2016
Location: New South Wales Australia
Vehicle: 1999 SLK230
Other Toys: clarinet
Posts: 69
Country:
Chats: 1
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 1
Thanked 10 Times in 9 Posts
Hi
I have the same issue with my car. I cleaned the connector a few days ago but it was not right. had the codes checked and cleared at the local garage today and the car was good for a short time. I think the codes have come back. One code I had which you dont mention is P0715. I think its telling my that the conductor plate has reached its end of life.
Im going to find a suitably priced kit to change the plate and change the sensors at the same time.
bryn is offline  
#12 Old 11-22-2017
Premium Member

 
Turdo2's Avatar
 
Join Date: Apr 2013
Location: Kansas
Vehicle: 1999 SLK 5.4 M113 V8 6-speed Manual
Other Toys: Ram 2500, '74 Plymouth Duster, W140 300 SE
Posts: 1,362
Country:
Chats: 0
Mentioned: 437 Post(s)
Tagged: 1 Thread(s)
Quoted: 361 Post(s)
Thanks: 0
Thanked 87 Times in 77 Posts
Garage
Quote:
Originally Posted by bryn View Post
Hi
I have the same issue with my car. I cleaned the connector a few days ago but it was not right. had the codes checked and cleared at the local garage today and the car was good for a short time. I think the codes have come back. One code I had which you dont mention is P0715. I think its telling my that the conductor plate has reached its end of life.
Im going to find a suitably priced kit to change the plate and change the sensors at the same time.
P0715 was my issue. conductor plate was replaced, codes cleared and all has been well after about 100 miles.
Turdo2 is offline  
#13 Old 11-22-2017
Premium Member
 
savcom's Avatar
 
Join Date: Nov 2015
Location: Wiltshire, UK
Vehicle: 2002 Blue SLK320 known as 'Silkie"
Other Toys: 2010 Grey BMW F10 528i
Posts: 2,575
Country:
Chats: 0
Mentioned: 493 Post(s)
Tagged: 0 Thread(s)
Quoted: 610 Post(s)
Thanks: 167
Thanked 299 Times in 242 Posts
Garage
Send a message via Skype™ to savcom
Quote:
Originally Posted by bryn View Post
Hi
I have the same issue with my car. I cleaned the connector a few days ago but it was not right. had the codes checked and cleared at the local garage today and the car was good for a short time. I think the codes have come back. One code I had which you dont mention is P0715. I think its telling my that the conductor plate has reached its end of life.
Im going to find a suitably priced kit to change the plate and change the sensors at the same time.
It's not hard to put together a kit from different suppliers to be honest - just make sure the parts are OEM Cheap pilot bushings have a habit of failing before they're due and that's really a poor economy. I was lucky in that we had the use of a garage with a full car lift and proper cleaning facilities so we were able to get every part of the sump pan cleaned out. One other thing - you may find a magnet fitted in the sump. Clean that off if it has any swarf on it (if you've none then very happy days!!!)

Looks like you can ship the kit from eBay UK, so I see.

Now : Silkie - 2002 Lazulithe Blue Mercedes Benz SLK320
Also
: 2011 Sophisto Grey BMW F10 528i SE


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Brings a smile to my face whenever I drive her



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Previous :
1965 Triumph Herald 12/50 ... 1972 Austin 1300 ... 1982 Volvo 265GLE ...

1987 Volkswagen Caravelle ... 1997 Rover 214si ... 2002 BMW E39 530D

If I've helped you sort your problem(s) out, click the 'Thanks' button on the right hand side under my signature.
savcom is offline  
#14 Old 11-29-2017
Registered Users
 
cbrbo's Avatar
 
Join Date: Nov 2017
Location: Seminole, Fl
Vehicle: 1998 SLK 230
Other Toys: Bike, Boats
Posts: 30
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
(Thread Starter)
I got the kit and now need to get the car in the air and drop the pan. After I pull the valve body is there a need to disassemble it and clean it thoroughly or just cleanup the solenoids and replace the controller board. I really only want to do this as few times as possible.

Getting excited about getting my baby on the road.

Bob
cbrbo is offline  
#15 Old 11-29-2017
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,321
Country:
Chats: 0
Mentioned: 597 Post(s)
Tagged: 0 Thread(s)
Quoted: 914 Post(s)
Thanks: 155
Thanked 522 Times in 482 Posts
Just have a clean work table to work on... You can't really disassemble the valve body other than removing the CP.
efair is online now  
#16 Old 01-03-2018
Registered Users
 
cbrbo's Avatar
 
Join Date: Nov 2017
Location: Seminole, Fl
Vehicle: 1998 SLK 230
Other Toys: Bike, Boats
Posts: 30
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
(Thread Starter)
SLK230 repair continues

I broke down and took the car to a local mechanic to have the conductor plate installed.
He called and said fluid was really dirty and that the TCU also should be replaced as the plate didn't fix the issue.
Lucky for me he happen to have a couple TCU units in his shop.
I am hoping this will fix the transmission limp mode issue and I can get to enjoy the car.

Bob
jbanks15 likes this.
cbrbo is offline  
#17 Old 01-03-2018
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,888
Country:
Chats: 38
Mentioned: 472 Post(s)
Tagged: 5 Thread(s)
Quoted: 6560 Post(s)
Thanks: 3,246
Thanked 11,096 Times in 8,449 Posts
Then you can attend our next meet in April!


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#18 Old 01-03-2018
Premium Member

 
Turdo2's Avatar
 
Join Date: Apr 2013
Location: Kansas
Vehicle: 1999 SLK 5.4 M113 V8 6-speed Manual
Other Toys: Ram 2500, '74 Plymouth Duster, W140 300 SE
Posts: 1,362
Country:
Chats: 0
Mentioned: 437 Post(s)
Tagged: 1 Thread(s)
Quoted: 361 Post(s)
Thanks: 0
Thanked 87 Times in 77 Posts
Garage
Quote:
Originally Posted by cbrbo View Post
I broke down and took the car to a local mechanic to have the conductor plate installed.
He called and said fluid was really dirty and that the TCU also should be replaced as the plate didn't fix the issue.
Lucky for me he happen to have a couple TCU units in his shop.
I am hoping this will fix the transmission limp mode issue and I can get to enjoy the car.

Bob
did he happen to try those other ones to see if they fixed the problem???
Turdo2 is offline  
#19 Old 01-03-2018
Registered Users
 
cbrbo's Avatar
 
Join Date: Nov 2017
Location: Seminole, Fl
Vehicle: 1998 SLK 230
Other Toys: Bike, Boats
Posts: 30
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 4
Thanked 0 Times in 0 Posts
(Thread Starter)
#Turdo2 What other things are you referencing?
cbrbo is offline  
#20 Old 01-03-2018
Premium Member

 
Turdo2's Avatar
 
Join Date: Apr 2013
Location: Kansas
Vehicle: 1999 SLK 5.4 M113 V8 6-speed Manual
Other Toys: Ram 2500, '74 Plymouth Duster, W140 300 SE
Posts: 1,362
Country:
Chats: 0
Mentioned: 437 Post(s)
Tagged: 1 Thread(s)
Quoted: 361 Post(s)
Thanks: 0
Thanked 87 Times in 77 Posts
Garage
Quote:
Originally Posted by cbrbo View Post
#Turdo2 What other things are you referencing?
If the mechanic had a couple more TCU's, why didn't he put them in your car and see if that solved the issue?
Turdo2 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Selling my 1998 slk230 OEM headlights / OEM bumper park light / OEM side marker light (turn signals) afr00t SLK Parts For Sale 1 04-17-2012 03:23 PM
WHY ESP MALFUNCTION and went into LIMP MODE..on and off mrl0n3ly714 SLK R171 General Discussion 1 07-29-2011 12:56 PM
currently in limp home mode quikdraw SLK R170 General Discussion 7 09-30-2010 08:12 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.