Problem with my new to me slk320 - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 2Likes
  • 1 Post By leapyfish
  • 1 Post By RobertP
 
LinkBack Thread Tools
#1 Old 04-25-2013
Registered Users
 
Join Date: Apr 2013
Location: North Carolina
Vehicle: 2001 SLK320
Posts: 48
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 7 Times in 6 Posts
(Thread Starter)
Problem with my new to me slk320

Hello all.
I'm sad to say this is my first introduction post and I have a problem. Quick background. I purchased my first MB SLK 320 last week from a private seller in VA. I live in NC. It's a 01 sport. Decent looking, 103k miles, ran and drove great. Here's comes my problem soon after arriving home the next day on a short drive near the house the CEL came on and the car, while still driveable, has a bad miss. I pulled the codes and they are as follows 301,302,303,304 cly misfires, 300 mulitiple cly misfires and 410 secondary air system. I did a quick search and it looks as if I have a failed coil pack or several. What is a good way starting to diagnose what my issues are and determing which coil packs are bad. Thanks in advance for your help.
Randy
randy993 is offline  
Sponsored Links
Advertisement
 
#2 Old 04-25-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,824
Country:
Chats: 38
Mentioned: 471 Post(s)
Tagged: 5 Thread(s)
Quoted: 6551 Post(s)
Thanks: 3,246
Thanked 11,090 Times in 8,444 Posts
Randy,

Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’.

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.

Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response and only once. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message) - capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread, make a post, click on the ‘paper clip’ or go to ‘advanced’ and then ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’!
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Also vote or enter our Ride of the Month competition: https://www.slkworld.com/rotm-submissions-voting/

Thank you
Jeff
Moderator/Founding Member


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 04-25-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,824
Country:
Chats: 38
Mentioned: 471 Post(s)
Tagged: 5 Thread(s)
Quoted: 6551 Post(s)
Thanks: 3,246
Thanked 11,090 Times in 8,444 Posts
start with a search:

https://www.slkworld.com/search.php?searchid=1331601

others will chime in

look in the r170 general discussion hits in the search


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
 
#4 Old 04-25-2013
Premium Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: Daily driver 1998 SLK230 243,xxx miles
Posts: 3,505
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Thanks: 960
Thanked 527 Times in 415 Posts
Garage
Welcome,
You should download the Crossfire service manual in my signature, there is a troubleshooting guide in it.
Idiot101 likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Vario roof
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

R170 & R171
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
SLK 230 320 32AMG
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
leapyfish is offline  
#5 Old 04-25-2013
Registered Users
 
Join Date: Apr 2013
Location: North Carolina
Vehicle: 2001 SLK320
Posts: 48
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 7 Times in 6 Posts
(Thread Starter)
I had a little time before work and did a google search of my codes and issues. Of course it's nothing definite. Looks like it could be a MAF sensor or cat converter. I was hoping for some direction prior to just replacing parts.
Thanks for the link to the manual, although I can't see it yet. Not 5 posts yet. Yhis will make 4.
Randy
randy993 is offline  
#6 Old 04-25-2013
Registered Users
 
Join Date: Apr 2013
Location: North Carolina
Vehicle: 2001 SLK320
Posts: 48
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 7 Times in 6 Posts
(Thread Starter)
I had to post this one, number 5 to view the troubleshooting manual.
randy993 is offline  
#7 Old 04-25-2013
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,144
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
I would start with the simple stuff, replace the plugs, check the connections on the coil's, clean the MAF with MAF cleaner, clear the codes if you hace a code reader and go from there.
Livefreeordie is offline  
#8 Old 04-26-2013
Wizard of ID
 
tcrankwa's Avatar
 
Join Date: Feb 2010
Location: Idaho
Vehicle: 2001 SLK320
Other Toys: '97 Silverado 4X4 Lifted (body and suspension)BMW X5
Posts: 589
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 22 Post(s)
Thanks: 68
Thanked 207 Times in 76 Posts
Garage
Try this:

https://www.slkworld.com/slk-r170-gen...-cleaning.html

Sportlich, Leicht und Kurz

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Margie and Terry

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
tcrankwa is offline  
#9 Old 04-26-2013
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,315
Country:
Chats: 0
Mentioned: 595 Post(s)
Tagged: 0 Thread(s)
Quoted: 913 Post(s)
Thanks: 155
Thanked 520 Times in 481 Posts
This is relevant -- http://www.obd-codes.com/p0410
Did you leave the engine running and if yes did the misfire stop after a few minutes?
efair is offline  
#10 Old 04-26-2013
Registered Users
 
Join Date: Apr 2013
Location: North Carolina
Vehicle: 2001 SLK320
Posts: 48
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 7 Times in 6 Posts
(Thread Starter)
I'm not sure what you mean by did I leave the engine running. The misfires started while I was driving the car. I was able to make it home, about 3-4 miles. The misfires have not stopped.
Randy
randy993 is offline  
#11 Old 04-26-2013
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,144
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
One other thing to look at is the CPS, that solved my missfire problem last year.
Livefreeordie is offline  
#12 Old 04-26-2013
MrG
Registered Users
 
Join Date: Aug 2011
Location: Texas
Vehicle: Black '02 SLK320
Other Toys: F250 4x4 Power Stroke Diesel, 22' boat
Posts: 246
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 56
Thanked 53 Times in 35 Posts
Garage
Quote:
Originally Posted by livefreeordie View Post
One other thing to look at is the CPS, that solved my missfire problem last year.
CPS=Crank position sensor. I didn't know all the code words when I got on here. CPS fixed mine too. Cheaper than coils or plugs.
MrG is offline  
#13 Old 04-26-2013
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,144
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
Quote:
Originally Posted by MrG View Post
CPS=Crank position sensor. I didn't know all the code words when I got on here. CPS fixed mine too. Cheaper than coils or plugs.

I think i payed $10 for mine. I'm bad, i should get in the habit of spelling out parts.
Livefreeordie is offline  
#14 Old 04-27-2013
Registered Users
 
Join Date: Apr 2013
Location: North Carolina
Vehicle: 2001 SLK320
Posts: 48
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 7 Times in 6 Posts
(Thread Starter)
Thanks for the suggestions. Where's the CPS located?
randy993 is offline  
#15 Old 04-27-2013
Registered Users
 
Join Date: Apr 2013
Location: North Carolina
Vehicle: 2001 SLK320
Posts: 48
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 7 Times in 6 Posts
(Thread Starter)
Update

I have figured out my misfire problem. The cylinders that had the misfire problem had the spark plugs fouled due to coolant in the combustion chamber. This can't be good. I need to try and determine where the coolant is coming from. Head or possibly intake gasket. Maybe someone with technical knowledge of these engines can chime in.
Randy
randy993 is offline  
#16 Old 09-02-2017
Registered Users
 
Join Date: Apr 2017
Location: Broward County Florida
Vehicle: 2002 Black SLK320
Other Toys: 1995 Chrysler Lebaron Convertible
Posts: 227
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 58 Post(s)
Thanks: 17
Thanked 8 Times in 8 Posts
Just wanted to add this to the thread, yes I know it's old, but it is also pretty much all search found for 410 320.

My Check Engine Light came on, no apparent difference in how the car ran. My cheapie Harbour Fright scanner read 410, would not reset.

Was not happy about ordering a EGR valve $80, MAF spray, etc. Yet was still in car repair mode and remembered I had a new temp sensor in the to-do box. Replaced the temp sensor on a whim and the Check Engine Light went away . . . at least for now . . .
Avel Du likes this.
RobertP is offline  
#17 Old 09-02-2017
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: SLK350/C200AMG(Bluebadger),MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 23,255
Country:
Chats: 0
Mentioned: 271 Post(s)
Tagged: 0 Thread(s)
Quoted: 2286 Post(s)
Thanks: 1,980
Thanked 1,477 Times in 1,363 Posts
Garage
Quote:
Originally Posted by RobertP View Post
Just wanted to add this to the thread, yes I know it's old, but it is also pretty much all search found for 410 320.

My Check Engine Light came on, no apparent difference in how the car ran. My cheapie Harbour Fright scanner read 410, would not reset.

Was not happy about ordering a EGR valve $80, MAF spray, etc. Yet was still in car repair mode and remembered I had a new temp sensor in the to-do box. Replaced the temp sensor on a whim and the Check Engine Light went away . . . at least for now . . .
Yep, Mercs can be weird this way.

As you know it's an old thread I'll leave the 'posting in...' link out.
Besides, updates are always welcome, however old the thread.

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is online now  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent Starting Problem edzed SLK R171 General Discussion 44 07-28-2018 03:38 PM
2002 SLK320 starting problem Blue02 SLK R170 General Discussion 3 01-11-2013 11:33 AM
2001 SLK320 Radio problem t509boy SLK R170 General Discussion 1 07-26-2012 10:53 PM
Conductor Plate Problem; shady service rep... What to do? Th3120ck General Discussion 35 02-12-2012 04:41 PM
2001 SLK320 6 spd manual transmission problem CO-SLK320 SLK R170 General Discussion 0 10-11-2010 01:13 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.