odd alarm, cigar lighter, dome light issue - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 2Likes
  • 1 Post By Tolak
  • 1 Post By Tolak
 
LinkBack Thread Tools
#1 Old 04-22-2013
Hopeless *** owner
 
stinger608's Avatar
 
Join Date: Apr 2013
Location: Cheyenne Wyoming
Vehicle: 1999 SLK 230 AMG
Posts: 102
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 65
Thanked 5 Times in 5 Posts
Garage
(Thread Starter)
odd alarm, cigar lighter, dome light issue

Okay, my 99 slk 230 has an odd issue. I found that the horn and alarm did not work along with the cigar lighter and dome (interior) light.
Found that a 10A fuse in the engine compartment was missing that controlled the horn, alarm, and lighter. Plugged a new fuse in and the alarm instantly starting going!!! Naturally I pulled the fuse back out. LOL

Dome light issue I have no idea on. I know I seen a guide to remove the cover but cannot seem to find it.

Another odd issue is the door locks. They do not unlock or lock using the key fob or the button on the center console.

thanks in advance for any and all suggestions.

stinger
stinger608 is offline  
Sponsored Links
Advertisement
 
#2 Old 04-22-2013
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
Do a search for PSE problems ..
curro101 is offline  
#3 Old 04-22-2013
Hopeless *** owner
 
stinger608's Avatar
 
Join Date: Apr 2013
Location: Cheyenne Wyoming
Vehicle: 1999 SLK 230 AMG
Posts: 102
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 65
Thanked 5 Times in 5 Posts
Garage
(Thread Starter)
Quote:
Originally Posted by curro101 View Post
Do a search for PSE problems ..
man, I was afraid someone would say that. I had a hunch that may be a possible issue but was sure hoping that it was something else.
stinger608 is offline  
 
#4 Old 04-22-2013
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
As far as I know all those faults together point to the PSE , looks like the fuse was removed as an easy solution !!
curro101 is offline  
#5 Old 04-22-2013
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
Have you checked the pump and its connectors for corrosion ??
curro101 is offline  
#6 Old 04-22-2013
Hopeless *** owner
 
stinger608's Avatar
 
Join Date: Apr 2013
Location: Cheyenne Wyoming
Vehicle: 1999 SLK 230 AMG
Posts: 102
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 65
Thanked 5 Times in 5 Posts
Garage
(Thread Starter)
Quote:
Originally Posted by curro101 View Post
Have you checked the pump and its connectors for corrosion ??
I haven't yet. Every time I decide to check things out the weather turns bad and it snows and gets real cold. LOL
I have had this slk for about a month now and only driven it 3 dang times.
stinger608 is offline  
#7 Old 04-22-2013
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
Hopefully you'll get it sorted soon and have a great summer together !!
curro101 is offline  
The Following User Says Thank You to curro101 For This Useful Post:
#8 Old 05-29-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
Any progress?

Since the ATA (Anti Theft Alarm) is also housed in the PSE (Pneumatic Services Environment), which looks after dome light, boot light, etc as well as central locking (both fob and button), the PSE is really the most likely culprit.

You may need to get out there with a brolly to chase down the problems before they become worse. And it is possible to remove the PSE completely, and drive the car OK, should you need longer to dry it out or get someone to investigate it. (Manual locking of both doors, boot and fuel filler flap)
Anon
stinger608 likes this.
Tolak is offline  
#9 Old 05-30-2013
Hopeless *** owner
 
stinger608's Avatar
 
Join Date: Apr 2013
Location: Cheyenne Wyoming
Vehicle: 1999 SLK 230 AMG
Posts: 102
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 65
Thanked 5 Times in 5 Posts
Garage
(Thread Starter)
Quote:
Originally Posted by Tolak View Post
Any progress?

Since the ATA (Anti Theft Alarm) is also housed in the PSE (Pneumatic Services Environment), which looks after dome light, boot light, etc as well as central locking (both fob and button), the PSE is really the most likely culprit.

You may need to get out there with a brolly to chase down the problems before they become worse. And it is possible to remove the PSE completely, and drive the car OK, should you need longer to dry it out or get someone to investigate it. (Manual locking of both doors, boot and fuel filler flap)
Anon

I haven't yet. The weather has finally started to get nice.

LOL I have to manually lock and unlock the doors and boot now as it is. The fuse is removed from the alarm at the moment. If I try to insert a fuse the alarm just keeps screaming. Not able to disarm the alarm with the fuse installed.

Kind of tend to believe it is the PSE.
stinger608 is offline  
#10 Old 05-30-2013
Per ardua ad cineris.
 
Tolak's Avatar
 
Join Date: Apr 2013
Location: Somerset UK
Vehicle: SLK230 '99 R170
Other Toys: Clio Williams
Posts: 1,039
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 10 Post(s)
Thanks: 14
Thanked 136 Times in 117 Posts
Quote:
Originally Posted by stinger608 View Post
I haven't yet. The weather has finally started to get nice.

LOL I have to manually lock and unlock the doors and boot now as it is. The fuse is removed from the alarm at the moment. If I try to insert a fuse the alarm just keeps screaming. Not able to disarm the alarm with the fuse installed.

Kind of tend to believe it is the PSE.
Nice (?) to see others have problems getting things done.
Good hunting when you get the weather and time to chase this problem down.

I confirmed today that the alarm connections to the ATA side of the PSE are completely missing; someone has connected a wire from the pins on the PSE connector and run them forward to some sort of alarm in the bonnet area.
But strangely, it works on the normal fob?

All I want to do is add a vacuum pump action to allow locking and unlocking.

OK, back to my other thread on the PSE, etc.
stinger608 likes this.
Tolak is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
PSE acting up: no power locks, dome light etc BSK SLK R170 General Discussion 22 08-24-2017 11:29 AM
Dome Light Stays On Doors Shut LRC SLK R170 General Discussion 13 03-22-2013 03:02 PM
HELP! Alarm, tow light, parking lights, door locks, interior light wont go off ExoticClassics General Discussion 3 05-01-2011 05:22 PM
Check Engine Light Issue Smitty General Discussion 2 10-25-2010 05:14 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.