PSE Questions - repair detached connector pins? Plug and Play part number compatibility? - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 1Likes
  • 1 Post By cliveski
 
LinkBack Thread Tools
#1 Old 03-24-2017
Registered Users
 
Join Date: May 2016
Location: Corby
Vehicle: 1996 SLK 230 Non-Runner
Posts: 119
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 49
Thanked 3 Times in 3 Posts
(Thread Starter)
Thumbs down PSE Questions - repair detached connector pins? Plug and Play part number compatibility?

The PSE on my recently acquired '98 SLK has suffered water damage.

The protective foam it sat in was damp - symptoms were interior light constantly on (so have it switched to the constantly off position) and the central locking not always unlocking passenger door / boot.

Today I removed it hopeful I could give it a clean and get it working again. Sadly there was corrosion in the white 18 pin connector socket. One of the pins had become detached (rusted off) and two more are wobbly. The board itself didn't seem too bad compared to some pictured on the internet.

I will post some pictures up but in the first instance are the rusted off pins something that could be repaired? anyone know of a place who repairs this kind of thing?

Assuming a repair is not possible or might be futile I will be looking for a replacement.

Mine is 1708000148 (06) and I have seen the following list of alternatives -

1708000548
1708000248
1708000348
1708000448
1708000648
1708000848

My question is - is the matching part number the only one that will be plug and play for my car? and others will need programming?

I will be clearing the drains and turning the repalcement PSE upside down.

Thank you, Clive
cliveski is offline  
Sponsored Links
Advertisement
 
#2 Old 03-24-2017
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,315
Country:
Chats: 0
Mentioned: 594 Post(s)
Tagged: 0 Thread(s)
Quoted: 913 Post(s)
Thanks: 155
Thanked 520 Times in 481 Posts
If you have access to the EPC you can often find the pins. I've ordered a few of these direct from MB over the years.
efair is online now  
The Following User Says Thank You to efair For This Useful Post:
#3 Old 03-24-2017
Registered Users
 
Join Date: May 2016
Location: Corby
Vehicle: 1996 SLK 230 Non-Runner
Posts: 119
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 49
Thanked 3 Times in 3 Posts
(Thread Starter)
Done a google search and discovered another SLK owner had removed the white A37 connector from the board and hard-wired some connections to it instead. Apparently only 5 of the 18 pins are used.

PSE connector fix - Mercedes-Benz Forum

I doubt I will be lucky enough that my 3 missing/wobbly/barely standing up pins are not required.

Replacement PSE's of this type seem to be 200+

I have a lovely 'as new' PSE from the 96 car I am breaking but it is the 210 variant not the 170 version so is not compatible sadly.
cliveski is offline  
 
#4 Old 03-24-2017
Registered Users
 
Join Date: May 2016
Location: Corby
Vehicle: 1996 SLK 230 Non-Runner
Posts: 119
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 49
Thanked 3 Times in 3 Posts
(Thread Starter)
Well after cleaning and drying the PSE I plugged it back into the car and it's no worse than before despite being 3 pins short.

Central Locking may actually work better (too early to confirm for certain).

In other news and in an attempt to pass on some useful information earlier cars with '210' PSE's have different cables/connectors than cars with '170' PSE's.

The 1996 SLK I'm breaking has one fitted - 2108000648 - a 2005 replacement by Mercedes no less (I have the receipt). If anyone needs one it's in mint condition.
Avel Du likes this.
cliveski is offline  
#5 Old 03-26-2017
Registered Users
 
1978L82's Avatar
 
Join Date: Jan 2017
Location: Texas
Vehicle: 1998 MB SLK230
Posts: 186
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 111 Post(s)
Thanks: 1
Thanked 13 Times in 13 Posts
Not sure if it's much help because of your location, but the PSE from a crossfire should also work. I used one of a different number on my 98 and it worked just fine. I'm under the impression that PSE's from all r170s and Crossfires are the same. I'll look up my original number and the new number later today for reference. I found mine for $200 on eBay.
1978L82 is offline  
The Following User Says Thank You to 1978L82 For This Useful Post:
#6 Old 04-20-2017
Registered Users
 
Join Date: May 2016
Location: Corby
Vehicle: 1996 SLK 230 Non-Runner
Posts: 119
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 49
Thanked 3 Times in 3 Posts
(Thread Starter)
An update on this - got a replacement PSE via ebay for 120 - alas it arrived with some green corrosion amongst the pins in the white connector socket AND two missing pins grrr

Got a full refund and allowed to keep it - have since opened it up and it actually appears in really good condition - no sign of water damage or anything.

Does anyone know of somewhere that can de-solder the white connector and solder a new one in?

I have another white connector with all its pins intact on another board (alarm or something) I'm happy to sacrifice.

Regards, Clive
cliveski is offline  
#7 Old 04-20-2017
Registered Users
 
ixion's Avatar
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2013 Smart Car in Blue.
Posts: 354
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 0
Thanked 57 Times in 36 Posts
Take a look at - https://www.atpelectronics.co.uk/pages/products.html

Last edited by ixion; 04-21-2017 at 07:40 AM.
ixion is online now  
#8 Old 04-20-2017
Registered Users
 
Join Date: May 2012
Location: Vienna, VA
Vehicle: 1998 SLK230, 2000 SLK230, 2012 SLK250
Other Toys: Tennis Racquet
Posts: 160
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 45 Post(s)
Thanks: 14
Thanked 11 Times in 11 Posts
Hi Clive, the higher part numbers supersede the lower part numbers. They were introduced in different years, and maybe they had more functionality. You can safely order the highest number, I did.

You know, you can always just remove the big white plug, and wire in your own connector to the board. I forget how many are used, but most of those pins aren't. Maybe 6 of them?
mightycpa is offline  
#9 Old 04-21-2017
Registered Users
 
Join Date: Jul 2015
Location: Saint-Aigulin, France
Vehicle: 2003 SLK 200 Kompressor
Other Toys: BMW R100 GS PD/C
Posts: 129
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 29 Post(s)
Thanks: 1
Thanked 3 Times in 3 Posts
Quote:
Originally Posted by ixion View Post
Linky not working for me.....
Shalesy is offline  
#10 Old 04-21-2017
Registered Users
 
ixion's Avatar
 
Join Date: Aug 2010
Location: Bristol, United Kingdom
Vehicle: 2002 R170 SLK 230 Kompressor. Silver. Black Leather. 67k Miles
Other Toys: I also have a 320CDI Estate, Silver,Black Leather, 61k Miles TWIN of SLK & 2013 Smart Car in Blue.
Posts: 354
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 41 Post(s)
Thanks: 0
Thanked 57 Times in 36 Posts
Remanufacturers

Sorry about that.

SORRY TRY THESE -

https://www.bba-reman.com/gb/catalogue/16/
BBA Reman is one of the worlds leading automotive Remanufacturers. ABS ECU modules, throttle bodies & instrument cluster repair Etc.The company was founded in 1998.Lifetime warranty offered.


http://www.actronics.eu/en
Remanufacture - ABS ECU modules, throttle bodies & instrument cluster repair


https://www.atpelectronics.co.uk/pages/products.html
Electronic Remanufacturing Since 1988 ECU,Clusters, ABS,Etc

Last edited by ixion; 04-21-2017 at 07:54 AM. Reason: Wrong Information
ixion is online now  
The Following User Says Thank You to ixion For This Useful Post:
#11 Old 04-21-2017
Premium Member
 
Pictor's Avatar
 
Join Date: Jul 2015
Location: Australia
Vehicle: 2001 SLK320
Posts: 1,032
Country:
Chats: 0
Mentioned: 16 Post(s)
Tagged: 0 Thread(s)
Quoted: 219 Post(s)
Thanks: 22
Thanked 88 Times in 73 Posts
Interchangeabilty

Quote:
Originally Posted by mightycpa View Post
Hi Clive, the higher part numbers supersede the lower part numbers. They were introduced in different years, and maybe they had more functionality. You can safely order the highest number, I did.

You know, you can always just remove the big white plug, and wire in your own connector to the board. I forget how many are used, but most of those pins aren't. Maybe 6 of them?
I got the same story as mightycpa when I enquired at a dealer, the replacement for my '98 230 which had part number ending in 148 was the '848 last issued part.

But if I could get a new one for 200 I would, dealers ask over $2000 here and almost all the USA suppliers will not ship internationally. I got a good one for the '230 from a wrecker for $100 but it is still an old one.
Pictor is offline  
The Following User Says Thank You to Pictor For This Useful Post:
#12 Old 04-23-2017
Registered Users
 
1978L82's Avatar
 
Join Date: Jan 2017
Location: Texas
Vehicle: 1998 MB SLK230
Posts: 186
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 111 Post(s)
Thanks: 1
Thanked 13 Times in 13 Posts
My pins were a bit corroded too. I dipped them in a product called CLR. Let them sit in there an it pretty much dissolves. Then brush off terminals with toothbrush. Don't know how bad yours are though.
1978L82 is offline  
The Following User Says Thank You to 1978L82 For This Useful Post:
#13 Old 04-24-2017
Registered Users
 
Join Date: May 2016
Location: Corby
Vehicle: 1996 SLK 230 Non-Runner
Posts: 119
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 49
Thanked 3 Times in 3 Posts
(Thread Starter)
Quote:
Originally Posted by mightycpa View Post
Hi Clive, the higher part numbers supersede the lower part numbers. They were introduced in different years, and maybe they had more functionality. You can safely order the highest number, I did.

You know, you can always just remove the big white plug, and wire in your own connector to the board. I forget how many are used, but most of those pins aren't. Maybe 6 of them?
Thank you for the input people.

I had seen a post elsewhere where someone had hard-wired 5 connections to the board so it's certainly true not all 18 pins are required - a shame we don't know which of the 18 pins are actually used.

I have used Servisol Super 10 Switch Cleaning Lubricant (from Maplin) on the original PSE board and it cleaned things up nicely. Used it on the pins of the replacement PSE as well to good effect.

I will explore having the replacement PSE I bought repaired / checked as it owes me nothing. The original one does work in that it locks and unlocks the doors and boot but I do find after a drive the passenger door and boot will have locked and I have to lock then unlock the car to get these open - annoying.

Thanks again, Clive
cliveski is offline  
#14 Old 05-17-2017
Registered Users
 
Join Date: May 2016
Location: Corby
Vehicle: 1996 SLK 230 Non-Runner
Posts: 119
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 49
Thanked 3 Times in 3 Posts
(Thread Starter)
I have some useful information to pass on which I hope may be useful to others . . .

I now know it is only 5 of the 18 pins that are used and I now know which pins they are - see picture below - the five highlighted in pink are the ones that are used.



The numbering is my own system.

I discovered the above when I realised I could take the connector apart to clean it - the black 'tab' slides down and off allowing the connector block to slide out. I got good results from a quick clean of mine.







Sadly I don't know what each pin controls but considering on my car the PSE is missing pins 3,5 and 6 yet the central locking still works correctly* I can only assume pins 10 and 11 are connected to the central locking. My interior light is stuck permanently on so assume that is connected to pins 3,5 and 6.

* from reading another post by bazzle it is normal for the car to lock itself once you first start moving. I have found this anti-hijack (??) feature annoying as if I get out and go to open the boot or passenger door I find them locked - have to remember to press the unlock button on the dash to open passenger door and boot.
cliveski is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.