Smarttop install and BAS/ESP light after... I thought I broke something ;) - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 9Likes
  • 3 Post By mono
  • 2 Post By mono
  • 1 Post By jbanks15
  • 2 Post By mono
  • 1 Post By Avel Du
 
LinkBack Thread Tools
#1 Old 03-17-2017
Registered Users
 
Join Date: Aug 2016
Location: SF Bay Area
Vehicle: 2003 SLK320
Other Toys: SL500, GL450
Posts: 10
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
(Thread Starter)
Smarttop install and BAS/ESP light after... I thought I broke something ;)

So I finally got my smarttop and installed it last night. Based on the instructions I saw I thought it would be easy and take 15 minutes tops...

Overall it took me about an hour and a half and it got dark before I was finished so I had to make the last 3 connections holding a penlight in my mouth. When you do something like this the first time give yourself extra time. You don't want to rush it. A couple of the wires were twisted around each other on my wiring harness and it was really hard to get enough slack on them to put the taps on.

I got everything in and made sure I hadn't left any tools sitting on the engine and when I got in to start the car the BAS ESP light was on... Did a quick search on my phone and the threads that came up here were all talking about which sensors may have gone bad and how expensive it was to fix, etc, etc and I was thinking "what the hell did I break?"

I tried turning the car off and back on and it was still there... so I decided to take it for a drive and see if it cleared the error and it was gone after about half a mile. I've tried restarting several times and it hasn't come back so I guess I didn't break anything.

I'm delighted with the smarttop so far. I've had SL500's (R129) since the year 2000 and I wish I had discovered the smarttop years ago.

I was a little apprehensive on the install because all the wiring insulation on my SL500s is rotting away and if you move any wires there is the chance that you will cause a short somewhere else. (I've had to replace the throttle body and main engine wiring harness on one of them and the other needs both replaced in order to pass smog so it's currently on PNO with the DMV and has been sitting idle in front of my house for 3 years.

All that being said it's not difficult if you can follow instructions. If I keep the other SL500 I will be getting a smarttop for it, and the first thing I will do to any future SLK is add the smarttop!

Thanks for all the pointers everyone!
jbanks15, Avel Du and RLander like this.
mono is offline  
Sponsored Links
Advertisement
 
#2 Old 03-17-2017
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,853
Country:
Chats: 38
Mentioned: 472 Post(s)
Tagged: 5 Thread(s)
Quoted: 6554 Post(s)
Thanks: 3,246
Thanked 11,092 Times in 8,445 Posts
Glad you got it sorted
The SmartTop has been around a long time and covers all generations of SLKs
so any issues have been covered before and resolved happily!

the bas/esp light, usually comes on after driving for a bit or turning the wheel left and then right

had you disconnected your battery? if so, that is why


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 03-17-2017
Registered Users
 
Join Date: Aug 2016
Location: SF Bay Area
Vehicle: 2003 SLK320
Other Toys: SL500, GL450
Posts: 10
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
(Thread Starter)
Quote:
Originally Posted by jbanks15 View Post

had you disconnected your battery? if so, that is why
Yes - I disconnected the battery before digging into all those cables (per the Smarttop instructions)

When I woke up this morning I searched on the computer and found a lot of other topics regarding the BAS/ESP and realized it had to do with disconnecting the battery. However when I was in a panic last night, the way I searched brought up threads having to do with bad sensors and the car automatically braking at speeds with this light on and I was getting myself more and more worried.

Nice to know that nothing was going on...
jbanks15 and Avel Du like this.
mono is offline  
 
#4 Old 03-17-2017
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,853
Country:
Chats: 38
Mentioned: 472 Post(s)
Tagged: 5 Thread(s)
Quoted: 6554 Post(s)
Thanks: 3,246
Thanked 11,092 Times in 8,445 Posts
Quote:
Originally Posted by mono View Post
Yes - I disconnected the battery before digging into all those cables (per the Smarttop instructions)

When I woke up this morning I searched on the computer and found a lot of other topics regarding the BAS/ESP and realized it had to do with disconnecting the battery. However when I was in a panic last night, the way I searched brought up threads having to do with bad sensors and the car automatically braking at speeds with this light on and I was getting myself more and more worried.

Nice to know that nothing was going on...
you did see the part in your....oh what is it called....the owner's manual
about resetting the esp/bas?
Avel Du likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#5 Old 03-17-2017
Registered Users
 
Join Date: Aug 2016
Location: SF Bay Area
Vehicle: 2003 SLK320
Other Toys: SL500, GL450
Posts: 10
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 3 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
(Thread Starter)
Quote:
Originally Posted by jbanks15 View Post
you did see the part in your....oh what is it called....the owner's manual
about resetting the esp/bas?
LOL - NOPE! I always look here BEFORE I look in the owners manual...
jbanks15 and Avel Du like this.
mono is offline  
#6 Old 03-17-2017
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: SLK350/C200AMG(Bluebadger),MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 23,283
Country:
Chats: 0
Mentioned: 271 Post(s)
Tagged: 0 Thread(s)
Quoted: 2290 Post(s)
Thanks: 1,981
Thanked 1,480 Times in 1,366 Posts
Garage
Quote:
Originally Posted by mono View Post
LOL - NOPE! I always look here BEFORE I look in the owners manual...

Aw!


You made Jeff blush!
jbanks15 likes this.

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is online now  
#7 Old 10-06-2017
6007.us
 
Padgett's Avatar
 
Join Date: Mar 2017
Location: Orlando
Vehicle: '01 SLK320 Lazulithe Blue, '00 SLK230 Bahama Blue (needs interior parts)
Other Toys: Too many others. See web page.
Posts: 2,594
Country:
Chats: 0
Mentioned: 288 Post(s)
Tagged: 0 Thread(s)
Quoted: 573 Post(s)
Thanks: 0
Thanked 157 Times in 144 Posts
Found the nut gone on the negative battery clamp and musta broke contact. Got BAS/ESP. Found the cure on page 167 of OM but why not just say "Start engine, turn wheel full right then left and return to center. The BAS/ESP light should go off after a few seconds.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Padgett is offline  
#8 Old 10-07-2017
Premium Member
 
Australian's Avatar
 
Join Date: Sep 2012
Location: South Australia
Vehicle: SLK 320 2002
Other Toys: Just a shopping trolley.
Posts: 575
Country:
Chats: 0
Mentioned: 216 Post(s)
Tagged: 0 Thread(s)
Quoted: 85 Post(s)
Thanks: 13
Thanked 50 Times in 49 Posts
Many of us have been caught with the BAS/ESP light after disconnecting the battery.
Australian is offline  
The Following User Says Thank You to Australian For This Useful Post:
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
BAS/ESP light with codes. joeyuk SLK R170 General Discussion 4 02-11-2015 01:17 AM
BAS/ESP light discovery I think sokoloff SLK R170 General Discussion 0 06-16-2014 07:57 PM
BAS/ESP light Simprof SLK R170 General Discussion 10 10-17-2013 03:11 AM
Intermittent BAS/ESP light SLK320Bob SLK R170 General Discussion 14 04-08-2011 10:01 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.