Throttle bogged down, stalled, then ran fine. - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 2Likes
  • 1 Post By pemsland
  • 1 Post By pemsland
 
LinkBack Thread Tools
#1 Old 04-07-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
Throttle bogged down, stalled, then ran fine.

Ok so I took the car out yesterday after working on it for the week getting it ready from being in storage. The car ran great. Then me and my wife had luch and when we got back in it, there was no acceleration, I would stomp on the pedal and it would slowly gain speed. It stalled going up a hill, so I turned it off took the key out and restarted her..... and everything has worked fine ever since.

This seems to happen once or twice a year to the car, any suggestions to what it is, K40?

I don't think its the MAF, I just replaced with a new one from MB. Throttle body is in great shape, and all wires to and from engine look good. the spark plugs were just changed, so what could do this once in a blue moon?

Its just making me
Himecraig likes this.
pemsland is offline  
Sponsored Links
Advertisement
 
#2 Old 04-07-2013
Registered Users
 
Join Date: Mar 2013
Location: Bay area
Vehicle: 01 320slk
Other Toys: Passat 4mo. Ranger FX4, Hondas, Alfa bits, 500cc Triumph
Posts: 7
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
I had something similar but CEL came on.
Replaced O2 sensor(s) and throttle peddle sensor.
Himecraig is offline  
#3 Old 04-07-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
Yea my BAS light was on, but since this happend that turned off and hasnt come back on.
pemsland is offline  
 
#4 Old 04-07-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
I was thinking camshaft position sensor. But wouldst that throw a code?
pemsland is offline  
#5 Old 04-09-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
(Thread Starter)
Ok well after driving it around and checking pending codes, I found that codes p0100, p0101, and p1580 all we pending. So I took apart the intake from the MAF to Throttlebody. What I found was that O-ring by the MAF was not making a good seal. When the car was under acceleration, the seal was bleeding off pressure from the S/C. this threw all three codes at once. I made rubber seal to help with the O-ring and now theres no air escaping. thus no CODES and NO Bogging down.
Woolly likes this.
pemsland is offline  
The Following 3 Users Say Thank You to pemsland For This Useful Post:
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.