HELP! Alarm keeps going off randomly! - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 16Likes
Reply
 
LinkBack Thread Tools
#1 Old 02-24-2017
Registered Users
 
Join Date: May 2015
Location: Oak Hills, CA
Vehicle: 2003 SLK32 AMG
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
HELP! Alarm keeps going off randomly!

Hello everyone,

I am so frustrated with this alarm problem. I have researched forums and checked all the items they have suggested. I have now hit a dead end and my alarm keeps going off randomly. There are days where it can go without going off and then out of nowhere it starts again.

I have checked the PSE pump, #9 fuse, car battery, Key fob battery, replaced the alarm siren, etc.

Do you have any other ideas/options?

I was thinking my last options are the alarm module behind the PSE pump or just a STAR system alarm reset?

What do you suggest?

Thank you.
JLDroppert likes this.
JMSLK32AMG is offline  
Sponsored Links
Advertisement
 
#2 Old 02-24-2017
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,911
Country:
Chats: 38
Mentioned: 473 Post(s)
Tagged: 5 Thread(s)
Quoted: 6569 Post(s)
Thanks: 3,246
Thanked 11,098 Times in 8,451 Posts
so you replaced the alarm battery or the alarm totally?

https://www.google.com/#q=site:slkwo...ps+going+off&*
Avel Du likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 02-24-2017
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: SLK350/C200AMG(Bluebadger),MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 23,320
Country:
Chats: 0
Mentioned: 271 Post(s)
Tagged: 0 Thread(s)
Quoted: 2293 Post(s)
Thanks: 1,982
Thanked 1,485 Times in 1,371 Posts
Garage
And you don't have anything dangling off the rearview?

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is offline  
 
#4 Old 02-24-2017
Registered Users
 
Join Date: May 2015
Location: Oak Hills, CA
Vehicle: 2003 SLK32 AMG
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
I replaced the alarm siren unit, the one that is located under the plastic windshield wiper cover.

The weird thing is that if I leave the window down, lock the car, and then open the door from the inside, the alarm does not go off and just unlocks like if I pressed the key FOB.
JMSLK32AMG is offline  
#5 Old 02-24-2017
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: SLK350/C200AMG(Bluebadger),MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 23,320
Country:
Chats: 0
Mentioned: 271 Post(s)
Tagged: 0 Thread(s)
Quoted: 2293 Post(s)
Thanks: 1,982
Thanked 1,485 Times in 1,371 Posts
Garage
Have a look at the vacuum lines from the pse.


You've already checked the pse and if that's ok then maybe the line is twisted.


Hope you're good at yoga, because it's a bit of a contortion trying to see.
Yellow tubes in pic below: (ignore the red arrows, borrowed pic)



Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is offline  
#6 Old 02-24-2017
Registered Users
 
Join Date: May 2015
Location: Oak Hills, CA
Vehicle: 2003 SLK32 AMG
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
No, nothing dangling from rear-view mirror.

Bit of background: Someone hit the rear-end of the car a month ago. The taillight was broken and so it had to be towed. I suspect that the tow truck driver did not disable the tow alarm when it was getting towed to the body shop and the alarm just kept going off. Do you guys think that the alarm system stored all the alarms and it has just gone crazy because of that event?
JMSLK32AMG is offline  
#7 Old 02-24-2017
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,911
Country:
Chats: 38
Mentioned: 473 Post(s)
Tagged: 5 Thread(s)
Quoted: 6569 Post(s)
Thanks: 3,246
Thanked 11,098 Times in 8,451 Posts
you say you checked the car battery?
but how old is it?

the slk needs a great battery, not a good battery otherwise all types of electronic gremlins start to appear


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#8 Old 02-24-2017
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: SLK350/C200AMG(Bluebadger),MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 23,320
Country:
Chats: 0
Mentioned: 271 Post(s)
Tagged: 0 Thread(s)
Quoted: 2293 Post(s)
Thanks: 1,982
Thanked 1,485 Times in 1,371 Posts
Garage
Aha.
Mercedes Benz SLK Forum - Search Results for SLKWorld.com tow sensor


Have a trawl through that lot.


Not an issue that I had but it rings a distant bell.

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is offline  
#9 Old 02-24-2017
Registered Users
 
Join Date: Oct 2013
Location: Minnesota
Vehicle: Looking to keep Jeff off my back.
Other Toys: Carver 350 Mariner, Boston Whaler Dauntless, 1961 Les Paul Formerly 2003 slk 230
Posts: 550
Country:
Chats: 0
Mentioned: 276 Post(s)
Tagged: 0 Thread(s)
Quoted: 133 Post(s)
Thanks: 3
Thanked 63 Times in 57 Posts
I had exactly the same problem August before last. It would go off for no reason at all. I stored it that winter and in January, decided to take it out for a spin. The battery was nearly dead so I replaced it. Haven't had a problem with it since.
JMSLK32AMG likes this.
Mn car guy is offline  
#10 Old 02-24-2017
Registered Users
 
Join Date: May 2015
Location: Oak Hills, CA
Vehicle: 2003 SLK32 AMG
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Thanks Avel Du. I will give those threads a read. There is and SLK320 at my local scrap yard and I'm tempted to go remove the tow sensor unit... hopefully that will fix the problem.

jbanks15: I'm not sure how old the battery is... I took it in to a shop to get it checked and they said it was at 50%. They charged it and after installing it the alarm did not go off for 3 days. I took the battery back to get it checked to see if it had lost charge, they checked it, but it was at 100%. At this point I discarded the battery as being the problem. But, now that you mention the battery, I might have to go check again. It is not an original Mercedes battery in there, it's one of those Duralast (it came with the car).
jbanks15 and Avel Du like this.
JMSLK32AMG is offline  
#11 Old 02-24-2017
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,911
Country:
Chats: 38
Mentioned: 473 Post(s)
Tagged: 5 Thread(s)
Quoted: 6569 Post(s)
Thanks: 3,246
Thanked 11,098 Times in 8,451 Posts
Remember, batteries get bad cell or cells
They get charged up, act ok for a while, then go bad.
You need to get a conductive test done on the battery
does the battery have a sticker with date manufactured on it?
JMSLK32AMG and Avel Du like this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#12 Old 02-24-2017
Registered Users
 
Join Date: May 2015
Location: Oak Hills, CA
Vehicle: 2003 SLK32 AMG
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
I think I might just replace the battery with a new OEM, since I don't like seeing that Duralast in my engine bay anyway.

I will report back on the results later.

Thank you all for your help.
jbanks15 and Avel Du like this.
JMSLK32AMG is offline  
#13 Old 03-08-2017
Registered Users
 
Join Date: May 2015
Location: Oak Hills, CA
Vehicle: 2003 SLK32 AMG
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Hello everyone,

I purchased a new oem battery. After 1 and a half weeks, the alarm had not gone off until today. At this moment, I think the only option left is to take it in to the dealership to hook up the STAR Diagnosis and see where the alarm is being triggered.
Avel Du likes this.
JMSLK32AMG is offline  
#14 Old 03-08-2017
Super Moderator/RoTMorganiser

 
Avel Du's Avatar
 
Join Date: Jul 2015
Location: Wirral, England
Vehicle: 2007 SLK55AMG
Other Toys: SLK350/C200AMG(Bluebadger),MK I Nissan Murano (2008), Honda VFR 800 FiW (1998), CB400four f2 (1978)
Posts: 23,320
Country:
Chats: 0
Mentioned: 271 Post(s)
Tagged: 0 Thread(s)
Quoted: 2293 Post(s)
Thanks: 1,982
Thanked 1,485 Times in 1,371 Posts
Garage
Quote:
Originally Posted by JMSLK32AMG View Post
Hello everyone,

I purchased a new oem battery. After 1 and a half weeks, the alarm had not gone off until today. At this moment, I think the only option left is to take it in to the dealership to hook up the STAR Diagnosis and see where the alarm is being triggered.

Check the battery and see that it hasn't lost it's charge.
It might be that you have an electrical leak that is drawing power when your car is parked.
Several threads on here about that.


The fact that it was ok for a week and a half suggests battery drainage.

Myk
(Moderator/Ride of the Month Coordinator)


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Thanks go to those that post problems, solutions & feedback. It all helps.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Smartop : Cubby Holder : Cree fronts : Both rear fogs : Clock Insert : Quicksilver exhaust



Useful R170 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R171 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Useful R172 diy:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Avel Du is offline  
#15 Old 03-09-2017
Registered Users
 
T-Bears's Avatar
 
Join Date: Apr 2016
Location: Rohnert Park CA
Vehicle: 2001 SLK 230 Kompressor AMG Sport Package
Other Toys: Kawasaki Ninja, 07 VW Rabbit 2.5
Posts: 40
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 0
Thanked 2 Times in 2 Posts
Garage
Yup, I agree look for a current drain. I remember my family would have that alarm issue and the culprit was the battery going bad. This was on a few Bimmers & an Audi which should be similar to our cars. I hope you find the problem.
T-Bears is offline  
#16 Old 04-02-2017
Registered Users
 
Join Date: May 2015
Location: Oak Hills, CA
Vehicle: 2003 SLK32 AMG
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Update -

No power drain whatsoever. The battery is 100%

I took the car back to the body shop that fixed the car (the alarm problem started after they fixed it). The body shop took it to a Mercedes "guy" and the alarm system got re-calibrated (???), it was fine for about 4 days. I took the car for a drive and stopped for some coffee and the alarm started going off again like crazy.

Took the car back to the shop and they said that they might just have to take it to Mercedes to figure out the problem. They did mention that this has happened before with some of the vehicles they repair.

Will update on the problem when I get it back.
JMSLK32AMG is offline  
#17 Old 04-20-2017
Registered Users
 
Join Date: May 2015
Location: Oak Hills, CA
Vehicle: 2003 SLK32 AMG
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
UPDATE -

Alarm still going off. The car went to a Mercedes "specialist." He diagnosed the problem as the alarm siren under the wiper spindles. I told him that the part had been changed already. To test out his diagnosis I unplugged the alarm siren altogether. I don't believe this is the problem because the lights still go off even with the alarm siren off. The lights go off randomly, sometimes when I walk out to the garage they are going off, just like they would have with the alarm siren off.

Any other ideas? Maybe setting the car on fire?

Thanks.
M4rCu5 likes this.
JMSLK32AMG is offline  
#18 Old 05-04-2017
Registered Users
 
Join Date: Sep 2012
Location: San Jose, CA
Vehicle: Black 2001 SLK320 Siam Beige interior
Posts: 41
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 0
Thanked 4 Times in 3 Posts
Well I think I am haunted by the same 'ghost in the machine'. Lights started flashing for no apparent reason, a few minutes after locking the car (2001 SLK320). I decided the sixteen year old battery in the alarm siren might be due for a replacement so I opened it up and replaced it, which was not easy at all. I guess I did fix the alarm siren; a few days later the light show was accompanied by a surprisingly loud siren, at about 6am on a Sunday morning.
I took a closer look at the PSE pump in the trunk, which was actually the first thing I checked, but then there had been zero signs of wetness around the pump or anywhere in the trunk for that matter. And the central locking has always worked flawlessly. But when I unplugged and inspected the black and the white connectors on the pump I saw very noticeable corrosion. Somehow water managed to get deep into the connectors and nowhere else.
I cleaned the connectors on the wiring harness, and removed the PSE pump and opened it up. Fortunately there were no signs of corrosion anywhere but the connectors so I cleaned them too. I put it all back together and bagged the pump to reduce the chance of it getting wet again.
Forgot to mention, ever since I bought the car there was a faint glow from the light on the anti-tow-away-override switch on the dash. I thought for sure my PSE pump connector cleanup would cure that, but no. If anything, it's a little worse; even throbs sometimes. So I unplugged the black connector on the PSE pump and the light went off. I bet that disabled the alarm completely, but at least the central locking still works (unless you unplug the white connector). I've gone a few days now without disturbing the peace. For for now at least until I stop being pissed off, I will run around with the black cable off. And shop for a PSE pump.
M4rCu5 and JMSLK32AMG like this.
Dean-o is offline  
#19 Old 05-06-2017
Registered Users
 
Join Date: May 2015
Location: Oak Hills, CA
Vehicle: 2003 SLK32 AMG
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Dean-O:


YES!!! That is exactly my problem, we are being haunted by the same "ghost." Thank you for your input on this issue. At the moment I have unplugged the #9 fuse so the lights don't go off, but I do not have central locking, interior lights, etc.

I think I will also follow your footsteps and disconnect the PSE pump black wires so I can have central locking again. I guess I will also have to start looking for a new PSE pump :/

Once again, thanks a million!
JMSLK32AMG is offline  
#20 Old 08-25-2019
Registered Users
 
Join Date: Aug 2019
Location: Central FL
Vehicle: '99 Mercedes SLK 230
Posts: 1
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy Help! Alarm keeps going off randomly.

My battery went dead on my SLK 230 recently because I wasn't driving it regularly. My battery was totally dead, so I got it replaced under the 5 yr, warranty (battery). However, the alarm (security) keeps going off intermittently when I try to drive it. No problems before the battery died. Will this problem go away after fully charged up driving it again, or do you think it is a sensor problem. please help! Thanks so much! Letha
Galwknd is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List




Similar Threads
Thread Thread Starter Forum Replies Last Post
Alarm issue help needed please. willydoit SLK R171 General Discussion 10 07-01-2019 05:11 PM
tow alarm reset issue BluBenz SLK R170 General Discussion 2 08-29-2014 07:23 PM
False Alarm Text Message from MBrace (Car Alarm)? mb911 SLK R171 General Discussion 4 07-04-2014 09:46 PM
R170 (SLK 230 2003) SmartTop alarm issues =( JaysonM General Modifications R170 9 03-10-2013 06:53 PM
Help! My alarm keeps going off randomly lombrozo SLK R170 General Discussion 6 05-09-2012 05:52 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.