Top Issue: Bad switch or user error? - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 04-03-2013
Registered Users
 
conleyjb's Avatar
 
Join Date: Feb 2013
Location: Tallahassee, Florida
Vehicle: 02 SLK 320 w/ AMG Sport package
Posts: 237
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 6
Thanked 32 Times in 20 Posts
(Thread Starter)
Top Issue: Bad switch or user error?

I've had my '02 SLK320 for about a month and a half now and I am the first to admit that there is still alot for me to learn about these cars. But I am starting to suspect I have a problem with the electrics in my top, specifically a switch or something.

I am having a problem putting the top back up from down once I have lowered it and left it down for a while. I have inquired on other forums as to specific sequences for putting the top up and down, but can not figure out what is wrong, and whether or not it is me or the sequence or something else. There is not issue with the hydrolics once the top starts up or down, its just getting the top switch to the solid red light when top is down and you want to raise it.

Scenerio:
Anytime the top is down for a period of time, usually after a drive, etc. regardless of windows being up/down, regardless of car being in gear, brake being applied or other; the top won't go up.

If the car is running I can not put the top back up. The only way for me to get it up in this scenerio is to cut the car off and back on. Once I have done this, I can put it up either with the engine running or car in accessory position.

Is this normal, or am I missing something; or is this an indication of another issue. i.e. top switch, brake position switch, etc?
conleyjb is offline  
Sponsored Links
Advertisement
 
#2 Old 04-03-2013
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spŕin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
Try cleaning up the contacts on the micro switches , grease the articulations of the roof mechanism ??
curro101 is offline  
#3 Old 04-03-2013
Premium Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: Daily driver 1998 SLK230 243,xxx miles
Posts: 3,505
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Thanks: 960
Thanked 527 Times in 415 Posts
Garage
here is a bunch on info on the top https://www.slkworld.com/r170/topoperation.htm
have a look at the troubleshooting guide in my signature, it will give you a good idea where the problem is.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Vario roof
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

R170 & R171
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
SLK 230 320 32AMG
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
leapyfish is offline  
 
#4 Old 04-03-2013
Registered Users

 
Der Flieger's Avatar
 
Join Date: Sep 2010
Location: Ottawa Ontario
Vehicle: silver/red 06 350
Other Toys: 2011 MB C 300 4matic! and 06 Mazda 3; fly B767-300ER
Posts: 6,796
Country:
Chats: 38
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 123 Post(s)
Thanks: 1,039
Thanked 820 Times in 659 Posts
Garage
Send a message via MSN to Der Flieger Send a message via Yahoo to Der Flieger
latches lubricated etc.
I'm with Curro on this one..sounds like micro switches perhaps...and by turning off and then back on you've reset them.

Definitely not normal or operator problem!


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

FUN 4 2
Der Flieger is offline  
#5 Old 04-08-2013
Registered Users
 
conleyjb's Avatar
 
Join Date: Feb 2013
Location: Tallahassee, Florida
Vehicle: 02 SLK 320 w/ AMG Sport package
Posts: 237
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 8 Post(s)
Thanks: 6
Thanked 32 Times in 20 Posts
(Thread Starter)
will run through the trouble guide and take a look at the LH and RH contact switches. What do you'all recommend to clean the contacts, Qutip and rubbing alcohol ?
conleyjb is offline  
#6 Old 04-08-2013
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spŕin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
Contact cleaner , sold as a spray !
curro101 is offline  
#7 Old 04-10-2013
Hopeless *** owner
 
stinger608's Avatar
 
Join Date: Apr 2013
Location: Cheyenne Wyoming
Vehicle: 1999 SLK 230 AMG
Posts: 102
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 65
Thanked 5 Times in 5 Posts
Garage
Quote:
Originally Posted by conleyjb View Post
will run through the trouble guide and take a look at the LH and RH contact switches. What do you'all recommend to clean the contacts, Qutip and rubbing alcohol ?
Quote:
Originally Posted by curro101 View Post
Contact cleaner , sold as a spray !
Either what Curro stated or just using WD40 should work. That is what WD40 was actually originally made for was an electrical cleaner.
stinger608 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP! ABS/BAS/ESP warning lights on and top problem ||SLK320|| SLK R170 General Discussion 36 08-22-2018 07:53 AM
hard top issue HELP PLEASE snake66 SLK R170 General Discussion 6 07-07-2009 05:50 PM
Gas Consumption SLK230 top up/down results SLKCop SLK R170 General Discussion 9 07-29-2008 12:09 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.