Dome Light Stays On Doors Shut - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 2Likes
  • 1 Post By SandradMrsp
  • 1 Post By CarolinaBluetec
 
LinkBack Thread Tools
#1 Old 03-18-2013
LRC
Registered Users
 
LRC's Avatar
 
Join Date: Mar 2013
Location: Seattle, Washington
Vehicle: 2001 SLK230 & 2007 ML350
Other Toys: Snowboard
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 10 Times in 3 Posts
(Thread Starter)
Dome Light Stays On Doors Shut

My dome light was working fine a few days ago but now stays on when both of the doors are shut. I searched the forums to see if I could find a way to troubleshoot the problem and found a lot of discussion regarding a part found behind the spare tire called the PSE. However, it seems I should start by checking the door switches. Problem is, I'm not exactly sure how to check them to see if they are still working without just replacing them. Any ideas?

Also, for background, I recently replaced the trunk struts and also a bulb in the dome light. But the dome light worked fine for a couple of days after doing both.

Much appreciated!!
-L
LRC is offline  
Sponsored Links
Advertisement
 
#2 Old 03-18-2013
MrG
Registered Users
 
Join Date: Aug 2011
Location: Texas
Vehicle: Black '02 SLK320
Other Toys: F250 4x4 Power Stroke Diesel, 22' boat
Posts: 246
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 56
Thanked 53 Times in 35 Posts
Garage
Check fuse #9 before you start digging into the PSE.
MrG is offline  
#3 Old 03-18-2013
LRC
Registered Users
 
LRC's Avatar
 
Join Date: Mar 2013
Location: Seattle, Washington
Vehicle: 2001 SLK230 & 2007 ML350
Other Toys: Snowboard
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 10 Times in 3 Posts
(Thread Starter)
Thanks MrG. I hopped in my car to drive to work this morning and noted two recent developments in the saga. With my doors shut, I hit the lock doors button on the console and it no longer works. It unlocks the doors still, but won't lock them. I do this every time I get into the car, so this is new as of this morning.

Also, the trunk stays locked now even if the doors are unlocked. So I now have to unlock the trunk with the keyfob switch from outside the car. This is getting weirder and weirder. I'm new to working on my car so this is all a mystery to me that I can hopefully solve.
LRC is offline  
 
#4 Old 03-18-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,929
Country:
Chats: 38
Mentioned: 473 Post(s)
Tagged: 5 Thread(s)
Quoted: 6572 Post(s)
Thanks: 3,246
Thanked 11,101 Times in 8,454 Posts
pse pump right woolly?


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#5 Old 03-18-2013
LRC
Registered Users
 
LRC's Avatar
 
Join Date: Mar 2013
Location: Seattle, Washington
Vehicle: 2001 SLK230 & 2007 ML350
Other Toys: Snowboard
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 10 Times in 3 Posts
(Thread Starter)
Hmmm. Seems to be a bigger problem than I was hoping. The Check Engine light just came on. Would that be triggered by the PSE pump malfunction too, Jeff?
LRC is offline  
#6 Old 03-18-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,929
Country:
Chats: 38
Mentioned: 473 Post(s)
Tagged: 5 Thread(s)
Quoted: 6572 Post(s)
Thanks: 3,246
Thanked 11,101 Times in 8,454 Posts
well, i am not the r170 guru and woolly always says the pse pump just handles 'vacuum' things, like locks, etc. someone hopefully will jump in


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#7 Old 03-19-2013
LRC
Registered Users
 
LRC's Avatar
 
Join Date: Mar 2013
Location: Seattle, Washington
Vehicle: 2001 SLK230 & 2007 ML350
Other Toys: Snowboard
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 10 Times in 3 Posts
(Thread Starter)
Another odd symptom occurred while I drove to work this morning. After driving only a few minutes at about 20 miles an hour, a loud two-tone beeping alarm sounded inside the car. I've never heard anything like it. It wasn't the theft alarm, nor the horn. It was electronic sounding. It continued for about 30 feet and stopped as I pulled over but before the car came to a stop.

If this is, along with the other symptoms, caused by the PSE pump's failure, then I would feel comfortable replacing it. But it may be something more than just the PSE pump. And if so, I think I'd want to take it in to a mechanic. Any ideas?

Thanks for your thoughts!
-L
LRC is offline  
#8 Old 03-19-2013
MrG
Registered Users
 
Join Date: Aug 2011
Location: Texas
Vehicle: Black '02 SLK320
Other Toys: F250 4x4 Power Stroke Diesel, 22' boat
Posts: 246
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 56
Thanked 53 Times in 35 Posts
Garage
PSE is located behind the jack. It's where the yellow lines come out in this pic. Those are the air lines coming from the PSE.

Check for any sign of moisture or water damage.

MrG is offline  
#9 Old 03-19-2013
LRC
Registered Users
 
LRC's Avatar
 
Join Date: Mar 2013
Location: Seattle, Washington
Vehicle: 2001 SLK230 & 2007 ML350
Other Toys: Snowboard
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 10 Times in 3 Posts
(Thread Starter)
Thanks MrG. I just got the car emissions tested -- required in WA for tabs -- and it failed. The code is P0410 secondary air injection system. Sounds like some kind of air pump. Could this also be linked to the PSE pump? If so, then it seems like the constellation of issues I'm having are at least related to one big expensive problem and not a series of big/small expensive problems. :P
LRC is offline  
#10 Old 03-19-2013
Registered Users
 
Join Date: Jan 2013
Location: The Sticks (Lincolnshire)
Vehicle: 2000 SLK 230
Other Toys: Audi TT
Posts: 333
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 18 Times in 17 Posts
I had random locking issues, alarm going off etc, and was directed to the PSE unit, but it turned out that I just needed to clean the contacts on the door microswitches. Check all the tiny issues first, the PSE unit is an expensive option.
MrG likes this.
SandradMrsp is offline  
#11 Old 03-21-2013
LRC
Registered Users
 
LRC's Avatar
 
Join Date: Mar 2013
Location: Seattle, Washington
Vehicle: 2001 SLK230 & 2007 ML350
Other Toys: Snowboard
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 10 Times in 3 Posts
(Thread Starter)
Update on status: WA state will give you a waiver with respect to a failure of the emissions test if you go to a certified emissions specialist and spend at least $150 trying to get it fixed. They give you a list of such specialists. Unfortunately, none of the mechanics recommended on this site are on there. So given the timing, I took it to the Benz dealer. They performed the B-service it desperately needed and told me that the car needed the following:

1. Dome light, console lock switch, trunk lock - PSE unit is bad. They checked all the microswitches and wiring prior. They offered to replace it for $2,500. Ouch. Needless to say, it's not getting replaced at the moment by them.

2. Emissions issue - all of the hardware was fine, they said it needed a software update. So they reset the computer and fixed that problem. Done.

3. My dash lights were out - they went in to change the bulbs but they were fine. Said the circuit board was going bad and would replace it for $1,200. Too expensive for the moment.

4. Fan belts - apparently two of my fan belts were cracked and about to fall off. They have replaced them.

5. Motor mounts - I noticed the idle was rough on my car. They said that one of the hydraulic motor mounts had leaked all of its fluid out. They offered to replace it for $820. Not doing this just yet.

So those are the issues that Benz found. I have been looking around but haven't found a place where I can get a replacement PSE unit. Anyone have any ideas? Would this be something that a non-Benz dealer mechanic could order and install?

Thanks everyone for your thoughts!!

-L
LRC is offline  
#12 Old 03-21-2013
Registered Users
 
Join Date: Jan 2013
Location: Greenville SC
Vehicle: 2008 E320 Bluetec(sold 11/14), 2001 SLK 320, 2013 E350
Other Toys: 1972 MGB, 2004 Volvo V70
Posts: 287
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 2
Thanked 37 Times in 33 Posts
Garage
A PSE is not terribly difficult to replace, there is quite a bit of information regarding its problems and replacement on this forum. You can order the part for $464.00 (Dealer retail $580) from these guys: mbwholesalepartsonline.com I have used them for new parts with good results.
I could probably replace one in 2-3 hours, and I am far from a professional mechanic. Most of the time is spent taking out panels and stuff from the trunk. Most independents that work on Mercedes, etc. could handle the job easily for $200-300 dollars.
CarolinaBluetec is offline  
#13 Old 03-22-2013
LRC
Registered Users
 
LRC's Avatar
 
Join Date: Mar 2013
Location: Seattle, Washington
Vehicle: 2001 SLK230 & 2007 ML350
Other Toys: Snowboard
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 10 Times in 3 Posts
(Thread Starter)
Thanks CarolinaBluetec! It appears mbwholesalepartsonline.com refers to the PSE pump just as a "vacuum pump". But I assume this is the right part. The pricing and location match. Their return policy is a bit harsh though -- maybe that's just normal in the industry?

I think most Benz mechanics can handle the motor mount for me so I will be having that done after calling around to a few places.

The good news is the dash circuit board is okay. I picked up the car yesterday and talked to the mechanic. He said he cleaned it up and got it working fine. The only issue is that it's an older car and eventually the board will need to be replaced. To be expected.

The best news is that the engine is in excellent condition and, with the tune-up, it purrrrrs again.
LRC is offline  
#14 Old 03-22-2013
Registered Users
 
Join Date: Jan 2013
Location: Greenville SC
Vehicle: 2008 E320 Bluetec(sold 11/14), 2001 SLK 320, 2013 E350
Other Toys: 1972 MGB, 2004 Volvo V70
Posts: 287
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 2
Thanked 37 Times in 33 Posts
Garage
That's it. I have found them to be very knowledgeable and give good service with fast response to e-mails.
LRC likes this.
CarolinaBluetec is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dome Light Stays On - SLK230 Donpagel SLK R170 General Discussion 15 03-31-2018 08:04 PM
Why Does my Interior Dome Light Fuse Keep blowing? DashingDaryl SLK R170 General Discussion 4 07-21-2011 12:17 AM
Dome light will not turn off / trunk latch related? new2slk SLK R170 General Discussion 9 01-11-2010 08:08 AM
Ambient light shut off time? st2288 SLK R171 General Discussion 5 05-03-2008 10:53 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.