Top not working - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 4Likes
Reply
 
LinkBack Thread Tools
#1 Old 01-19-2013
Registered Users
 
Join Date: Jul 2009
Location: Hickory NC
Vehicle: 1999 slk 230
Other Toys: 99 slk 230, 88 Bronco II, '01 E 430,2004 s 430 1955 TBird
Posts: 33
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Top not working

I just installed a front lock cylinder in my 99 230. It has been a couple weeks since it was removed and due to the recent rains here I couldnt get to installing it . But its in, but the top wont operate . No power at the pump. The switch is on and flashing red when I push it to get top to close but thats it. I tried to get top to work to see if there were any leaks or anything wrong but the whole thing is dead. I taped the switch in the trunk that the curtain closes to get top to operate and i have checked all I can think of but no luck. Any tips or inside info is appreciated.
I will go over everything one more time. But after that I dont know what else to check. I have put the top down manually and covered it with the car cover. It did get wet inside due to 6 days of rain but everything on the car works electrically . So I dont think its wetness. So if you can help I appreciate it. Thanks
Stuck in the Carolinas
red230 is offline  
Sponsored Links
Advertisement
 
#2 Old 01-19-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,207
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6496 Post(s)
Thanks: 3,232
Thanked 11,030 Times in 8,389 Posts
sounds like the pse pump is wet. there are some threads on that here recently so do a search before someone jumps in. one person just dried it with towels. good luck


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#3 Old 01-19-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,207
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6496 Post(s)
Thanks: 3,232
Thanked 11,030 Times in 8,389 Posts
https://www.slkworld.com/slk-r170-gen...h-dry-pse.html

some ideas/location and a pic

and from that link:

http://www.ebay.co.uk/itm/vacume-pum...d=440756148284


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
 
#4 Old 01-20-2013
Registered Users
 
Join Date: Jul 2009
Location: Hickory NC
Vehicle: 1999 slk 230
Other Toys: 99 slk 230, 88 Bronco II, '01 E 430,2004 s 430 1955 TBird
Posts: 33
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
where is this PSE located ?
red230 is offline  
#5 Old 01-20-2013
Sadly Woolly has passed away

 
Woolly's Avatar
 
Join Date: Jun 2006
Location: Co. Durham, UK
Vehicle: SLK350 MT
Other Toys: CLK 270CDI (Slushbox!!)
Posts: 17,375
Country:
Chats: 1297
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Thanks: 2,912
Thanked 3,515 Times in 2,416 Posts
Garage
RHS of the trunk, behind the trim, but the PSE pump has nothing to do with roof operations. It is a vacuum pump that operates the door, fuel flap and glove box locks.






To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

MB SLK 350 Andradite Green (6 speed manual)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Woolly is offline  
#6 Old 01-20-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,207
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6496 Post(s)
Thanks: 3,232
Thanked 11,030 Times in 8,389 Posts
He mentioned lock cylinder so I threw the pse in the mix


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#7 Old 01-20-2013
Registered Users
 
Join Date: Jul 2009
Location: Hickory NC
Vehicle: 1999 slk 230
Other Toys: 99 slk 230, 88 Bronco II, '01 E 430,2004 s 430 1955 TBird
Posts: 33
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Ok I was sitting in the car thinking of what I had checked and needed to re-check when I decided to start from square one. So, I relieved the pressure manually closed the top to the locked position . Then I manually closed the trunk. Made sure all was well then I closed the pressure relief port, made sure the switch was closed in the trunk . Then I started the thing up and hit the top operation button and it started working !!!! The windows came down the trunk opened up the front lock unlocked . Then nothing. The top wont come down the pump works and it will close but not open. I have lubed all the pivot points and such but ran out of daylight. I at least have something to do tomrrow. Top does fine manually open and close. Any ideas appreciated.
red230 is offline  
#8 Old 01-20-2013
Registered Users

 
Der Flieger's Avatar
 
Join Date: Sep 2010
Location: Ottawa Ontario
Vehicle: silver/red 06 350
Other Toys: 2011 MB C 300 4matic! and 06 Mazda 3; fly B767-300ER
Posts: 6,796
Country:
Chats: 38
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 123 Post(s)
Thanks: 1,039
Thanked 820 Times in 659 Posts
Garage
Send a message via MSN to Der Flieger Send a message via Yahoo to Der Flieger
I've not dealt with the roof hydraulics on our 171 and have no experience on the 170, but it being hydraulic, how did you clear out any/all air from the system? Is there a chance you have an air lock? I assume the level shows full?

It does sound like you're making progress; too bad it's taking so long.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

FUN 4 2
Der Flieger is offline  
#9 Old 01-20-2013
Premium Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: Daily driver 1998 SLK230 243,xxx miles
Posts: 3,505
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Thanks: 960
Thanked 527 Times in 415 Posts
Garage
It may be the bellows switch in the roof http://www.benzworld.org/forums/r170...f-bellows.html


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Vario roof
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

R170 & R171
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
SLK 230 320 32AMG
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
leapyfish is offline  
#10 Old 01-20-2013
Sadly Woolly has passed away

 
Woolly's Avatar
 
Join Date: Jun 2006
Location: Co. Durham, UK
Vehicle: SLK350 MT
Other Toys: CLK 270CDI (Slushbox!!)
Posts: 17,375
Country:
Chats: 1297
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 120 Post(s)
Thanks: 2,912
Thanked 3,515 Times in 2,416 Posts
Garage
Quote:
Originally Posted by Der Flieger View Post
I've not dealt with the roof hydraulics on our 171 and have no experience on the 170, but it being hydraulic, how did you clear out any/all air from the system? Is there a chance you have an air lock?
The pumps on the R170 and R171 are allegedly self-priming.






To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

MB SLK 350 Andradite Green (6 speed manual)

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


Woolly is offline  
#11 Old 01-22-2013
Registered Users
 
Join Date: Jul 2009
Location: Hickory NC
Vehicle: 1999 slk 230
Other Toys: 99 slk 230, 88 Bronco II, '01 E 430,2004 s 430 1955 TBird
Posts: 33
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
top not working

I loosened the brass fitting on the side of the top pump in the trunk to releive the pressure . I read somplace in all the posts that the system is self priming so I didnt worry about it.

Should I take the bellows switch out and clean it or throw it away? what does it actually do ? MB didnt put it there to do nothing.

very cold here today so I didnt work on top. Colder tomorrow. may be weekend before I get to it . But top does go up and down fine manually. Just taking a long time to get this thing working. the car I gave to my Grandaughter and she wants it . I started out getting it to run then the top started leaking . Got cylinder fixed. 7 days ofd rain and so on. But I am down to the wire and I just am going slow here. So sooner or later it wil be working right. Thanks for all the help.
red230 is offline  
#12 Old 01-24-2013
Registered Users
 
Join Date: Jul 2009
Location: Hickory NC
Vehicle: 1999 slk 230
Other Toys: 99 slk 230, 88 Bronco II, '01 E 430,2004 s 430 1955 TBird
Posts: 33
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
top not working

Ok so when I move switch to open the top the trunk opens up ,the front latch unlocks . Thats it . The pump stops working . I can push on the top but nothing helps. So, my thought is a switch someplace not operating properly. What other switches are there ? I will locate them and see what happens. But I need to know if my thoughts are right. I have cleaned and oiled the joints on all the linkage as a possibility but nothing happened. This led me to believe its a switch someplace
red230 is offline  
#13 Old 01-25-2013
Premium Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: Daily driver 1998 SLK230 243,xxx miles
Posts: 3,505
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Thanks: 960
Thanked 527 Times in 415 Posts
Garage
Heres where all the switches etc are https://www.slkworld.com/r170/topoperation.htm


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Vario roof
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

R170 & R171
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
SLK 230 320 32AMG
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
leapyfish is offline  
#14 Old 01-25-2013
Registered Users
 
Join Date: Apr 2012
Location: Houston, TX
Vehicle: Mercedes SLK 230 2003
Posts: 1,613
Country:
Chats: 0
Mentioned: 11 Post(s)
Tagged: 0 Thread(s)
Quoted: 44 Post(s)
Thanks: 226
Thanked 378 Times in 265 Posts
Garage
Question

Hmmm... I was wondering if anyone knows if OBD scanners will read faulty codes for the roof switches/top operation in general!? I think this info should be sent to the ECU for easy diagnostics. Does anyone know or tried?!
JaysonM is offline  
#15 Old 01-25-2013
Registered Users

 
sokoloff's Avatar
 
Join Date: Jun 2009
Location: Ocean Isle Beach, NC
Vehicle: 2003 SLK320 31,000 miles
Posts: 1,314
Country:
Chats: 3
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Thanks: 27
Thanked 231 Times in 161 Posts
Garage
Quote:
Originally Posted by JaysonM View Post
Hmmm... I was wondering if anyone knows if OBD scanners will read faulty codes for the roof switches/top operation in general!? I think this info should be sent to the ECU for easy diagnostics. Does anyone know or tried?!
I'm not even sure if the proprietary Mercedes computer systems will read roof switch issues, but I'm fairly certain that generic type scanners won't.

Len
2003 SLK320 40,000 miles - now lives in Tucson with my daughter
1959 220S Cabriolet - sold - now lives in Malta
1983 240D 351,000 miles original owner - sold
1999 E300D 215,000 miles
2014 Smart electric 17,000 miles
2014 Smart electric 9,000 miles
sokoloff is offline  
#16 Old 01-27-2013
Registered Users
 
Join Date: Jul 2009
Location: Hickory NC
Vehicle: 1999 slk 230
Other Toys: 99 slk 230, 88 Bronco II, '01 E 430,2004 s 430 1955 TBird
Posts: 33
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
top not working

Ok so today I braved the cold and went outside to tackle the issue with the top not working . I started on the wiring at the latches. About 3" from the passenger latch mechanism micro switch is a clip that held the wiring . The wiring was pinched as was being held in the retaining clip. At least it seemed so. I carefully cut the rubber protective cover off the blue and brown wires and found the blue wire had indeed been pinched and had over time of the top going up and down had broken the wire allowing it to prevent the top from moving. I spliced the wire back together and now the top works perfectly. I attached the wire with a ziptie instead of putting it back inthe metal clip. Now it can move when the top is opening and closing. Thanks to everyone who had some advice on this dilema . I learned so much about the car through these replies . Still think the Benz is the best car on the road. Despite what you have to do to them form time to time. Thanks again to all .
red230 is offline  
The Following User Says Thank You to red230 For This Useful Post:
#17 Old 01-27-2013
Registered Users
 
Thal's Avatar
 
Join Date: Jan 2013
Location: Norfolk, UK
Vehicle: Sport 2010 Obs Black SLK 350
Other Toys: Old petrol Porsche Cayenne; Sit-on John Deere mower :D
Posts: 161
Country:
Chats: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 13
Thanked 4 Times in 4 Posts
Garage
well done!
Thal is offline  
#18 Old 04-05-2013
Hopeless *** owner
 
stinger608's Avatar
 
Join Date: Apr 2013
Location: Cheyenne Wyoming
Vehicle: 1999 SLK 230 AMG
Posts: 102
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 65
Thanked 5 Times in 5 Posts
Garage
Quote:
Originally Posted by red230 View Post
Ok so today I braved the cold and went outside to tackle the issue with the top not working . I started on the wiring at the latches. About 3" from the passenger latch mechanism micro switch is a clip that held the wiring . The wiring was pinched as was being held in the retaining clip. At least it seemed so. I carefully cut the rubber protective cover off the blue and brown wires and found the blue wire had indeed been pinched and had over time of the top going up and down had broken the wire allowing it to prevent the top from moving. I spliced the wire back together and now the top works perfectly. I attached the wire with a ziptie instead of putting it back inthe metal clip. Now it can move when the top is opening and closing. Thanks to everyone who had some advice on this dilema . I learned so much about the car through these replies . Still think the Benz is the best car on the road. Despite what you have to do to them form time to time. Thanks again to all .

Interesting find Red! I have a similar issue where all the windows go down, trunk opens, I see the Hex head whatsit in the center turn, but the locks do not release. I will look into the wiring as you did.

If anyone has other ideas I am sure open to suggestions.

I just purchased the vehicle and its a 1999 SLK230 AMG

thanks in advance,
Stinger
stinger608 is offline  
#19 Old 04-06-2013
Registered Users
 
Join Date: Oct 2012
Location: Kent, England
Vehicle: SLK32 AMG (2002)
Other Toys: Yamaha FZ1 (gen1) and DRZ400E
Posts: 307
Country:
Chats: 0
Mentioned: 10 Post(s)
Tagged: 0 Thread(s)
Quoted: 43 Post(s)
Thanks: 91
Thanked 32 Times in 22 Posts
Garage
Quote:
Originally Posted by red230 View Post
Ok so today I braved the cold and went outside to tackle the issue with the top not working . I started on the wiring at the latches. About 3" from the passenger latch mechanism micro switch is a clip that held the wiring . The wiring was pinched as was being held in the retaining clip. At least it seemed so. I carefully cut the rubber protective cover off the blue and brown wires and found the blue wire had indeed been pinched and had over time of the top going up and down had broken the wire allowing it to prevent the top from moving. I spliced the wire back together and now the top works perfectly. I attached the wire with a ziptie instead of putting it back inthe metal clip. Now it can move when the top is opening and closing. Thanks to everyone who had some advice on this dilema . I learned so much about the car through these replies . Still think the Benz is the best car on the road. Despite what you have to do to them form time to time. Thanks again to all .
Have you got a photo please of the bit you did?

Steve
steve pring is offline  
#20 Old 04-09-2013
Registered Users
 
Join Date: Jun 2011
Location: Cincinnati
Vehicle: 1999 SLK 230, 2001 ML55 AMG
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 12
Thanked 35 Times in 17 Posts
Garage
stinger use some WD-40 on the roof microswitches. should help loosen the bellows and may fix your problem.
pemsland is offline  
The Following User Says Thank You to pemsland For This Useful Post:
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Will a Smart top work on my car? simplyslk SLK R170 General Discussion 29 04-01-2012 01:02 PM
hard top lovers what is wrong with a Soft Top? Berliner Heckflosse Off Topic 30 02-18-2012 01:14 PM
98 slk 230 top wont go up mike jackson New Members Introduce Yourself Here 6 10-17-2011 02:22 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.