2003 SLK 230 Electrical Issues - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 12-27-2012
Registered Users
 
Join Date: Dec 2012
Location: Mansfield, England
Vehicle: 2003 Black SLK 230 Automatic
Posts: 2
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
(Thread Starter)
2003 SLK 230 Electrical Issues

Hi all,
I have a 2003 SLK, 230 Automatic which seems to have an issue, which has already cost me a fair whack on a suspected replacement part which hasn't worked, so hoping for advice from other owners.

I seem to have some sort of electrical problem. The indicators stopped working, and on came the orange light to suggest a bulb has blown. This happened five or ten mins in to my journey, and happens most times I drive the car now. It never happens when I turn the car on, always several minutes in to the journey.
Now when I turn the hazards on they all work fine. After a while the indictors will randomly start working again.
I took it to a Mercedes specialist, but the indicators were working, and he could only diagnose a suspected faulty multi function control module. The part was the best part of 500 so had to go without for a few weeks and save up.
In the mean time, it seemed as though a bulb had gone, and off to Halfords I went and bought the bulb, and paid them the 3.99 to fit, as I was in work attire, but after a few moments the chap said it wasn't the bulb that was an issue, there was no current going to the front light.
The problem was left with one normal light and one dull light that intermittently worked also.
The time came when I got the multi function control module, this got fitted, I drove off promising the SLK as I was driving her, that I would treat her now she was fixed, but minutes later, the indicators stop again, back to square one.
Must also add I have replaced all the fuses in the fuse box also.

To summarise;
Indicators stop working after 5/10 mins
Hazard lights continue to work
Always works when I first start up the car in the morning
Randomly start working again after an undefined period of time
Not the multi function control unit
Not a fuse or bulb issue

Any help would be massively appreciated, it was a huge blow paying the 500 plus lbour just before Christmas, so want to make sure I get it right this time
colinholmes is offline  
Sponsored Links
Advertisement
 
#2 Old 12-27-2012
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,744
Country:
Chats: 0
Mentioned: 109 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,297 Times in 1,138 Posts
Garage
Check out this post , it may give you a couple of ideas !

http://www.benzworld.org/forums/r170...nal-relay.html
curro101 is offline  
The Following User Says Thank You to curro101 For This Useful Post:
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
SLK 10th year special edition Zut SLK R171 General Discussion 46 02-27-2015 06:58 PM
SLK 230 & Kompressor Badges - Suggestions on where to find? peabody Where to get R170 SLK Items 15 08-21-2012 10:32 PM
New Owner's Impressions - 2000 SLK 230 Kompressor Godfrey SLK R170 General Discussion 43 06-04-2012 12:39 PM
New Car today, from SLK 230 to SKL 350... HBK SLK R171 General Discussion 20 03-31-2012 09:47 PM
SLK X 2 (long post) -1- SLK R171 General Discussion 29 04-01-2007 11:42 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.