0-60 in 18sec QQ - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 12-23-2012
Registered Users
 
king.stivan's Avatar
 
Join Date: Oct 2012
Location: kuwait
Vehicle: SLK 230 R170 1998
Posts: 95
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 7
Thanked 6 Times in 5 Posts
Send a message via Skype™ to king.stivan
(Thread Starter)
0-60 in 18sec QQ

i drove on a puddle the other day and my car got worse ... it use to do 0-60 in 11sec now its 18 ..... the funny thing when i unplug the MAF i get 1 sec less :S ya now that i read whats going on with me i guess i need a new MAF sensor :S bb my money QQ
king.stivan is offline  
Sponsored Links
Advertisement
 
#2 Old 12-27-2012
Registered Users
 
king.stivan's Avatar
 
Join Date: Oct 2012
Location: kuwait
Vehicle: SLK 230 R170 1998
Posts: 95
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 7
Thanked 6 Times in 5 Posts
Send a message via Skype™ to king.stivan
(Thread Starter)
so i went and bought a new MAF sensor and the car now dose the 0-60 in 13sec yes its faster but its x2 as slow as it should be ...... i dont think the SC kicks in anymore :S
king.stivan is offline  
#3 Old 01-01-2013
Registered Users
 
Join Date: Jul 2010
Location: Colleyville, TX
Vehicle: '99 SLK230
Other Toys: Porsche 356 Roadster, Scott CR1, '65 230SL
Posts: 3
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
When my kompressor failed to kick in, it was the K40 relay. I resold erred according to the instructions in the sticky, and all was well. Check it out.
rwhyde is offline  
The Following User Says Thank You to rwhyde For This Useful Post:
 
#4 Old 01-01-2013
Registered Users
 
Join Date: Jul 2010
Location: Colleyville, TX
Vehicle: '99 SLK230
Other Toys: Porsche 356 Roadster, Scott CR1, '65 230SL
Posts: 3
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
That was resoldered. Sheesh this spellcheck,...
rwhyde is offline  
#5 Old 04-12-2013
Registered Users
 
king.stivan's Avatar
 
Join Date: Oct 2012
Location: kuwait
Vehicle: SLK 230 R170 1998
Posts: 95
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 7
Thanked 6 Times in 5 Posts
Send a message via Skype™ to king.stivan
(Thread Starter)
sorry it took me forever to come back to here . i did re-soldier the K40 and in fact i hooked the S/C to work all the time now and its just a bit better just a bit infact its about the same .... new fuel bump now filter new many things and its the same any ideas ??
king.stivan is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.