Check Engine Light - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 1Likes
  • 1 Post By cwickgo9
 
LinkBack Thread Tools
#1 Old 11-29-2012
Registered Users
 
Join Date: Oct 2010
Location: Dallas, Texas
Vehicle: 2001 SLK 320
Other Toys: HD UltraClassic
Posts: 28
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 5
Thanked 5 Times in 1 Post
(Thread Starter)
Check Engine Light

Nice day yesterday, mid-60's, SLK humming fine. Stopped at last stop light before entrance ramp. Light changes, and of course, I'm behind the slowest person in the world leaving the line. After waiting for the other lanes to clear, I hammer down, get around the moving speed bump, running up to about 90 getting onto the on-ramp and motivating down the highway for maybe 30 seconds, before dropping back down to 70.
At which point the CHECK ENGINE light comes on. It feels relatively okay, and I exit in about 5 miles. At the light, I can tell something is not right. She is idling rough and poor throttle response, almost like she's not getting fuel or a coil pack is dropping out. I limp home a mile away at 30+ MPH and park and shut her down. Under the hood, nothing glaring other than a bit low on oil (she'd due for a change).
I start her back up and she's back purring like before. I run up the street and back, still good. Drive out to dinner and show later, again, good to go.
Only problem now is - stupid light is still on.
A) Any ideas as to what might have happened?
B) How can I turn the light off?
C) I have flexible maintenance, how can I reset the clock for the oil change?
cwickgo9 is offline  
Sponsored Links
Advertisement
 
#2 Old 11-29-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,141
Country:
Chats: 38
Mentioned: 458 Post(s)
Tagged: 5 Thread(s)
Quoted: 6492 Post(s)
Thanks: 3,232
Thanked 11,022 Times in 8,381 Posts
Welcome to the World’s Premier Mercedes-Benz SLK Community from Valrico, Florida!


Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’.

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.




If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message)- capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
New members and guests should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under quick links when you leave.
Also vote or enter our Ride of the Month competition: https://www.slkworld.com/rotm-submissions-voting/

Thank you,
Jeff
Moderator/Founding Member


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#3 Old 11-29-2012
Registered Users
 
Join Date: Oct 2010
Location: Dallas, Texas
Vehicle: 2001 SLK 320
Other Toys: HD UltraClassic
Posts: 28
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 5
Thanked 5 Times in 1 Post
(Thread Starter)
intro

Odd - I joined, as you can see, over 2 years ago, having brought over some information I had that I had previously posted on the BENZWORLD forum.
I do see now that my vehicle is not public, so I made that change.
I'm not sure why it does not show my previous posts as it contained the information for both the jack-point "pucks" and the rubber bumper in the trunk that supported the roof when stowed.
At any rate, my appologies if I offended anyone.
cwickgo9 is offline  
 
#4 Old 11-29-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,141
Country:
Chats: 38
Mentioned: 458 Post(s)
Tagged: 5 Thread(s)
Quoted: 6492 Post(s)
Thanks: 3,232
Thanked 11,022 Times in 8,381 Posts
info in garage does not communicate with the info in your profile on left side. sent you pm


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#5 Old 11-29-2012
Registered Users

 
Gbarringer100's Avatar
 
Join Date: May 2009
Location: Little River, SC
Vehicle: 2007 SLK350 BLK/BLK
Other Toys: 2016 GLA250
Posts: 2,309
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Thanks: 12
Thanked 404 Times in 350 Posts
Garage
You need to have the codes read and that will tell you what is the problem. You do not show where you live. If in the US you can go to the big auto parts chains and most will do a reading for you. The codes will tell you what was/is the problem. You might want to reset the codes and see if it comes back. Could be a rare thing that happen and not a problem.
Gbarringer100 is offline  
The Following User Says Thank You to Gbarringer100 For This Useful Post:
#6 Old 11-29-2012
Registered Users
 
Join Date: Oct 2010
Location: Dallas, Texas
Vehicle: 2001 SLK 320
Other Toys: HD UltraClassic
Posts: 28
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 5
Thanked 5 Times in 1 Post
(Thread Starter)
Thanks. Jeff explained the issue with the locale and car - fixed!

I'll stop by the zone or other chain and have them pull it. Do they all have the adapter for the Benz or should I call first?
jbanks15 likes this.
cwickgo9 is offline  
#7 Old 11-29-2012
Registered Users

 
sokoloff's Avatar
 
Join Date: Jun 2009
Location: Ocean Isle Beach, NC
Vehicle: 2003 SLK320 31,000 miles
Posts: 1,314
Country:
Chats: 3
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Thanks: 27
Thanked 231 Times in 161 Posts
Garage
Resetting service indicator and resetting clock info are both in your owners manual and probably on the forum somewhere via a search. Both pretty easy to do.

Len
2003 SLK320 40,000 miles - now lives in Tucson with my daughter
1959 220S Cabriolet - sold - now lives in Malta
1983 240D 351,000 miles original owner - sold
1999 E300D 215,000 miles
2014 Smart electric 17,000 miles
2014 Smart electric 9,000 miles
sokoloff is offline  
The Following User Says Thank You to sokoloff For This Useful Post:
#8 Old 11-29-2012
Registered Users
 
Join Date: Oct 2010
Location: Dallas, Texas
Vehicle: 2001 SLK 320
Other Toys: HD UltraClassic
Posts: 28
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 5
Thanked 5 Times in 1 Post
(Thread Starter)
AutoZone pulled the codes and reset the light.
Appears the #4 cylinder dropped out when I was doing my high-speed run. It also said something like it needed a tune up. With 147K miles, it probably has the same plugs and wires. The coil pack on #4 may have dropped out.
cwickgo9 is offline  
#9 Old 11-29-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,141
Country:
Chats: 38
Mentioned: 458 Post(s)
Tagged: 5 Thread(s)
Quoted: 6492 Post(s)
Thanks: 3,232
Thanked 11,022 Times in 8,381 Posts
So now you have your game plan!


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#10 Old 11-29-2012
Registered Users

 
Gbarringer100's Avatar
 
Join Date: May 2009
Location: Little River, SC
Vehicle: 2007 SLK350 BLK/BLK
Other Toys: 2016 GLA250
Posts: 2,309
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Thanks: 12
Thanked 404 Times in 350 Posts
Garage
Quote:
Originally Posted by cwickgo9 View Post
AutoZone pulled the codes and reset the light.
Appears the #4 cylinder dropped out when I was doing my high-speed run. It also said something like it needed a tune up. With 147K miles, it probably has the same plugs and wires. The coil pack on #4 may have dropped out.

They cleared the codes. Time will tell if you have a problem or it was a glich. Sometimes there is a glich and the cars computer will register it and turn on the check engine light and does not happen again. If comes on again very soon than you have a problem that needs repair work. You read the codes again and it is again #4 cylinder dropped then look at the items you mentioned. You could swap the coil pack with another cylinder and see you get a reading that the swapped cylinder was dropped. If so then it is the coil pack if it is still #4 then time for wires and plugs. I hope it was just a glich.
Gbarringer100 is offline  
#11 Old 11-29-2012
Registered Users

 
Gbarringer100's Avatar
 
Join Date: May 2009
Location: Little River, SC
Vehicle: 2007 SLK350 BLK/BLK
Other Toys: 2016 GLA250
Posts: 2,309
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Thanks: 12
Thanked 404 Times in 350 Posts
Garage
Quote:
Originally Posted by sokoloff View Post
Resetting service indicator and resetting clock info are both in your owners manual and probably on the forum somewhere via a search. Both pretty easy to do.

The codes to reset/clear are the ones for the check engine light turned on by the cars computer. You use a ODB2 reader to do this.
Gbarringer100 is offline  
#12 Old 11-30-2012
Registered Users
 
Join Date: Oct 2010
Location: Dallas, Texas
Vehicle: 2001 SLK 320
Other Toys: HD UltraClassic
Posts: 28
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 5
Thanked 5 Times in 1 Post
(Thread Starter)
I ordered plugs and wires since they are over 11 years old with 147K on them.
The code they printed out: P0304 Number 4 misfire detected
This would explain the rough running and idle when I exited. However, from my way of thinking, plugs and wires should not magically start working again after a shutdown. I am more inclined to think it is something more electrically controlled. Unfortunately, the coil pack is not that "technical", it should fire when it gets a signal from the ingnition system/control module - which leads me to be wary of the ECM or ignition module.
We'll get the plugs and wires in and then we'll "wait and see". Since I will probably move the coil pack rail out of the way when doing it, I may follow the advice and swap the #4 coil pack with another on that side just to see if it is a weak link.
cwickgo9 is offline  
#13 Old 12-01-2012
Registered Users
 
Barchetta's Avatar
 
Join Date: Nov 2012
Location: Biddeford, Maine
Vehicle: 1999 SLK230
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
It is more likely to be a coil pack than plugs/wires. Coil packs don't stand up to heat very well over time and will develop small fatigue cracks. They will often start to fail intermittently at first and get worse over time.

Although the coil packs are fairly well shrouded on the 320, never hose your engine down when it's hot. Hitting a hot coil pack with cold water will eventually cause it to develop thermal cracks, suck in water and short the coil.

Swapping coil packs with another cylinder (as someone suggested) is a good idea at determining if it's the coil, plug, wiring, etc. On modern engines they don't use plug wires anymore. The coil packs plug directly onto the spark plugs and a low voltage signal is used to fire it so there are no longer any high voltage wires that can break down like on older engines.

Hope this helps,
Rob
Barchetta is offline  
The Following User Says Thank You to Barchetta For This Useful Post:
#14 Old 12-10-2012
Registered Users
 
docleo's Avatar
 
Join Date: Nov 2011
Location: Abu Dhabi UAE
Vehicle: 2002 SLK230 Black
Other Toys: 85' Mazda RX-7, 02' VW Beetle Turbo, 01' Yamaha Waverunner GP1300R, 97' Seadoo GSX
Posts: 11
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Hi there, my check engine light came on also this morning when i push the throttle hard, then immediately i park the car and check. It seem no problem with engine, it response as normal, what i'm worried is the check engine light, i drove 55miles and it's not turning off, i will check later after work if the light still there. my car was R170 SLK230 2002 from US shift here in United Arab Emirates and now it's 66
Degrees Fahrenheit here. Do you think what cause this light to turn on this is the first time. Thank you in advanced.
docleo is offline  
#15 Old 12-10-2012
Registered Users
 
Barchetta's Avatar
 
Join Date: Nov 2012
Location: Biddeford, Maine
Vehicle: 1999 SLK230
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
You are fine to drive the car with the CEL on. It only has to do with emissions related faults. You will need to read the fault code with an OBDII reader and report back. There may be more than one. Most auto parts stores will pull the codes for you for free if you don't have access to one.

Rob
Barchetta is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Tags
check engine light

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine check light missing...... JustinJoyit SLK R170 General Discussion 4 04-19-2012 09:24 PM
Check Engine Light ON HwoALanG SLK R171 General Discussion 21 04-16-2012 09:34 PM
Check Engine Light Issue Smitty General Discussion 2 10-25-2010 05:14 PM
Check engine light on - fault code # 0064 smarciano1 SLK R171 General Discussion 1 05-22-2010 10:03 AM
check engine light myslk230 SLK R170 General Discussion 4 05-27-2008 02:26 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.