1999 SLK230 supercharger clutch - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 11-26-2012
Registered Users
 
Barchetta's Avatar
 
Join Date: Nov 2012
Location: Biddeford, Maine
Vehicle: 1999 SLK230
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
(Thread Starter)
1999 SLK230 supercharger clutch

Sorry, I know this subject has been beat to death but I didn't find any threads discussing my particular problem. The clutch engages during cold start for 60-90 sec like it's supposed to but never disengages like it supposed to below 2k....basically runs all the time (unless I unplug the round connector).

The car is not responsive and has little power so I'm guessing the bypass valve is staying open all the time but I haven't verified this. It throws P1236 & P0410 codes. I bought the car with this issue so I don't know what kind of power it should have but I would expect more than it does. It has 116k. Any ideas??

***UPDATE*** Wow, I guess not too many tech folks on this site or they are all tired of talking about this problem. I'll just document my troubleshooting method in hopes someone else may benefit.

So just turning on the ignition with the car not running engages the s/c clutch. I'm thinking a transistor in the ECM but I don't have a schematic. Because of the current that the clutch coils draws, there has to be a transistor/power amp being driven by a control signal. My experience with these is they will fail "shorted".

I don't suspect the K40 relay module since they are mechanical relays and they usually fail open (I checked anyway to make sure no contacts were stuck shut). From what I've read, the relay supplies the 12v to the coil and the ECM grounds the return....just need to trace that back thru. A schematic sure would help.

Rob

Last edited by Barchetta; 11-28-2012 at 09:25 AM.
Barchetta is offline  
Sponsored Links
Advertisement
 
#2 Old 11-26-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 90,805
Country:
Chats: 38
Mentioned: 455 Post(s)
Tagged: 5 Thread(s)
Quoted: 6478 Post(s)
Thanks: 3,222
Thanked 10,995 Times in 8,357 Posts
Welcome to the World’s Premier Mercedes-Benz SLK Community from Valrico, Florida!




You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.




If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message)- capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
New members and guests should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under quick links when you leave.
Also vote or enter our Ride of the Month competition: https://www.slkworld.com/rotm-submissions-voting/

Thank you,
Jeff
Moderator/Founding Member


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 12-01-2012
Registered Users
 
Barchetta's Avatar
 
Join Date: Nov 2012
Location: Biddeford, Maine
Vehicle: 1999 SLK230
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
(Thread Starter)
OK no real updates here since I haven't had time to work on it. The car is coming off the road for the winter next week so I'll dig into the ECM then. That way if I blow something I've got a few months to fix it.
Barchetta is offline  
 
#4 Old 12-01-2012
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,100
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,088
Thanked 1,292 Times in 1,143 Posts
Garage
Please keep us posted and take some pictures of your findings for other folks to reference. Thanks
Livefreeordie is offline  
#5 Old 12-03-2012
Registered Users
 
Barchetta's Avatar
 
Join Date: Nov 2012
Location: Biddeford, Maine
Vehicle: 1999 SLK230
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
(Thread Starter)
I got a chance to open up the ME-SFI (ECM) to see if I could trace conn K, pin 21 to the bad transistor. Unfortunately it's a multi-layer board and is impossible to follow many of the traces so I'm stuck again. If anyone has a schematic for this that would be super!

I've attached a few pics of the board.....and yes the car still runs after putting it all back together.

Rob
Attached Images
File Type: jpg ME-SFI 1.jpg (109.8 KB, 32 views)
File Type: jpg ME-SFI 2.jpg (101.5 KB, 19 views)
File Type: jpg ME-SFI 3.jpg (105.8 KB, 15 views)
Barchetta is offline  
#6 Old 12-06-2012
Registered Users
 
Barchetta's Avatar
 
Join Date: Nov 2012
Location: Biddeford, Maine
Vehicle: 1999 SLK230
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
(Thread Starter)
P0410 code gone...

I was able to eliminate P0410 by replacing a split vacuum hose going to the air pump switchover solenoid valve. Eventually I will replace all vac line tubing....especially the hard plastic ones which are brittle and break very easily. Since I can't troubleshoot the EMU any further (without a schematic), I checked to make sure the clutch coil wasn't shorted to ground on the return side and it was fine. Getting about 4.0 ohms across the coil so that's fine.
Barchetta is offline  
#7 Old 01-02-2013
Registered Users
 
Join Date: Jan 2013
Location: Southern California
Vehicle: 99 SLK230
Posts: 14
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Any luck with this?

Hi Barchetta. I have the EXACT same situation with my 99 SLK230. Any luck so far?

Clutch checks out good. I too suspect the ECU. I have eliminated the K40 as a possibility (it seems to supply the + voltage, while the - connection on/off is controlled through the ECU. Like you, I took my ECU apart. Don't see anything burned. I agree...an ECU schematic would be great!
Katz is offline  
#8 Old 01-02-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 90,805
Country:
Chats: 38
Mentioned: 455 Post(s)
Tagged: 5 Thread(s)
Quoted: 6478 Post(s)
Thanks: 3,222
Thanked 10,995 Times in 8,357 Posts
have you guys checked leapy fish sig block here:

https://www.slkworld.com/353554-post8.html


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#9 Old 01-03-2013
Registered Users
 
Join Date: Jan 2013
Location: Southern California
Vehicle: 99 SLK230
Posts: 14
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by jbanks15 View Post
have you guys checked leapy fish sig block here:

https://www.slkworld.com/353554-post8.html
Thank you, Jeff! Leapyfish has supplied an interesting lead. I will need to do some more testing.

This looks like a great forum. Glad I joined!
Katz is offline  
#10 Old 01-05-2013
Registered Users
 
Barchetta's Avatar
 
Join Date: Nov 2012
Location: Biddeford, Maine
Vehicle: 1999 SLK230
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
(Thread Starter)
Quote:
Originally Posted by Katz View Post
Hi Barchetta. I have the EXACT same situation with my 99 SLK230. Any luck so far?

Clutch checks out good. I too suspect the ECU. I have eliminated the K40 as a possibility (it seems to supply the + voltage, while the - connection on/off is controlled through the ECU. Like you, I took my ECU apart. Don't see anything burned. I agree...an ECU schematic would be great!
Hi Katz,

Check out this thread on BenzWorld for updated info on this issue....I've been working with a chap from the UK on this.

http://www.benzworld.org/forums/r170...-please-2.html

I've found that SLKWorld is more geared towards folks that enjoy polishing their cars and doing cosmetic upgrades. BenzWorld has more tech savy folks that like to dig in and troubleshoot problems vs. going to the dealer or an indy for repairs.....just my opinion though.

Last edited by Barchetta; 01-05-2013 at 10:30 AM. Reason: sp
Barchetta is offline  
#11 Old 01-05-2013
Registered Users
 
Barchetta's Avatar
 
Join Date: Nov 2012
Location: Biddeford, Maine
Vehicle: 1999 SLK230
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Garage
(Thread Starter)
Quote:
Originally Posted by jbanks15 View Post
have you guys checked leapy fish sig block here:

https://www.slkworld.com/353554-post8.html
Yes, thanks. Good basic overview stuff on the car. Nothing too technical though.
Barchetta is offline  
#12 Old 01-07-2013
Registered Users
 
Join Date: Jan 2013
Location: Southern California
Vehicle: 99 SLK230
Posts: 14
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Quote:
Originally Posted by Barchetta View Post
Hi Katz,

Check out this thread on BenzWorld for updated info on this issue....I've been working with a chap from the UK on this.

http://www.benzworld.org/forums/r170...-please-2.html

I've found that SLKWorld is more geared towards folks that enjoy polishing their cars and doing cosmetic upgrades. BenzWorld has more tech savy folks that like to dig in and troubleshoot problems vs. going to the dealer or an indy for repairs.....just my opinion though.
Thanks, Barchetta. Great information! Looks like I should also join BenzWorld.

I suspect that I will need to go the same route, since F21 is constantly grounded. The thought of doing ECU repair is a little scary, but since I managed to open it up and then reinstall it with no problems, I feel a little more confident about that.

It will be interesting to see if this repair resolves the issue for you. It certainly sounds like you are on the right track. Best of luck!
Katz is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
'03 SLK230 Supercharger Noise bobinyelm SLK R170 General Discussion 14 01-16-2018 11:22 PM
Difference between supercharger on a SLK200 & SLK230 Dontino SLK R170 General Discussion 0 06-19-2012 07:53 AM
Supercharger Clutch Parts? Kyngfish AMGs 0 05-22-2012 09:41 AM
1999 SLK230 Kompressor White Sport Pkg AaronHartwell SLK Cars For Sale 4 01-02-2012 08:36 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.