2000 SLK230 Runs Poorly - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 11-22-2012
Registered Users
 
Join Date: Apr 2011
Location: Destin, Florida
Vehicle: 2000 SLK230
Other Toys: 2006 Hummer H3
Posts: 27
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
2000 SLK230 Runs Poorly

Hello ya'll and Happy Thanksgiving.

Since the beginning of Summer, I have had a lot of problems keeping my SLK230 running. The "search" function has been a lot of help but I cannot find any other suggestions.

The car is hard to start. I turn the key to the "on" position and listen for the fuel pump to finish charging the system. Then I turn the key. The engine will sputter sounding like it isn't firing on all cylinders. I'll turn the key off and on a couple times and start it again. Usually within three or four tries, the car will run and idle. I usually have to tickle the gas pedal a bit and get the engine warmed up good before the car runs like it should.

Originally, the car would simply die leaving me stranded for a few minutes. I replaced the fuel filter, sparkplugs, coils, MAF and O2 sensors. That made it run better but it still died. I replaced the K40 Relay board. That fixed the problem. Then we bought a couple more cars and stopped driving theSLK.

After a couple of months of sitting, I started the car and it rans rough. The engine would faulter when you gently press the gas pedal. I replaced the fuel pump, fuel filter (again), the crankshaft position sensor and cam position sensor. I replaced the cam adjustment magnet.

Today, the car is very hard to get started. But once it is running, everything seems fine. I changed the sparkplugs (again) to some off-the-shelf from Autozone. I'm going to replace the plugs with what every my Import Auto place recommends.

I still get ODBII code P0130. O2 Sensor Bank One Position One.

I need some suggestions to get my car running like new again.

Please help

Thanks

Pat
Havana, FLA
Piper60c is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2000 slk230 mirrors remote doesn't work jimlabarbara SLK R170 General Discussion 3 09-29-2012 12:32 AM
2000 SLK230 for sale - New York amata47 SLK Cars For Sale 1 06-08-2011 07:44 AM
Aftermarket shift knob for manual SLK230 year 2000 jeanp SLK R171 General Discussion 3 06-07-2011 05:17 PM
SLK230 2000 import from US to Canada metric conversion jeanp SLK R170 General Discussion 4 04-29-2011 10:52 PM
2000 SLK230 Options MISOJDM SLK R170 General Discussion 5 12-02-2008 03:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.