Code P0301 - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 11-06-2012
Registered Users

 
sokoloff's Avatar
 
Join Date: Jun 2009
Location: Ocean Isle Beach, NC
Vehicle: 2003 SLK320 31,000 miles
Posts: 1,314
Country:
Chats: 3
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Thanks: 27
Thanked 231 Times in 161 Posts
Garage
(Thread Starter)
Code P0301

Have a friend with an '01 SLK230. She complained about rough running and poor acceleration. Pulled the codes the other day and they came up as 301, 335 and 336. I assume there is supposed to be a "P0" in front of each of those. P0301 is misfire cylinder 1. P0335 and P0336 are both crankshaft position sensor codes. The codes were reset and haven't come back on, but it's also only been a day. What would you think would be the approach to fix this? Plugs have not been changed, so it's due for them I think regardless. Could the MAF cause the P0301 code and it that the likely culprit?

Len
2003 SLK320 40,000 miles - now lives in Tucson with my daughter
1959 220S Cabriolet - sold - now lives in Malta
1983 240D 351,000 miles original owner - sold
1999 E300D 215,000 miles
2014 Smart electric 17,000 miles
2014 Smart electric 9,000 miles
sokoloff is offline  
Sponsored Links
Advertisement
 
#2 Old 11-06-2012
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,116
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
Clean the MAF first, if the codes come back its the CPS. I had the same issue this summer, also when ever i got into the throttle heavy i would get a misfire code and end up in limp mode. The new CPS fixed that issue.
Livefreeordie is offline  
The Following User Says Thank You to Livefreeordie For This Useful Post:
#3 Old 11-07-2012
Registered Users
 
morpheusRO's Avatar
 
Join Date: Dec 2010
Location: Bucharest
Vehicle: SLK 200 Kompressor R170 (2002)
Posts: 56
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 7
Thanked 3 Times in 3 Posts
Garage
What is CPS ?
morpheusRO is offline  
 
#4 Old 11-07-2012
Premium Member
 
Join Date: May 2010
Location: Atlanta
Vehicle: 2005 SLK 55; 2005 SLK 350
Other Toys: Several past R170's
Posts: 4,275
Country:
Chats: 0
Mentioned: 580 Post(s)
Tagged: 0 Thread(s)
Quoted: 901 Post(s)
Thanks: 155
Thanked 514 Times in 475 Posts
CPS (sometimes called CKP) is the crankshaft position sensor, and it's really easy and inexpensive to replace. It usually sits on top of the transmission bell housing. It's a common point of failure.
efair is offline  
The Following User Says Thank You to efair For This Useful Post:
#5 Old 11-07-2012
Registered Users
 
Chris_R's Avatar
 
Join Date: Feb 2011
Location: Loganville, GA
Vehicle: 2001 SLK 230
Posts: 80
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 4
Thanked 4 Times in 4 Posts
Garage
Just did the P0301 on my daughter's Volvo C70 convertible. I'm pretty sure it's the same error (misfire on cylinder one). Hers turned out to be that the coil (coil-on-plug) on cylinder one had failed.

To diagnose I swapped coils and plugs around then would pull the connector to the coil (or the plug wire in the case of a car with distributor) while the engine was running. If the engine idle doesn't change then you've found the bad cylinder/coil/plug.

P0301 can also be caused by a vacuum leak, bad/dirty MAF (as mentioned), sticking valve(s), bad rings, etc.

Is the car running poorly?
Chris_R is offline  
#6 Old 11-09-2012
Registered Users

 
sokoloff's Avatar
 
Join Date: Jun 2009
Location: Ocean Isle Beach, NC
Vehicle: 2003 SLK320 31,000 miles
Posts: 1,314
Country:
Chats: 3
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Thanks: 27
Thanked 231 Times in 161 Posts
Garage
(Thread Starter)
It was but after a half hour 60 mph jaunt down the freeway with our SLK Group, she said it was running much better.

Len
2003 SLK320 40,000 miles - now lives in Tucson with my daughter
1959 220S Cabriolet - sold - now lives in Malta
1983 240D 351,000 miles original owner - sold
1999 E300D 215,000 miles
2014 Smart electric 17,000 miles
2014 Smart electric 9,000 miles
sokoloff is offline  
#7 Old 12-09-2013
Registered Users
 
Join Date: Jan 2013
Location: Camas, Wa
Vehicle: 1998 SLK 230 Silver
Other Toys: 2010 950 V-Star Tour
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Garage
Thanks, I'll order the CPS right now
Eshreeve is offline  
#8 Old 12-27-2013
Registered Users
 
Join Date: Jan 2013
Location: Camas, Wa
Vehicle: 1998 SLK 230 Silver
Other Toys: 2010 950 V-Star Tour
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 1 Time in 1 Post
Garage
Thanks, I changed out my CPS and the misfire is gone. I can get in to it and it goes
Eshreeve is offline  
#9 Old 07-31-2016
Registered Users
 
Join Date: Jul 2016
Posts: 1
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Question? I have a po301 when the engine temp is cold. after it reaches 40C an I restart the engine it runs perfect.??
I replaced a couple hoses that were bad figured that would be too easy. I recently did a head gasket and new tensioner unit, hoses bla bla.....
I replaced the MAF sensor unit ordered online new and the top speed issue went away. still once it cools down I need to limp for about 5 minutes...

Any thoughts or could it be cam position sensor at the front of the engine?
Drjake911 is offline  
#10 Old 07-31-2016
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,085
Country:
Chats: 38
Mentioned: 458 Post(s)
Tagged: 5 Thread(s)
Quoted: 6490 Post(s)
Thanks: 3,232
Thanked 11,020 Times in 8,379 Posts
Quote:
Originally Posted by Drjake911 View Post
Question? I have a po301 when the engine temp is cold. after it reaches 40C an I restart the engine it runs perfect.??
I replaced a couple hoses that were bad figured that would be too easy. I recently did a head gasket and new tensioner unit, hoses bla bla.....
I replaced the MAF sensor unit ordered online new and the top speed issue went away. still once it cools down I need to limp for about 5 minutes...

Any thoughts or could it be cam position sensor at the front of the engine?
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

First please update your location and vehicle (year?: 1996-2017, model?: 32, 200, 230, 250, 280, 300,320,350,55) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t. This takes about 30 seconds to do.
Follow exactly to update: ‘Usercp’ at the top of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’. Info in your garage does not update your profile.

Your 1st thread should be your introduction so we can welcome you properly so post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already. New Members Introduce Yourself Here - Mercedes Benz SLK Forum


Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable or to ‘edit’, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM. You can always pm a moderator.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
FREE!! Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
P0123 code - Loss of power in 02 320 twowheelin SLK R170 General Discussion 9 09-10-2017 11:02 PM
Help with a misfire and code P0301 please lombrozo SLK R170 General Discussion 3 08-22-2012 09:22 AM
Code p1230 ? SLKman General Discussion 0 06-01-2010 06:48 AM
Problem with my spare remote kpalmer SLK R171 General Discussion 11 03-15-2010 08:06 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.