SLK 230 Acceleration issues - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 3Likes
Reply
 
LinkBack Thread Tools
#1 Old 11-03-2012
Registered Users
 
Join Date: Nov 2012
Location: Hickory NC
Vehicle: 99 SLK 230
Other Toys: 01 E430,2000 C230,55 TBird,cessna 182
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
SLK 230 Acceleration issues

I have a 99 slk230. 140k miles. Last night I was driving the car and I started tro accelerate and got no response. I let off gas and engine was running fine. I puled into a parking lot and listened a bit heard no unusual noises . I shut the engine off and restarted and it ran and responded fine. I drove the car about a mile or so and it did the same thing again. Each time I tried to accelerate it would not respond. So I repeated the process and when car restarted it ran fine and this time I drove it home with no issues. About 2 weeks ago I changed the MAF . No other problems have occured. there are no CEL warnings. No lights came on during the problem I had last night. Right now engine is fine. but you just never know. Any one have any info that may help me solve my problem I would appreciate it . Thanks in advance. e-mail me at [email protected]
red55 is offline  
Sponsored Links
Advertisement
 
#2 Old 11-03-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,227
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6496 Post(s)
Thanks: 3,232
Thanked 11,032 Times in 8,391 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’. And it only takes about 30 seconds to do!

You might want to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.



Some tips to make your visit here more enjoyable:

If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response and only once. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message) - capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
New members and guests should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Also vote or enter our Ride of the Month competition: https://www.slkworld.com/rotm-submissions-voting/

Thank you,
Jeff
Moderator/Founding Member


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#3 Old 11-03-2012
Registered Users
 
Join Date: Apr 2011
Location: Copenhagen
Vehicle: '98 SLK 230, MT, 195k kms, Smaragdsswartz (189), black trim, latex paint removed
Posts: 132
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 23
Thanked 45 Times in 14 Posts
Hi red55

Welcome to slkworld. Before jbanks start chasing you, you should update your profile to state details of your car and where in the world you are located (these vehicles have country specific features).

You ask for members here to email you with response to your query. In the interest of others having similar problems as you do, we will respond here in the forum.

I have not personally experienced what you describe, but it sounds as if the accelerator position signal is not read/transfered correctly to the ECU. But I am sure that someone here with better knowledge will chip in shortly

Raindog
jbanks15 likes this.
Raindog is offline  
 
#4 Old 11-03-2012
Registered Users
 
Join Date: Apr 2011
Location: Copenhagen
Vehicle: '98 SLK 230, MT, 195k kms, Smaragdsswartz (189), black trim, latex paint removed
Posts: 132
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 23
Thanked 45 Times in 14 Posts
Quote:
Originally Posted by Raindog View Post
Hi red55

Before jbanks start chasing you, you should update your profile to state details of your car and where in the world you are located (these vehicles have country specific features).
Raindog
Darn Jeff, you beat me to it while typing...
jbanks15 likes this.
Raindog is offline  
#5 Old 11-03-2012
Registered Users
 
Join Date: Nov 2012
Location: Hickory NC
Vehicle: 99 SLK 230
Other Toys: 01 E430,2000 C230,55 TBird,cessna 182
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Profile updated. 1999 SLK 230, 140 K miles I live in NC . I completed introduction as well.
red55 is offline  
#6 Old 11-03-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,227
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6496 Post(s)
Thanks: 3,232
Thanked 11,032 Times in 8,391 Posts
Thanks for updating and posting an intro.

and Raindog, you may, of course, perform the duties of my assistant!
Raindog likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#7 Old 11-03-2012
Registered Users
 
Join Date: Nov 2012
Location: Hickory NC
Vehicle: 99 SLK 230
Other Toys: 01 E430,2000 C230,55 TBird,cessna 182
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Did it again this afternoon . No CEL,nothing all ok . Shut down restarted and it ran fine. This is beginning to puzzle me. Help
red55 is offline  
The Following User Says Thank You to red55 For This Useful Post:
#8 Old 11-03-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,227
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6496 Post(s)
Thanks: 3,232
Thanked 11,032 Times in 8,391 Posts
r170 experts will jump in soon. have you done a search for pse pump?


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#9 Old 11-03-2012
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,116
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
Check to see if there are any pending codes. Unplug the new MAF and see if there is a difference. If ther is then the MAF is dirty or bad. Did you get an OEM MAF?
Livefreeordie is offline  
#10 Old 11-03-2012
Registered Users
 
Join Date: Nov 2012
Location: Hickory NC
Vehicle: 99 SLK 230
Other Toys: 01 E430,2000 C230,55 TBird,cessna 182
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
it is an OEM MAF. Guy at autozone didnt know what to do to check for pending codes. Neither do I .
red55 is offline  
#11 Old 11-03-2012
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,116
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
Some one correct me if im wrong, don't most code readers show pending codes? or is that a feature that only dealers have?
Livefreeordie is offline  
#12 Old 11-04-2012
Registered Users
 
Join Date: Aug 2012
Location: Berkshire UK
Vehicle: 2000 SLK 320
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
I had the same problem it turned out to be Throttle Position Sensor

Roy
Roy S is offline  
#13 Old 11-04-2012
Registered Users
 
Join Date: Nov 2012
Location: Hickory NC
Vehicle: 99 SLK 230
Other Toys: 01 E430,2000 C230,55 TBird,cessna 182
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Acceleration issue

Is there a test I can do to check the Throttle sensor to see if its bad ? Have found some for $500 plus . Not sure I want to dump that kind of money in it unless I am definitely sure. It wont go to the shop for sure. Also is there a test for the MAF ? I just put this thing in about 3 weeks ago.
Other than the unplug test suggested above is there another easy test? Just hate to spend money if I dont need to. But i am willing to buy what I need . If anyone knows of a cheaper TPS let me know . Thanks
red55 is offline  
#14 Old 11-04-2012
Registered Users
 
Join Date: Nov 2012
Location: Hickory NC
Vehicle: 99 SLK 230
Other Toys: 01 E430,2000 C230,55 TBird,cessna 182
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Where is the TPS located ? engine compartment or gas pedal ?
red55 is offline  
#15 Old 11-05-2012
Registered Users
 
Join Date: Aug 2012
Location: Berkshire UK
Vehicle: 2000 SLK 320
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Gas Pedal.
When I had mine done the cost was £192 inc parts and labour
Throttle Position Sensor was £113 plus our VAT



Roy
Roy S is offline  
#16 Old 11-05-2012
Registered Users
 
Join Date: Nov 2012
Location: Hickory NC
Vehicle: 99 SLK 230
Other Toys: 01 E430,2000 C230,55 TBird,cessna 182
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
acceleration issue

there are several parts places that list 2 different TPS . how do I know which one to get ? The description doesnt say which is which. Is it based on the year of the car. Ie. thru 1999 its a pedal operated sensor and 2000 and above its in the engine compartment?

When I replace this item do I need to replace the entire pedal assembly ?
red55 is offline  
#17 Old 11-06-2012
Registered Users
 
Join Date: Sep 2012
Location: socal
Vehicle: 2002 SLK 320
Other Toys: Catalina 25
Posts: 1
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
acceleration issue

Exact same thing happened to my SLK 320 2002. The throttle pedal was defective. Replaced with new unit at independent repair shop for about 225 dollars. Works perfectly now.
falco1 is offline  
#18 Old 11-07-2012
Registered Users
 
Join Date: Nov 2012
Location: Hickory NC
Vehicle: 99 SLK 230
Other Toys: 01 E430,2000 C230,55 TBird,cessna 182
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
I have been told by one individual that the sensor is located in the engone compartment and another says its on the gas pedal . Anybody know for sure where it is. Our MB dealer left town so we have no place to go for help .
red55 is offline  
#19 Old 11-08-2012
Registered Users
 
Join Date: Apr 2011
Location: Copenhagen
Vehicle: '98 SLK 230, MT, 195k kms, Smaragdsswartz (189), black trim, latex paint removed
Posts: 132
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 23
Thanked 45 Times in 14 Posts
I do not see any sensors on my gas pedal. Buellwinkle states this: http://www.buellwinkle.com/r170/comb37.htm

I believe that there are differences in the way this system is arranged between the earlier r170 ('96-´99) and the later ones. I think yours is the same as mine and the one in the link. Easy give-aways are turnsignals integrated in rear view mirrors and no trunk key hole on later models.

Did you try and reset the throttle? Easy and cannot hurt. As far as I recall, you floor the pedal and keep it there, then turn key to pos 2, hold pedal for 30 sec, key to pos 0 and remove. Do a search to double check this procedure.

All the best
Raindog
Raindog is offline  
#20 Old 11-24-2012
Registered Users
 
Join Date: Nov 2012
Location: Hickory NC
Vehicle: 99 SLK 230
Other Toys: 01 E430,2000 C230,55 TBird,cessna 182
Posts: 18
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
replaced the TPS on Monday and its screwing up again. Doing the same thing no acceleration . Dont have any ideas what to do.HELP
Could it be fuel injectors?

Somebody help me please !!!!!!!!!!!!!!!

Last edited by red55; 11-25-2012 at 09:05 PM.
red55 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
What can you tell me about the SLK 230? CALL911 SLK R170 General Discussion 21 05-10-2015 06:59 PM
SLK 230 & Kompressor Badges - Suggestions on where to find? peabody Where to get R170 SLK Items 15 08-21-2012 10:32 PM
Let me introduce myself and my SLK 230! JaysonM New Members Introduce Yourself Here 23 07-30-2012 03:56 PM
99 slk 230 throttle issues - help sealluke SLK R170 General Discussion 2 06-13-2012 08:49 PM
SLK 230 & 320 Mille Miglia Edition leapyfish SLK R170 General Discussion 0 05-06-2012 10:44 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.