Engine Management Warning Light R170 - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 07-03-2012
Registered Users
 
Join Date: Apr 2012
Location: West London
Vehicle: 2002 SLK 230 K tip
Other Toys: Skoda fabia TDI
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 6 Times in 6 Posts
(Thread Starter)
Engine Management Warning Light R170

Engine Management Warning Light R170
R170 02 SLK 230 K

Have made a search but could not find much on my issue. The warning light has illuminated twice recently and been reset after investigation by the garage and no fault found.

Both times it activated was on hot days- ? It is on again. The car continues to run perfectly.

The only thing I can ID is the exhaust which to me is a little noisy as if the baffles are not as effective as they could be. I guess that it may well be the original exhaust.

The garage I use is an independent but sells and services sports cars of all makes. They were unable to find anything wrong.

Anyone experience of this problem ?
HZ123 is offline  
Sponsored Links
Advertisement
 
#2 Old 07-03-2012
Registered Users
 
Join Date: Oct 2011
Location: Riverside
Vehicle: 09' SLK55 w'AMG Performance Package
Posts: 500
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 2
Thanked 96 Times in 65 Posts
What's the codes and description?
Klinh is offline  
#3 Old 07-03-2012
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,733
Country:
Chats: 38
Mentioned: 470 Post(s)
Tagged: 5 Thread(s)
Quoted: 6543 Post(s)
Thanks: 3,246
Thanked 11,083 Times in 8,437 Posts
moving out of diy. diy is for established diys. moving to r170 general discussion


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
 
#4 Old 07-11-2012
Registered Users
 
Join Date: Jul 2012
Location: Johannesburg
Vehicle: best investment ive made so far
Other Toys: Golf MK3 VR6
Posts: 21
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
I had this light come on in my car aswell. It wsa the catalytic converter which caused mine to come on and after having a cat fooler installed it went away for awhile and came back, went to have it reset and it came back....6 months on and the car still goes smooth so i have learnt to ignore the light untill i get the equipment to reset the light myself
JustinArends is offline  
#5 Old 07-15-2012
Registered Users
 
Join Date: Apr 2012
Location: West London
Vehicle: 2002 SLK 230 K tip
Other Toys: Skoda fabia TDI
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 6 Times in 6 Posts
(Thread Starter)
Well got it sorted - it was the CO2 sensor in the exhaust. Hope that is the end of it. Interesting - just ignore it as indeed some of the 98 models did not have the engine / warning cluster, I think they would still have had the CO2 sensor.

Happy motoring !
HZ123 is offline  
#6 Old 07-16-2012
Registered Users
 
Join Date: Jul 2012
Location: Johannesburg
Vehicle: best investment ive made so far
Other Toys: Golf MK3 VR6
Posts: 21
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
Glad to hear you got it sorted
JustinArends is offline  
#7 Old 07-22-2012
Registered Users
 
Join Date: Jun 2010
Location: Cheltenham
Vehicle: SLK 32 AMG
Posts: 40
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 5 Times in 3 Posts
Quote:
Originally Posted by HZ123 View Post
Well got it sorted - it was the CO2 sensor in the exhaust. Hope that is the end of it. Interesting - just ignore it as indeed some of the 98 models did not have the engine / warning cluster, I think they would still have had the CO2 sensor.

Happy motoring !
I have the same problem, been in the bodyshop for a few months and now has the engine management light on.. How much was the sensor to sort out?
Cw2608 is offline  
#8 Old 07-22-2012
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,144
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
Before you start to replace parts i would pull the codes and go from there, just because the light came on doesn't mean its the 02 sensor.
Livefreeordie is offline  
#9 Old 08-03-2012
Registered Users
 
Join Date: Apr 2012
Location: West London
Vehicle: 2002 SLK 230 K tip
Other Toys: Skoda fabia TDI
Posts: 60
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 3
Thanked 6 Times in 6 Posts
(Thread Starter)
Issues

Pull the cam magnet plug off and see if it is oily, dead centre top of engine. You may need to instal and check;-

the camshaft adjuster magnet
the pigtail wiring harness adapter
orange sealant for the magnet installation

brake clean will clean the harness connectors or the worse case will be that a
new wiring harness will be required, you may need to check if the oil has
reached the me control unit, as permanent damage could occur, we have cleaned
this control unit before with brake clean , but make sure it dries (and turn
upside down to drain over 48hours if oil is in it) thougurly



Oil within the cable may contribute to the problem and activate the ECU light.
HZ123 is offline  
#10 Old 08-03-2012
Registered Users

 
Gbarringer100's Avatar
 
Join Date: May 2009
Location: Little River, SC
Vehicle: 2013 SLK250
Other Toys: 2016 GLA250
Posts: 2,317
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 100 Post(s)
Thanks: 12
Thanked 404 Times in 350 Posts
Garage
Quote:
Originally Posted by HZ123 View Post
Pull the cam magnet plug off and see if it is oily, dead centre top of engine. You may need to instal and check;-

the camshaft adjuster magnet
the pigtail wiring harness adapter
orange sealant for the magnet installation

brake clean will clean the harness connectors or the worse case will be that a
new wiring harness will be required, you may need to check if the oil has
reached the me control unit, as permanent damage could occur, we have cleaned
this control unit before with brake clean , but make sure it dries (and turn
upside down to drain over 48hours if oil is in it) thougurly



Oil within the cable may contribute to the problem and activate the ECU light.

In the USA this might be done by a MB dealer at no cost as some are covered under a recall. If you are in the USA I would check with a dealer, recall was started in December 2009. Do search for Cam adjuster for more info.
Gbarringer100 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY - Engine mounts replacement for post facelift R170 Mantist SLK R170 class DIY 10 11-23-2014 11:14 AM
check engine light on - oxygen sensors out? benz_bolek General Discussion 12 07-27-2010 10:19 AM
AMGPL: AMG 5.5-litre V8 biturbo engine Cold Shot AMGs 14 03-21-2010 09:11 AM
models and prices SLKman General Discussion 23 02-09-2007 04:02 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.