Very little but very cold air coming from outter-side passenger vent? - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 05-02-2012
Registered Users
 
Join Date: Mar 2012
Location: Cincinnati, OH USA
Vehicle: 2001 SLK 320
Other Toys: I've got about 20 Fieros, Camaros, MBs, Rams, Jeeps, Suzuki Bikes, Arctic cat Sleds
Posts: 212
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 14
Thanked 45 Times in 21 Posts
(Thread Starter)
Very little but very cold air coming from outter-side passenger vent?

I've tackled every single problem on my SLK 320, but only one remains... The passenger side vent.

I can put the blower on high, and still, very little air comes out of the far passenger vent. I can put the heat on high, and still, a little bit of cold air comes through the passenger side vent.

While this may not sound like a big deal, wifey doesn't like being cold and I like the top down. No heat = No top down when uts under 80....

Any takers on what could possibly be the problem???
Arachnyd is offline  
Sponsored Links
Advertisement
 
#2 Old 05-02-2012
Registered Users
 
Gulliver's Avatar
 
Join Date: Apr 2012
Location: Southern Tennessee
Vehicle: '99 R170 SLK230 Kompressor
Other Toys: S55 AMG, lots of old GM muscle
Posts: 28
Country:
Chats: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 9 Times in 2 Posts
I haven't used the heat yet, but our pass side vent is very weak as well.

At least on a/c- it doesn't blow nearly like the other vents.. Closing some of the other vents (at least partially) does help.
Gulliver is offline  
#3 Old 05-03-2012
Registered Users
 
Join Date: Aug 2011
Location: Minnesota
Vehicle: SLK230 2000, 117K miles
Posts: 116
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 22
Thanked 20 Times in 9 Posts
Garage
duovalve?

you check the duovalve?
Klonny is offline  
 
#4 Old 05-04-2012
Premium Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: Daily driver 1998 SLK230 243,xxx miles
Posts: 3,505
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Thanks: 960
Thanked 527 Times in 415 Posts
Garage
It may be the vent is blocked.
Try taking the cabin air filter out & checking the vents behind it.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Vario roof
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

R170 & R171
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
SLK 230 320 32AMG
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
leapyfish is offline  
#5 Old 05-12-2012
Registered Users
 
Join Date: Mar 2012
Location: Cincinnati, OH USA
Vehicle: 2001 SLK 320
Other Toys: I've got about 20 Fieros, Camaros, MBs, Rams, Jeeps, Suzuki Bikes, Arctic cat Sleds
Posts: 212
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 14
Thanked 45 Times in 21 Posts
(Thread Starter)
Problem solved:

The tube wasn't connected to the vent. I was able to access it through the access hole on the pass side, reconnect them, and voila it works.
Arachnyd is offline  
The Following User Says Thank You to Arachnyd For This Useful Post:
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
DIY - Replace Passenger Side Low Beam Bulb - 2005 SLK 350 grizzlyak SLK R171 Class DIY 13 04-16-2017 02:00 PM
Aftermarket HID, post-xenon-coded passenger side occasionally won't fire zymotix3 General Discussion 11 11-28-2011 06:11 PM
cold air intake ideas jameslk55 Performance MODS for the R171 52 04-23-2009 11:50 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.