PSE pump? - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 1Likes
  • 1 Post By Jet Wrench
 
LinkBack Thread Tools
#1 Old 08-09-2015
Registered Users
 
Join Date: Jun 2015
Location: Ponte Vedra Beach Florida
Vehicle: Magna Red 2001 SLK 230 36,000 miles
Other Toys: Selling my 1995 Dodge Neon Run SS/GS has held NHRA and IHRA national records
Posts: 101
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 52
Thanked 3 Times in 3 Posts
(Thread Starter)
PSE pump?

Hi. My console storage compartment will not unlock. All the other locks, doors, trunk/boot, and gas cap work fine. But I can get the storage compartment to open.
I've slid the PSE pump out and see the yellow lines leading from it. I have a vacuum tool that I can use to test.
But I'm not sure I can get the lines off and back on without damaging them.
What is the proper way to chase this problem?
rt1092 is offline  
Sponsored Links
Advertisement
 
#2 Old 08-15-2015
Registered Users
 
Join Date: Aug 2015
Location: Grand Cayman
Vehicle: 1998 SLK 230 (LHD)
Posts: 3
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Having been working on my PSE pump all day, I understand your reluctance to try to disconnect the hoses from the connectors. You can, however, remove the entire vacuum hose plastic manifold from the PSE by pushing the central locking bar located in its center towards the wheel arch. You can also remove each vacuum line seperately from the manifold by using a small screwdriver to disengage the locking tab where it snaps downwards into the manifold. I was able to apply a handheld food sealer vacuum pump to each line to check that it worked.
rosemail is offline  
#3 Old 08-16-2015
Registered Users
 
Jet Wrench's Avatar
 
Join Date: Jun 2014
Location: Sicily, Italy
Vehicle: 1999 European spec 200, 5 speed. Silver exterior, red and black interior
Other Toys: BMW 320d Wagon, Glastron Carlson CVX18, 2013 Harley Davidson Road King
Posts: 134
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 22
Thanked 13 Times in 13 Posts
Garage
If your doors, trunk and gas tank door are all working correctly, more than likely the vacuum line to the center console lock mechanism is off. I found out the hard way! For almost a year, I thought there was an issue with the latch on the center console. I would have to open it with a credit card and slide it in between the latch to open it. I was not aware that there was a vacuum lock on the center console until I removed it for re-paint. Sure enough, the vacuum line had either worked it's way off or someone had removed it in the past and not re-installed it. I replaced the original line with a longer line and now it works as advertised. Hope this helps.
El_Toro_33809 likes this.
Jet Wrench is offline  
The Following User Says Thank You to Jet Wrench For This Useful Post:
 
#4 Old 08-16-2015
Registered Users
 
Join Date: Jun 2015
Location: Ponte Vedra Beach Florida
Vehicle: Magna Red 2001 SLK 230 36,000 miles
Other Toys: Selling my 1995 Dodge Neon Run SS/GS has held NHRA and IHRA national records
Posts: 101
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 52
Thanked 3 Times in 3 Posts
(Thread Starter)
Quote:
Originally Posted by Jet Wrench View Post
If your doors, trunk and gas tank door are all working correctly, more than likely the vacuum line to the center console lock mechanism is off. I found out the hard way! For almost a year, I thought there was an issue with the latch on the center console. I would have to open it with a credit card and slide it in between the latch to open it. I was not aware that there was a vacuum lock on the center console until I removed it for re-paint. Sure enough, the vacuum line had either worked it's way off or someone had removed it in the past and not re-installed it. I replaced the original line with a longer line and now it works as advertised. Hope this helps.
Thanks this helps a lot. I bought the car like this and have yet to open it, I'll use the credit card trick for now. I thought that if one of the lines were leaking the others wouldn't work properly. I'll figure out how to get them off. Then use a mity vac to see if it will work.
rt1092 is offline  
#5 Old 08-17-2015
Registered Users
 
Jet Wrench's Avatar
 
Join Date: Jun 2014
Location: Sicily, Italy
Vehicle: 1999 European spec 200, 5 speed. Silver exterior, red and black interior
Other Toys: BMW 320d Wagon, Glastron Carlson CVX18, 2013 Harley Davidson Road King
Posts: 134
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 22
Thanked 13 Times in 13 Posts
Garage
I never had an issue with door locks, trunk, etc. The pump never ran excessively, even with the center latch vacuum line detached.
Jet Wrench is offline  
#6 Old 08-17-2015
Registered Users
 
Join Date: Jun 2015
Location: Ponte Vedra Beach Florida
Vehicle: Magna Red 2001 SLK 230 36,000 miles
Other Toys: Selling my 1995 Dodge Neon Run SS/GS has held NHRA and IHRA national records
Posts: 101
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 12 Post(s)
Thanks: 52
Thanked 3 Times in 3 Posts
(Thread Starter)
Quote:
Originally Posted by Jet Wrench View Post
If your doors, trunk and gas tank door are all working correctly, more than likely the vacuum line to the center console lock mechanism is off. I found out the hard way! For almost a year, I thought there was an issue with the latch on the center console. I would have to open it with a credit card and slide it in between the latch to open it. I was not aware that there was a vacuum lock on the center console until I removed it for re-paint. Sure enough, the vacuum line had either worked it's way off or someone had removed it in the past and not re-installed it. I replaced the original line with a longer line and now it works as advertised. Hope this helps.
I used the credit card trick to get it open. Then I took the locking mechanism off. I'll pull the console and fix it at a later date.
At least I can have some extra storage.
Thanks
rt1092 is offline  
#7 Old 08-17-2015
Registered Users
 
Jet Wrench's Avatar
 
Join Date: Jun 2014
Location: Sicily, Italy
Vehicle: 1999 European spec 200, 5 speed. Silver exterior, red and black interior
Other Toys: BMW 320d Wagon, Glastron Carlson CVX18, 2013 Harley Davidson Road King
Posts: 134
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 22
Thanked 13 Times in 13 Posts
Garage
You're welcome! Glad I could help.
Jet Wrench is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to replace water pump R171 SLK55 thirteendog AMGs 22 02-26-2015 11:21 AM
Central Locking System (PSE Pump) jznation SLK R170 General Discussion 4 03-20-2014 01:47 PM
Replaced PSE Pump, Horn Chrips when Ignition in Position 2 MZeraldo SLK R170 General Discussion 2 10-30-2013 03:26 AM
Another IC Pump Install rfourt AMGs 4 05-13-2012 01:00 PM
Working R170 PSE Door Actuator Pump BSK SLK Parts For Sale 10 10-18-2011 10:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.