Total electrical power loss when key turned to start position - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 6Likes
  • 1 Post By Delucas
  • 1 Post By t140v
  • 1 Post By t140v
  • 1 Post By curro101
  • 1 Post By El_Toro_33809
  • 1 Post By ichris93
 
LinkBack Thread Tools
#1 Old 07-29-2015
Registered Users
 
Join Date: Jul 2015
Location: Doncaster U.K.
Vehicle: 2000 SLK 320
Other Toys: Suzuki RE5, Triumph Bonnevile, CBR1100xx.
Posts: 347
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Thanks: 25
Thanked 37 Times in 35 Posts
(Thread Starter)
Total electrical power loss when key turned to start position

Hi all, had a bit of a problem today going to go out for a drive unlocked the door with the remote got in the car and put the key in the ignition, turned to posn 1 all lights came on etc turned key to start engine, the engine turned and just started then stopped and all power went off radio, lights, central locking nothing working at all except the fuel guage and rev counter remained in running positions.
Turned key back and removed it, refitted and turned, nothing.
Tried spare key, nothing, rev counter still at 1500 engine not running.
Opened bonnet and checked all fuses, all ok, checked the black and yellow relays at the back of the fusebox these ok also.

Checked the battery terminal, ok with no corrosion nothing loose.
checked battery voltage showing 12.1v so put trickle charger on.

Opened up the relay compartment and checked for water loose wires etc could not find a thing. Took the plastic plug out if the door keyway and manually locked the door.
Left it for a couple of hours went back, door unlocked with the remote again, inserted key in the ignition and turned to posn 1 all lights etc came on, turned key engine started all lights except BAS/ESP went out.
Had a read of handbook that said turn wheels full lock to full lock then back and lights should go out.
Started the engine turned wheels full lock to full lock, was a ping sound and lights went out.

All things working again what could have caused the problem ?, the only thing I have done different is separate the keys and use what looks like the better of the two keys.
Back to two keys fastened togeter on one key ring untill i know a bit more about the car.

Any suggestions.
t140v is offline  
Sponsored Links
Advertisement
 
#2 Old 07-29-2015
Registered Users
 
Join Date: Aug 2012
Location: KENT
Vehicle: MERCEDES SLK 171 - 09. - SLK KENT GROUP MEET - EVENT ORGANISER
Posts: 4,803
Country:
Chats: 0
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1136 Post(s)
Thanks: 52
Thanked 344 Times in 322 Posts
Garage
1 Check / test / replace battery
2 Starter motor faulty .
3 Ignition switch faulty
4 ignition key

Good battery is crucial on these cars .
ichris93 likes this.
Delucas is offline  
#3 Old 07-30-2015
Registered Users
 
Join Date: Jul 2015
Location: Doncaster U.K.
Vehicle: 2000 SLK 320
Other Toys: Suzuki RE5, Triumph Bonnevile, CBR1100xx.
Posts: 347
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Thanks: 25
Thanked 37 Times in 35 Posts
(Thread Starter)
Checked the battery this morning, 1 cell down but plates not showing topped up with distilled water.
Tried key and everything OK started up no problem, drove xa bit stopped, and a bit more, no problem ,
Whatever I did yesterday seems to have fixed the problem, for now.
El_Toro_33809 likes this.
t140v is offline  
 
#4 Old 08-13-2015
Registered Users
 
Join Date: Jul 2015
Location: Doncaster U.K.
Vehicle: 2000 SLK 320
Other Toys: Suzuki RE5, Triumph Bonnevile, CBR1100xx.
Posts: 347
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Thanks: 25
Thanked 37 Times in 35 Posts
(Thread Starter)
After fully charging the battery I got a couple of days of trouble free driving then started to get the warning lights on again, battery seems to settle down to a reading of 12.3v which is at 70% capacity when things start to go wrong.

New battery fitted, all warning lights gone, been out for a drive all is good.

Regards Stuart.
Idiot101 likes this.
t140v is offline  
The Following User Says Thank You to t140v For This Useful Post:
#5 Old 08-26-2015
Registered Users
 
Join Date: Jul 2015
Location: Doncaster U.K.
Vehicle: 2000 SLK 320
Other Toys: Suzuki RE5, Triumph Bonnevile, CBR1100xx.
Posts: 347
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Thanks: 25
Thanked 37 Times in 35 Posts
(Thread Starter)
Hi all, after replacing the battery two weeks ago have had a fairly uneventfull time, however a new problem has raised its head, when the key is turned the key sticks and she starter motor runs until the key is turned back to the off position, has happened a couple of times , once or twice the engine has started and the started motor kept running and key stuck till turned off .

Regards Stuart.
t140v is offline  
#6 Old 08-26-2015
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spŕin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,744
Country:
Chats: 0
Mentioned: 109 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,297 Times in 1,138 Posts
Garage
Sounds like it may be a problem with the key barrel ?

Have you tried putting contact cleaner down the barrel , it may help ?
t140v likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
curro101 is offline  
#7 Old 08-26-2015
Registered Users
 
El_Toro_33809's Avatar
 
Join Date: Nov 2013
Location: Lakeland, Florida
Vehicle: 1999 SLK230 (sold); 2001 SLK320
Other Toys: 2003 SL55, jet boat & PWC's
Posts: 712
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 86 Post(s)
Thanks: 16
Thanked 78 Times in 76 Posts
I agree with curro, but what I've read has indicated the key would not turn, it hasn't been sticking with the starter engaged. Are you indicating that the key gets stuck in position 3 (I think that is correct - position 0 is inserting the key, position 1 is accessories, position 2 is run and position 3 is start)? You could try some cleaner and then graphite. Does the key look worn? Do you have a second key you could try?

Tim
t140v likes this.
El_Toro_33809 is offline  
#8 Old 08-27-2015
Registered Users
 
Join Date: Jul 2015
Location: Doncaster U.K.
Vehicle: 2000 SLK 320
Other Toys: Suzuki RE5, Triumph Bonnevile, CBR1100xx.
Posts: 347
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Thanks: 25
Thanked 37 Times in 35 Posts
(Thread Starter)
Hi Tim, the key is sticking in position 3, when I bought the car it had 2 keys the one I am using is looks like the least worn of the 2.
I'll try the other key and if the same thing happens put a bit of cleaner and lube into the barrel.
Thanks
Stuart
t140v is offline  
#9 Old 08-27-2015
Registered Users

 
ichris93's Avatar
 
Join Date: Dec 2014
Location: Ann Arbor, MI
Vehicle: 05 C240; Sold-2001 SLK 230 6 Speed
Posts: 469
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 64
Thanked 62 Times in 48 Posts
Quote:
Originally Posted by t140v View Post
Hi Tim, the key is sticking in position 3, when I bought the car it had 2 keys the one I am using is looks like the least worn of the 2.
I'll try the other key and if the same thing happens put a bit of cleaner and lube into the barrel.
Thanks
Stuart
Make sure to use graphite as the lube. Anything else will attract dirt and gum up the barrel.
t140v likes this.
ichris93 is offline  
#10 Old 08-27-2015
Registered Users
 
Join Date: Jan 2015
Location: Joelton, TN USA
Vehicle: 1998 SLK 230
Other Toys: BMW R100Rs, Several Olerd Folks TOYS (RV, Boat, 4X4 Tracker)
Posts: 3
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 2 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Tim, I read someplace (and my 1999 SLK does it) That there is a start module located by the SRS module that when you turn the car to start (position 3) that the module engages until the car starts or it "times out". I never relized mine did it until I let go early once and I thought something wrong. But It is normal to turn to start and let go of the vkey it will crank until it starts or time out. I do not think mine stays in position 3 it just cranks like it is there. But if yous stays in the 3rd position it is something different.
Larry
larrysfixit is offline  
#11 Old 08-27-2015
Registered Users

 
ichris93's Avatar
 
Join Date: Dec 2014
Location: Ann Arbor, MI
Vehicle: 05 C240; Sold-2001 SLK 230 6 Speed
Posts: 469
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 64
Thanked 62 Times in 48 Posts
Quote:
Originally Posted by larrysfixit View Post
Tim, I read someplace (and my 1999 SLK does it) That there is a start module located by the SRS module that when you turn the car to start (position 3) that the module engages until the car starts or it "times out". I never relized mine did it until I let go early once and I thought something wrong. But It is normal to turn to start and let go of the vkey it will crank until it starts or time out. I do not think mine stays in position 3 it just cranks like it is there. But if yous stays in the 3rd position it is something different.
Larry
That is correct for the automatic transmission R170s
ichris93 is offline  
#12 Old 08-29-2015
Registered Users
 
El_Toro_33809's Avatar
 
Join Date: Nov 2013
Location: Lakeland, Florida
Vehicle: 1999 SLK230 (sold); 2001 SLK320
Other Toys: 2003 SL55, jet boat & PWC's
Posts: 712
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 86 Post(s)
Thanks: 16
Thanked 78 Times in 76 Posts
Quote:
Originally Posted by larrysfixit View Post
Tim, I read someplace (and my 1999 SLK does it) That there is a start module located by the SRS module that when you turn the car to start (position 3) that the module engages until the car starts or it "times out". I never relized mine did it until I let go early once and I thought something wrong. But It is normal to turn to start and let go of the vkey it will crank until it starts or time out. I do not think mine stays in position 3 it just cranks like it is there. But if yous stays in the 3rd position it is something different.
Larry
Larry, that is correct, you do not have to hold the key in position 3, so it sounds like yours is working properly. If you are hearing a grinding noise, there may be a starter issue, but if you turn the key and it starts or times out, it is functioning properly, if, like ichris said, it's an automatic.

Tim
El_Toro_33809 is offline  
#13 Old 09-07-2015
Registered Users
 
Join Date: Jul 2015
Location: Doncaster U.K.
Vehicle: 2000 SLK 320
Other Toys: Suzuki RE5, Triumph Bonnevile, CBR1100xx.
Posts: 347
Country:
Chats: 0
Mentioned: 5 Post(s)
Tagged: 0 Thread(s)
Quoted: 54 Post(s)
Thanks: 25
Thanked 37 Times in 35 Posts
(Thread Starter)
Hi Larry & Tim just an update, car had run OK since I swapped keys but has done the starter motor engage but the engine not firing up a couple of times since, very strangely in the same parking spot at the local post office, the parking lot has a gradient running downhill right to left as the front wheels approach the kerb, I have had this happen twice now when I park in the same spot, reversed into the parking bay today same spot and all OK see what happens tomorrow.
I'll probably see if I have any error codes, suspect the crankshaft sensor is playing up.
Regards Stuart.

Code reader diagnosed crank sensor as well as 5 other possibilities, replaced the crank sensor all other codes gone as well , car running well .

Last edited by t140v; 09-23-2015 at 04:47 PM. Reason: Update and conclusion
t140v is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
hard to start issue Key fobs or Ignition switch? qwkrn u SLK R171 General Discussion 9 11-18-2015 12:30 AM
Loss of power spannerchucker SLK R170 General Discussion 6 01-08-2013 11:20 AM
Start Error - High Speed Fan - Run w/o key in ignition jmorse62 SLK R170 General Discussion 11 07-08-2011 02:44 AM
Good battery, turn key no start mrdougie General Discussion 10 02-13-2010 10:02 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.