Yet another ESP/ABS problem :) - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 07-29-2015
Registered Users
 
Join Date: Nov 2013
Location: Whangarei
Vehicle: 2003 SLK230
Posts: 6
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Yet another ESP/ABS problem :)

My wife's SLK230 has developed the dreaded ESP/ABS lights problem,with the car locked in 1st gear

Diagnostic codes show a speed sensor issue, reading the live date there's no data from either of the right or left rear wheel speed sensors.

I've checked one, it seems OK and the connector is OK. It seems to me it's extremely unlikely that both fail at exactly the same time so I suspect there's either a connection issue somewhere, or an ESP unit issue.

Questions I hope someone can help with.

1/The ESP wiring diagram shows a connector 'x99/14 'which the legend shows as 'REST[MRA}/BA or ESP intermediate connector'. Where is this located? It has a different pin configuration from the connector on the ESP unit itself, so I'm assuming it's not that one. Both the left and right speed sensor lines pass through it, so that may be the common point of connection loss.

2/ Any other ideas on what could cause loss of data from both wheel speed sensors at the same time?

3/How difficult is it to remove the ESP PCB to check it for connection issues?

The car is 150 miles from the nearest MB dealer with full diagnostics, and I don't feel like driving there in 1st gear!

Any help would be much appreciated.
kiwiradical is offline  
Sponsored Links
Advertisement
 
#2 Old 07-29-2015
Registered Users
 
Join Date: Mar 2014
Location: France - down by the Spanish border
Vehicle: 2014 SLK250
Other Toys: RS3, MacanS, MGBV8
Posts: 1,000
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 271 Post(s)
Thanks: 5
Thanked 97 Times in 81 Posts
Sometimes, note sometimes, you can reset limp home mode by simply disconnecting the battery. I think it might depend on the type of fault that put you there though, and you might have to do this several times each time the fault puts you back into it. Worth a try!

As for the PCB, no can help I am afraid!
Hal Adams is offline  
#3 Old 07-29-2015
Registered Users
 
Join Date: Nov 2013
Location: Whangarei
Vehicle: 2003 SLK230
Posts: 6
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Thanks, but no, I tried that right in the beginning.

No data from the wheel sensors is a hard fault, not a temporary one., so stays there.
kiwiradical is offline  
 
#4 Old 07-29-2015
Premium Member
 
Join Date: May 2013
Location: Keller, Texas
Vehicle: My wife's first 'fun car' 2002 SLK 32 AMG
Other Toys: 2007 Dodge Magnum Police Interceptor
Posts: 166
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 30
Thanked 23 Times in 13 Posts
I may be incorrect, but in reading about this problem, it appears that this problem may originate in the brake light switch at the brake pedal.

It's like a $20 part. And replacing it MAY resolve your issues. The wife's car has the same problem, but it has not 'locked up' anything . So I'm having my mechanic replace that switch the next time I take it in for service (oil change) plus I will be replacing all four shocks and the steering stabilizer at that time as well.

We tried the Koni Yellow Sport shocks but even though they are adjustable, they are still too stiff for my wife. So back to factory shocks. As long as we are going that route, I figured we might as well change the steering stabilizer as well.

A rattlesnake in the living room tends to end all discussion of animal rights. "Vengence is mine" sayth the Lord, but sometimes he subcontracts...
wallew is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Intermittent seat adjustment problem. Seat relay fix. JaysonM SLK R170 class DIY 46 03-29-2019 03:34 PM
HELP! ABS/BAS/ESP warning lights on and top problem ||SLK320|| SLK R170 General Discussion 36 08-22-2018 07:53 AM
Intermittent Starting Problem edzed SLK R171 General Discussion 44 07-28-2018 03:38 PM
Help needed with a possible problem please ?? curro101 SLK R171 General Discussion 15 06-15-2014 06:34 PM
SRS & Tele Aid problem thepiratetech SLK R171 General Discussion 2 04-11-2013 04:40 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.