S/C pumping - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 5Likes
  • 1 Post By ichris93
  • 2 Post By TehRage
  • 2 Post By TehRage
 
LinkBack Thread Tools
#1 Old 07-24-2015
Registered Users
 
Aubrey's Avatar
 
Join Date: Jun 2015
Location: Germiston - South Africa
Vehicle: SLK 200 kompressor 2002
Other Toys: BMW 1150 GS Adventurer
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
Send a message via Skype™ to Aubrey
(Thread Starter)
S/C pumping

Can someone please tell me what factors influence the charger from pumping and not pumping on my SLK 200 2002 model
Aubrey is offline  
Sponsored Links
Advertisement
 
#2 Old 07-24-2015
Registered Users

 
ichris93's Avatar
 
Join Date: Dec 2014
Location: Ann Arbor, MI
Vehicle: 05 C240; Sold-2001 SLK 230 6 Speed
Posts: 469
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 64
Thanked 62 Times in 48 Posts
As far as I know, facelift models have no clutch so the supercharger will always be engaged.
Aubrey likes this.
ichris93 is offline  
#3 Old 07-26-2015
Registered Users
 
Join Date: Dec 2012
Location: Elizabeth, CO (SE Denver)
Vehicle: 2002 SLK230
Other Toys: '13 LR2, '11 z71 Suburban, '09 Yamaha R6S
Posts: 11
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
your supercharger will be constantly "pumping", meaning trying to compress air, being spun by the belt on the front of the motor. On the top front of the SC assembly, beneath the black "box" resonator, is the bypass valve, which functions much the same way as a blow off valve on a turbo setup. It's job is to release the air pressure between the supercharger and engine. This is the only thing that can cause your supercharger to not build boost/pressure aside from a leak in your intake/inter-cooler piping. If you look at the pulley on the front of the supercharger and it is spinning while the car is running, it should be fine. If you are not getting boost, your bypass valve could be stuck open, or there could be some of the intake piping loose...or the car could be keeping that valve open for some reason, but those are the things that would prevent it from building boost.
El_Toro_33809 and Aubrey like this.
TehRage is offline  
 
#4 Old 07-26-2015
Registered Users
 
Join Date: Dec 2012
Location: Elizabeth, CO (SE Denver)
Vehicle: 2002 SLK230
Other Toys: '13 LR2, '11 z71 Suburban, '09 Yamaha R6S
Posts: 11
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
Sorry, i just realized you have a 200. I am not sure what exactly the differences are between that and the 230, but from what i can tell, they are very similar, but with less engine displacement, so what I mentioned should still apply. Are you having trouble with your car? If you are, give us some more details of the symptoms and we can better point you in the right direction.
ichris93 and Aubrey like this.
TehRage is offline  
#5 Old 07-27-2015
Registered Users
 
Aubrey's Avatar
 
Join Date: Jun 2015
Location: Germiston - South Africa
Vehicle: SLK 200 kompressor 2002
Other Toys: BMW 1150 GS Adventurer
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
Send a message via Skype™ to Aubrey
(Thread Starter)
Thanks for the advice appreciate it , and yes i believe that there is something not right with the S/C because sometimes the car goes like a rocket and then some days it is just a normal 2L with no oomph
Aubrey is offline  
#6 Old 07-27-2015
Registered Users
 
Join Date: Dec 2012
Location: Elizabeth, CO (SE Denver)
Vehicle: 2002 SLK230
Other Toys: '13 LR2, '11 z71 Suburban, '09 Yamaha R6S
Posts: 11
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
I would suggest at least taking a look at that bypass valve to see if it needs to be cleaned out. Sometimes they can stick (from oil buildup from the air/oil separator and dust). Personally, I would just take it off and clean it with carb cleaner and a soft brush. It is possible that the bypass valve itself is failing and needs to be replaced. I have no clue how likely that is, just worth mentioning. Aside from that being the issue, it may be the ecu keeping it open for some reason. If cleaning it out doesn't help, I would get it scanned with a mercedes specific scanner tool to see if there is a trouble code that would indicate a problem. The supercharger itself is most likely fine since it is intermittent. I finally found a picture of the 200 engine bay, and it looks nearly identical, so this should all apply to your car. The bypass valve is the silver part at the bottom of this photo.
Attached Images
File Type: jpg Capture.JPG (14.8 KB, 27 views)
TehRage is offline  
#7 Old 07-28-2015
Registered Users
 
Aubrey's Avatar
 
Join Date: Jun 2015
Location: Germiston - South Africa
Vehicle: SLK 200 kompressor 2002
Other Toys: BMW 1150 GS Adventurer
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
Send a message via Skype™ to Aubrey
(Thread Starter)
Thnx again for all the support and advice , the bypass valve was not sticky at all what i did do is opening that bypass valve and i found that all the gears and mechanics inside is badly worn with excessive play on the elect motor shaft and intermediate gear ,i just dont know where i am going to find such a valve here in SA or do you think it is possible to import it from you guys
Aubrey is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
CITGO Gas Pump Found to Charge When no Gas is Pumping jbanks15 Off Topic 0 04-29-2015 07:38 AM
vacuum lines from s/c to where ever it goes king.stivan SLK R170 General Discussion 12 08-10-2013 03:26 PM
Kleemann s/c and C.A.R.B. Anyone dealing w/ this? Todd157k AMGs 23 02-28-2011 11:58 PM
Problems after Kleeman S/C install Hakaze Performance MODS for the R171 99 07-31-2010 02:16 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.