R170 help needed - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 07-14-2015
Registered Users
 
andy_grant's Avatar
 
Join Date: Apr 2013
Location: Hampshire
Vehicle: 1998 SLK230
Other Toys: Audi Q5, Quantum Microlight
Posts: 25
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 3
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
R170 help needed

Hi, hopefully someone here will be able to advise or maybe has had a similar problem.

History: 2 weeks ago the car lost a lot of coolant, there was no rough running or plumbs of smoke. I replaced the coolant and it has been fine since.

Yesterday on my journey to work I lost all power (no fault light)and came to a halt. Through a bit of knowledge (mainly reading articles on this site) I striped the maf and discovered it was covered in a yellow milky type substance, I managed to clean it up at the road side and get into work. I checked the maf again and it was coated yet again.

I proceeded in cleaning the system out from the oil separator through to the throttle body (will do the intercooler at the weekend). There was lots of moisture coming from the oil separator and has now ruined the air filter. I suspect this is where my coolant disappeared to 2 weeks earlier what is confusing is why the coolant has remained constant after it was topped up.

If anyone has had a similar issue or has any thoughts the help would be appreciated.
andy_grant is offline  
Sponsored Links
Advertisement
 
#2 Old 07-14-2015
Registered Users

 
ichris93's Avatar
 
Join Date: Dec 2014
Location: Ann Arbor, MI
Vehicle: 05 C240; Sold-2001 SLK 230 6 Speed
Posts: 469
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 64
Thanked 62 Times in 48 Posts
Uh oh.... check your oil. Is it overfilled or milky?
ichris93 is offline  
#3 Old 07-14-2015
Registered Users
 
andy_grant's Avatar
 
Join Date: Apr 2013
Location: Hampshire
Vehicle: 1998 SLK230
Other Toys: Audi Q5, Quantum Microlight
Posts: 25
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 3
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
Oil has been checked its between the marks. It's old and does need changing but no water in it.
andy_grant is offline  
 
#4 Old 07-14-2015
Registered Users

 
ichris93's Avatar
 
Join Date: Dec 2014
Location: Ann Arbor, MI
Vehicle: 05 C240; Sold-2001 SLK 230 6 Speed
Posts: 469
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 64
Thanked 62 Times in 48 Posts
Quote:
Originally Posted by andy_grant View Post
Oil has been checked its between the marks. It's old and does need changing but no water in it.
Well, in your despair, that is a bit of good news.

No idea of how the coolant got into your intake? Is the intercooler stock? If so, it is air to air so there is no water dissipating the heat and I cannot think of another way the coolant would get into your intake.
ichris93 is offline  
#5 Old 07-14-2015
Registered Users
 
andy_grant's Avatar
 
Join Date: Apr 2013
Location: Hampshire
Vehicle: 1998 SLK230
Other Toys: Audi Q5, Quantum Microlight
Posts: 25
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 3
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
I'm taking a few days off work as need to get to the bottom of this. I am still expecting it to be the dreaded head gasket but will do the easy stuff first.
andy_grant is offline  
#6 Old 07-14-2015
Registered Users

 
ichris93's Avatar
 
Join Date: Dec 2014
Location: Ann Arbor, MI
Vehicle: 05 C240; Sold-2001 SLK 230 6 Speed
Posts: 469
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 64
Thanked 62 Times in 48 Posts
Did it overheat at all?
ichris93 is offline  
#7 Old 07-14-2015
Registered Users
 
andy_grant's Avatar
 
Join Date: Apr 2013
Location: Hampshire
Vehicle: 1998 SLK230
Other Toys: Audi Q5, Quantum Microlight
Posts: 25
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 3
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
It did when it lost all the coolant 2 weeks ago but ever since it has been absolutely fine and not lost a drop. Have covered about 500 miles also.
My car is just strange.
andy_grant is offline  
#8 Old 07-14-2015
Registered Users

 
ichris93's Avatar
 
Join Date: Dec 2014
Location: Ann Arbor, MI
Vehicle: 05 C240; Sold-2001 SLK 230 6 Speed
Posts: 469
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 89 Post(s)
Thanks: 64
Thanked 62 Times in 48 Posts
Quote:
Originally Posted by andy_grant View Post
It did when it lost all the coolant 2 weeks ago but ever since it has been absolutely fine and not lost a drop. Have covered about 500 miles also.
My car is just strange.
Uh oh again. Can you do a compression test or pressure test the coolant system? Doing a pressure test on the coolant system may show you where the leak is too.
ichris93 is offline  
#9 Old 07-14-2015
Registered Users
 
andy_grant's Avatar
 
Join Date: Apr 2013
Location: Hampshire
Vehicle: 1998 SLK230
Other Toys: Audi Q5, Quantum Microlight
Posts: 25
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 3
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
I will have to see if I can get a loan of a compression tester
andy_grant is offline  
#10 Old 07-16-2015
Registered Users
 
andy_grant's Avatar
 
Join Date: Apr 2013
Location: Hampshire
Vehicle: 1998 SLK230
Other Toys: Audi Q5, Quantum Microlight
Posts: 25
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 7 Post(s)
Thanks: 3
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
After a fun filled day. I managed to strip out and clean the intercooler it was full of yellow sludge hopefully this will stop the maf from getting coated for a little while, had a good look around no signs of leaks I was a little disappointed as I am still unsure where my coolant went now. But it's a few jobs ticked just unfortunate I found a few more to add.
andy_grant is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
[US]Some R170 items needed stinger608 SLK Parts Wanted 9 05-27-2013 06:44 PM
Thinking of going from R170 to R171 or...SL? Klonny SLK R171 General Discussion 10 05-20-2013 01:17 AM
Does Basset Slooper counts 4 a R170 Problem Berliner Heckflosse SLK R170 General Discussion 3 03-16-2012 12:22 AM
Reg for sale: R170 AVW R170 Where to get R170 SLK Items 1 08-13-2009 05:52 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.