R 170 audio and amplifier connections - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 03-23-2010
Registered Users
 
Join Date: Mar 2010
Vehicle: SLK 320 R170
Posts: 4
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
(Thread Starter)
Question R 170 audio and amplifier connections

Hi can anyone help, I've read through quite a few different threads and can't seem to find the answer to my question. We have a year 2000 SLK 320 R170 which we brought recently. The head unit was an Aldi special (Aldi is a British supermarket for international readers) as I believe the original unit either stayed with a previous owner or was liberated by some toe rag during the cars life. Anyhow, located in the passenger footwell is what I believe to be an amplifier, besides others this has four connections to the "B" connector on the head unit. They are:-
Head Unit "B" to Amplifier
6 to 3
5 to 5
4 to 4
3 to 6

From the amplifier connector there is also cabling to speakers
23 & 15 to front left speakers
25 & 17 to front right speakers
20 & 12 to rear left speaker
19 and 11 to rear right speaker.

The rear speakers are Bose and I believe there is no D2 B cabling in the car.
Having done some research I have discovered that connections 1 & 2 and 7 & 8 of the "B" coupler are outputs from the head unit for rear speaker drivers.

Is it that I am missing the cabling from these "B" connections to the amplifier, and if so what are the corresponding connections on the Amplifier. ??????

Many Thanks..

"Sorry, whole point of this thread is that the rear speakers do not work".

Last edited by trev; 03-23-2010 at 06:45 PM. Reason: Further Information
trev is offline  
Sponsored Links
Advertisement
 
#2 Old 03-23-2010
Premium Member
 
paultalb's Avatar
 
Join Date: Feb 2010
Location: Colorado Springs
Vehicle: '04 SLK32 //AMG Needswings upgrades -- 4Sale
Other Toys: F150, A3 quattro, XC70 Polestar, MB Sprinter
Posts: 621
Country:
Chats: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 96
Thanked 63 Times in 49 Posts
Garage
Send a message via MSN to paultalb
Check this Thread

Look at my thread, do you have the connectors or did it get cut out, I can give you the color/use for most. I had a couple of extras that I don't know what they should have connected to.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
paultalb is offline  
#3 Old 03-23-2010
Registered Users
 
Join Date: Mar 2010
Vehicle: SLK 320 R170
Posts: 4
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
(Thread Starter)
Hi.
yes I did read through your thread and it confirmed my thoughts on the head unit connectors 1 & 2 and 7 & 8 being rear speaker drivers. Am I right in thinking these should be wired to the amp, and if so what are the connections on the amp. It may be that the wiring has been cut in the loom somewhere, as stated the original head unit has been removed.
trev is offline  
 
#4 Old 03-23-2010
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,821
Country:
Chats: 38
Mentioned: 471 Post(s)
Tagged: 5 Thread(s)
Quoted: 6551 Post(s)
Thanks: 3,246
Thanked 11,090 Times in 8,444 Posts
trev,

Welcome from Valrico, Florida!
And welcome to this great forum!

Please update your location in your profile as it helps the members answer any questions you might have based on locale and model.
usercp, edit your details, location.

You might want to post an introduction in the ‘new members introduce yourself here’ section, if you haven’t already.






If you haven’t, please use the 'search this forum' feature for your questions as they have probably been asked before.
In addition, If you haven’t, please post your questions in the appropriate discussion forum for a quicker response.
And finally, if you find something useful on your visit here today, please consider becoming a donating member or make a one-time donation to offset development and operating costs. Even $5 is welcome! Thanks!


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#5 Old 03-23-2010
Premium Member
 
paultalb's Avatar
 
Join Date: Feb 2010
Location: Colorado Springs
Vehicle: '04 SLK32 //AMG Needswings upgrades -- 4Sale
Other Toys: F150, A3 quattro, XC70 Polestar, MB Sprinter
Posts: 621
Country:
Chats: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 96
Thanked 63 Times in 49 Posts
Garage
Send a message via MSN to paultalb
Quote:
Originally Posted by trev View Post
Hi.
yes I did read through your thread and it confirmed my thoughts on the head unit connectors 1 & 2 and 7 & 8 being rear speaker drivers. Am I right in thinking these should be wired to the amp, and if so what are the connections on the amp. It may be that the wiring has been cut in the loom somewhere, as stated the original head unit has been removed.
Bummer.. If you have the Bose those need to be connected to the Pre-Amp from your deck. There is only left and right, not front and back going to the amp, unless they bypassed it and the leads go directly to the speakers. you could check the resistance, if they go directly to the speaker it would be 4 or 8 ohms.

If you want original OEM I'm going to sell my old head unit, and 6-disk changer.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
paultalb is offline  
#6 Old 03-24-2010
Registered Users
 
Join Date: Mar 2010
Vehicle: SLK 320 R170
Posts: 4
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
(Thread Starter)
Hi Paul, thanks for the info so far. The unit I am refering to as the amplifier is located on a plate in the passenger footwell. This has four wires direct to the head unit as described in my first entry. From this Amplifier ????? there is wiring to the two front speakers and the two rear speakers, I have traced / continuity tested these wires. On your thread it does show wiring from the head unit "B" coupler 1 & 2 and 7 & 8 and refers to them as the rear speaker outputs, but in the photograph it only shows four wires, the four wires which are present in my car. I can understand not needing these connections if not driving rear speakers. I have read in other threads about there being a D2B connection, is this what is possibly missing, if not, and pardon my ignorance here, if terminals 1 & 2 and 7 & 8 are not connected between the head unit and the amplifier how does the fader front / rear work on the head unit.
trev is offline  
#7 Old 03-24-2010
Premium Member
 
paultalb's Avatar
 
Join Date: Feb 2010
Location: Colorado Springs
Vehicle: '04 SLK32 //AMG Needswings upgrades -- 4Sale
Other Toys: F150, A3 quattro, XC70 Polestar, MB Sprinter
Posts: 621
Country:
Chats: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 96
Thanked 63 Times in 49 Posts
Garage
Send a message via MSN to paultalb
My head unit only had right and left, no front and rear control.
Smaller wires on block B are the only speaker connections.



I only connected A4, A7 and A8 to my deck. And soldered on RCA connections to B3 B4, B5 B6 that went to my pre-amp out on the deck.

A01 ??
A02 ?? Phone mute
A03 ??
A04 Burnt Orange\Green - Battery (circuit 30) +12V constant on, fuse F21 25A
A05 Blue\white - FM AM WEATHERBAND amplifier and Bose premium sound system power
A06 ??
A07 Pink/green - Power (circuit 15) +12V switched, ignition, fuse F10 10A
A08 Brown Ground

I couldn't find exactly what the other connects are in the R170.
paultalb is offline  
The Following User Says Thank You to paultalb For This Useful Post:
#8 Old 03-25-2010
Registered Users
 
Join Date: Mar 2010
Vehicle: SLK 320 R170
Posts: 4
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
(Thread Starter)
Hi Paul.
The more I look at this the more I am coming to the conclusion that all the wiring is there and that there is a fault with the Amp. I think my next move is to get the amp checked out.
Thanks once again for the help.
trev is offline  
#9 Old 03-25-2010
Premium Member
 
paultalb's Avatar
 
Join Date: Feb 2010
Location: Colorado Springs
Vehicle: '04 SLK32 //AMG Needswings upgrades -- 4Sale
Other Toys: F150, A3 quattro, XC70 Polestar, MB Sprinter
Posts: 621
Country:
Chats: 7
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 96
Thanked 63 Times in 49 Posts
Garage
Send a message via MSN to paultalb
Quote:
Originally Posted by trev View Post
Hi Paul.
The more I look at this the more I am coming to the conclusion that all the wiring is there and that there is a fault with the Amp. I think my next move is to get the amp checked out.
Thanks once again for the help.
If my amp was bad, I'd just bypass and use the deck's amp, the Bose doesn't have enough power. Make sure A5 is connected, it turns on the Bose amp. without that you will get nothing. I think you can manually switch it on by giving that lead 12v +.

With the Bose amp you really wouldn't need a head unit, just wire up a switched 12v to the Amp switch and connect an iPod to the speaker leads.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
paultalb is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Facelift Audio 20 amplifier output? fleep SLK R171 General Discussion 2 10-31-2009 07:11 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.