trouble with new pse pump - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 1Likes
  • 1 Post By mickmm
 
LinkBack Thread Tools
#1 Old 03-28-2014
Registered Users
 
Join Date: Mar 2014
Location: Leicester England
Vehicle: 1998 230 slk 2door kompressor auto
Other Toys: Jaguar s type 2.7 diesel /230 slk Kompessor auto 1998
Posts: 10
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 1 Post
(Thread Starter)
trouble with new pse pump

Hi folks after a search i managed to get an almost new pse pump and managed to pull out all the broken pins in the plugs i connected it all up and it worked but i did have a problem of switch on the dash it does not operate when the key is in and turned on also i did find out that it should lock auto when you start off and reach 15km per hour that was sorted by putting the key to posistion2 and holding the central lock switch top part in for 5 seconds that worked but it does not lock the passenger door now the question??? does anyone know if the yellow pipes should be fitted in any order as there are 2 connections close to each other and 1 further away i was wondering if the boot one fits on the one that is on its own ???? does anyone have any pictures of the way they should be connected ?????? or can tell me if there are any marks on the pipes to tell me where they go All the doors and boot and petrol cap locks up when you press the remote so i cannot understand why it does not lock the passenger door that is the anti hijack system
but it locks the drivers door and the boot thanks mickmm
mickmm is offline  
Sponsored Links
Advertisement
 
#2 Old 03-28-2014
Premium Member
 
Join Date: Jul 2013
Location: San Diego ca
Vehicle: 2002 320 sport automatic
Other Toys: 54 speedeter,66 mustang conv
Posts: 116
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 24
Thanked 28 Times in 11 Posts
There are two modes to locking your doors selective or global. . In selective mode when you push the unlock button once it only unlock the drivers door. pushing twice opens the passenger and trunk. In global both doors open with one push. To switch modes you need to push both the lock and unlock buttons on the remote together for 5 seconds. I would think if you are in the selective mode and the doors work as advertised then you at least have the drives door connected right. I too replaced my PSE and it all seems to work except that the doors dont lock at 15KM. I would like to know if anyone knows if the problem might be outside of the PSE. Is there a speed sensor that could cause the problem.
Robert320 is offline  
#3 Old 03-28-2014
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
If the button fix mentioned doesn't work , then yes , you've got the order of the vacuum pipes wrong .
curro101 is offline  
 
#4 Old 03-28-2014
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
Check this out , in one of the posts there's link to a layout diagram !

http://www.benzworld.org/forums/r170...-check-13.html

Have you inverted the new pump to avoid future problems ..
curro101 is offline  
#5 Old 03-28-2014
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
curro101 is offline  
The Following 2 Users Say Thank You to curro101 For This Useful Post:
#6 Old 03-28-2014
Registered Users
 
Join Date: Mar 2014
Location: Leicester England
Vehicle: 1998 230 slk 2door kompressor auto
Other Toys: Jaguar s type 2.7 diesel /230 slk Kompessor auto 1998
Posts: 10
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 1 Post
(Thread Starter)
problem with pse

Many thanks for the replies especially curro101 the diagram will be very usefull so it means that i will be able to trace all the pipes with blowing air down them and see which is which I will also try the pressing of the buttons together first and see if that helps
To you Robert mine did nit work on moving off up to 15km and then i found from another website that it is a function that can be turned on and off it works by putting the key into pos 2 then press the lock button on the console in at the top and hold for 5 seconds then you will hear a bleep that should turn it on its worth a try
thanks once again mickmm
mickmm is offline  
#7 Old 03-28-2014
Registered Users
 
Join Date: Mar 2014
Location: Leicester England
Vehicle: 1998 230 slk 2door kompressor auto
Other Toys: Jaguar s type 2.7 diesel /230 slk Kompessor auto 1998
Posts: 10
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 1 Post
(Thread Starter)
hello again i have not inverted it at the moment i have in fact put it into a plastic container so its the container that's sitting on the metal floor
that i can see has had water on it as its rusty so i will look at getting the extension for the wiring i did ask at my dealers and they had never heard of any extension to the harness i am at the moment dealing with the drains and making sure they are all clear mickmm
mickmm is offline  
#8 Old 03-31-2014
Registered Users
 
Join Date: Mar 2014
Location: Leicester England
Vehicle: 1998 230 slk 2door kompressor auto
Other Toys: Jaguar s type 2.7 diesel /230 slk Kompessor auto 1998
Posts: 10
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 3 Times in 1 Post
(Thread Starter)
psde pump problems

Hi folks just to report after all the help i have had with diagrams etc, i have a fully working locking system and does all as it should for the year and model, and locks at 15km or less.
Just been sorting all the drains out and clearing them only got a problem with 1 so far its blocked solid at the rear end where it comes out behind the bumper cant seem to clear it so far but i am going to try a twisted piece of copper wire in my battery drill its a bit embarrassing as a retired plumber being stuck on a blocked pipe and just one more thing to ask someone, when i fetched the car it had the usual 2 keys but there was a red type of key with 3 brass flat inserts, is it an after market part or was it supplied with the car from new and what does it do????
by the way i did find some other info about my windows going up to high and causing the door to be difficult to close so i tried out a suggestion by putting a piece of cardboard 3mm thick and sending the windows down then back up to come to the cardboard and hold the switch for 10 seconds and its worked its remembered the height it supposed to Finnish so now the doors close perfect thanks again mickmm
curro101 likes this.
mickmm is offline  
#9 Old 03-31-2014
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,745
Country:
Chats: 0
Mentioned: 110 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,298 Times in 1,139 Posts
Garage
Great news , glad you've got it all sorted !!
curro101 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Will CLK430/320 pse vacuum pump work in SLk320? wasatchmountains SLK R170 General Discussion 26 12-01-2015 01:45 PM
Central Locking System (PSE Pump) jznation SLK R170 General Discussion 4 03-20-2014 01:47 PM
Replaced PSE Pump, Horn Chrips when Ignition in Position 2 MZeraldo SLK R170 General Discussion 2 10-30-2013 03:26 AM
Another IC Pump Install rfourt AMGs 4 05-13-2012 01:00 PM
Working R170 PSE Door Actuator Pump BSK SLK Parts For Sale 10 10-18-2011 10:18 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.