Fault codes - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 03-07-2014
Registered Users
 
Join Date: Oct 2013
Location: Woking Surrey UK
Vehicle: 1999 Slk230K
Other Toys: 1967 230SL Pagoda
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 5
Thanked 1 Time in 1 Post
(Thread Starter)
Fault codes

Hi I have a 1999 R170 that shows up two fault codes, P0170 Fuel trim bank 1 and P0303 cylinder three misfire. I swapped no. 3 plug with no. 1 but still got the same result. The strange thing is the car runs and idles quite smoothly with no sign of a misfire. Can anyone suggest where to look next and what the P0170 code means?
Bobo26 is offline  
Sponsored Links
Advertisement
 
#2 Old 03-07-2014
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spŕin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,744
Country:
Chats: 0
Mentioned: 109 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,297 Times in 1,138 Posts
Garage
You might want to try cleaning your MAF and check the vacuum hoses for leaks ..
curro101 is offline  
The Following User Says Thank You to curro101 For This Useful Post:
#3 Old 03-08-2014
Registered Users

 
sokoloff's Avatar
 
Join Date: Jun 2009
Location: Ocean Isle Beach, NC
Vehicle: 2003 SLK320 31,000 miles
Posts: 1,314
Country:
Chats: 3
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Thanks: 27
Thanked 231 Times in 161 Posts
Garage
Quote:
Originally Posted by Bobo26 View Post
Hi I have a 1999 R170 that shows up two fault codes, P0170 Fuel trim bank 1 and P0303 cylinder three misfire. I swapped no. 3 plug with no. 1 but still got the same result. The strange thing is the car runs and idles quite smoothly with no sign of a misfire. Can anyone suggest where to look next and what the P0170 code means?
You swapped the plug or you swapped the coil pack? The coil pack is what you want to swap.

See http://www.obd-codes.com/p0170

Len
2003 SLK320 40,000 miles - now lives in Tucson with my daughter
1959 220S Cabriolet - sold - now lives in Malta
1983 240D 351,000 miles original owner - sold
1999 E300D 215,000 miles
2014 Smart electric 17,000 miles
2014 Smart electric 9,000 miles
sokoloff is offline  
The Following User Says Thank You to sokoloff For This Useful Post:
 
#4 Old 03-09-2014
Registered Users
 
Join Date: Oct 2013
Location: Woking Surrey UK
Vehicle: 1999 Slk230K
Other Toys: 1967 230SL Pagoda
Posts: 20
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 5
Thanked 1 Time in 1 Post
(Thread Starter)
Thanks for the info. I cleaned the MAF last week before I ran any checks. The car is fine on light throttle but if I drive it hard it runs very lumpy on idle. Maybe I need to replace the MAF? This morning I swapped the coil packs over and the P0303 code cleared (misfire on 3) But shouldn't I have seen a fault on another cylinder? and also checked for vacuum leaks, all ok.
Bobo26 is offline  
#5 Old 03-09-2014
Moderator
 
curro101's Avatar
 
Join Date: May 2010
Location: Madrid-Spŕin
Vehicle: Slk 200K 2004 r171
Other Toys: Toyota C-HR Hybrid
Posts: 10,744
Country:
Chats: 0
Mentioned: 109 Post(s)
Tagged: 0 Thread(s)
Quoted: 528 Post(s)
Thanks: 1,500
Thanked 1,297 Times in 1,138 Posts
Garage
You might want to change the MAF , cleaning doesn't always work , I've even heard of new , non OEM ones , not fixing the problem !
curro101 is offline  
#6 Old 03-09-2014
Registered Users

 
sokoloff's Avatar
 
Join Date: Jun 2009
Location: Ocean Isle Beach, NC
Vehicle: 2003 SLK320 31,000 miles
Posts: 1,314
Country:
Chats: 3
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Thanks: 27
Thanked 231 Times in 161 Posts
Garage
Quote:
Originally Posted by Bobo26 View Post
Thanks for the info. I cleaned the MAF last week before I ran any checks. The car is fine on light throttle but if I drive it hard it runs very lumpy on idle. Maybe I need to replace the MAF? This morning I swapped the coil packs over and the P0303 code cleared (misfire on 3) But shouldn't I have seen a fault on another cylinder? and also checked for vacuum leaks, all ok.
I'd wait a bit to see if the P0303 code reappears. Certainly wouldn't replace anything until it does. As for the P0170 that often is a MAF issue. If you do decide to replace it, please read some posts about using a real Bosch MAF vs. some of the aftermarket junk that's out there.

Len
2003 SLK320 40,000 miles - now lives in Tucson with my daughter
1959 220S Cabriolet - sold - now lives in Malta
1983 240D 351,000 miles original owner - sold
1999 E300D 215,000 miles
2014 Smart electric 17,000 miles
2014 Smart electric 9,000 miles
sokoloff is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
R171 SLK200K running lean....got fault codes..advice please! loanheadhouse SLK R171 General Discussion 7 10-12-2014 09:57 PM
Help with fault codes please synaptoman SLK R171 General Discussion 1 01-06-2014 11:53 AM
Fault Codes On a Used SLK 230 I'm looking at jimithing60089 SLK R170 General Discussion 16 09-02-2013 12:58 PM
SLK intermittently wont crank over - electrical fault finding ?? andyhhh SLK R170 General Discussion 11 09-29-2009 04:41 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.