Central Locking System (PSE Pump) - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 2Likes
  • 1 Post By DIYGirl
  • 1 Post By jznation
 
LinkBack Thread Tools
#1 Old 02-28-2014
Registered Users
 
jznation's Avatar
 
Join Date: Feb 2014
Location: San Jose
Vehicle: 2000 Mercedes SLK230 Designo Electric Green Metallic
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
Central Locking System (PSE Pump)

Problem: Central Locking System

Just like a lot of others on this forum I had my own issues with the aforementioned subject.
1. No lock/unlock
2. Dome light stays on
3. Central Locking button on dash no go.

Checked:

Looked at the PSE pump. No water damage. No corrosion. Checked all around pump and all looks good. Checked all around trunk no leaks. And just to be sure it's raining cats & dogs here in Norcal. So trust me. No leaks.

Kinda fixed:

Turns out the previous owner experienced what we've all experienced...at least those with this issue... the (white) connector had been disconnected.

Simple fix right. Got so excited. Thought to myself hallelujah I'm special....NOT!

So I reconnect it......

First thing comes on. Trunk light. Already worked without.
Second thing comes on Dome Light. Stays on
Third I get in the car click the button for the CLS and volare the locks lock and unlock.
Fourth I get out of the car, grab the remote and click to lock. Car locks. And not more than a breathe after the alarm sounds....Shoot
Fifth I grab the manual and see the remote can be re-synched. So I re-synch and even changed the batteries thinking it would help....Nope same thing. Alarm.
Sixth read every post on this forum and fell asleep.

So here's the deal. I checked all around and found the PSE Pump online for about $500 from a place in AZ.

Before I buy it I'm going to go back to the PSE pump and disconnect and open up and check and clean...carefully.

I'm so close I can feel it but do I really have to, should I have to buy the pump and call it a day?

Open to comments of any kind.

Thanks everyone!! for taking the time to read this and reply.

And once again sorry for starting up yet another similar thread.

Jz
jznation is offline  
Sponsored Links
Advertisement
 
#2 Old 03-01-2014
Registered Users
 
Join Date: Aug 2013
Location: Atlanta, GA
Vehicle: 2001 SLK 320
Posts: 161
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 39
Thanked 28 Times in 19 Posts
It may not be your PSE, it may be the alarm. It seems that once that battery goes dead, the alarm issues start. I may have been easier for the previous owner to disconnect the PSE system rather than replacing the alarm, since you can no longer just replace the battery on most of the models. Read on the forum about alarms and see if you can find out how to manually disconnect/remove the alarm for your vehicle (not the fuse, because it shares it with the PSE system. I would try that before buying a new PSE that may not fix your issue. Since the door lock and unlock, my first inclination would not be the PSE itself. Especially since you see no water damage and no corrosion.
VRG_._ likes this.
DIYGirl is offline  
The Following User Says Thank You to DIYGirl For This Useful Post:
#3 Old 03-02-2014
Registered Users
 
jznation's Avatar
 
Join Date: Feb 2014
Location: San Jose
Vehicle: 2000 Mercedes SLK230 Designo Electric Green Metallic
Posts: 13
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 1
Thanked 2 Times in 2 Posts
Garage
(Thread Starter)
I appreciate the input. I was thinking how could it be the pump since it seemed to do its job. Another suggestion that a friend of mine made was that maybe there's a leak of air somewhere. Maybe in the vacuum line since if it's losing some air then that might make the alarm go off thinking that there's a break in. But that's a needle in a hay stack.

I'll research the alarm as you suggest.

Thanks much!!
VRG_._ likes this.
jznation is offline  
 
#4 Old 03-20-2014
Registered Users
 
Join Date: Jun 2011
Location: Space Coast (Cocoa, FL
Vehicle: 98Silver SLK 168K
Posts: 6
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 8
Thanked 0 Times in 0 Posts
jznation PSE Pump and Alarm

Without being there with you to see all the details, my first impression is that your system is operating correctly. I had some of the same symptoms with my 98 R170. No. 1, I went back to the operator manual to reread the locking unlocking sequence and all I could find on the alarm system. (just to educate myself) No. 2, I found one relay in my PSC had a melted contact--- After buying what was said to be a non working PSE, I removed and replaced 4 open frame type relays in the original unit now it works fine. ( Other folks have had problems with the locking mechanism of the white plug.) VRG_._ Good Luck!
VRG_._ is offline  
#5 Old 03-20-2014
Registered Users
 
Join Date: Jan 2013
Location: Greenville SC
Vehicle: 2008 E320 Bluetec(sold 11/14), 2001 SLK 320, 2013 E350
Other Toys: 1972 MGB, 2004 Volvo V70
Posts: 287
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 2
Thanked 37 Times in 33 Posts
Garage
My alarm horn shorted out and blew f9 with similar symptoms to yours. I chose not to replace alarm horn (I detest car alarms) and everything works fine. The battery in the alarm horn can leak causes various symptoms from constant alarms, to intermittent alarms or no alarm. The alarm horn is fairly cheap to replace.
CarolinaBluetec is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 2 (0 members and 2 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Central Locking System Problem After New Battery EOLJR General Discussion 15 08-11-2015 07:02 AM
Interior light and central locking switch, dry PSE matphillips SLK R170 General Discussion 23 03-01-2015 04:23 PM
Strange Central Locking Problem Apesbrain SLK R170 General Discussion 8 11-19-2014 07:22 AM
Another IC Pump Install rfourt AMGs 4 05-13-2012 01:00 PM
PSE Vacuum Supply Pump for central Locking - Needed rocc_Diesel Where to get R170 SLK Items 3 03-25-2012 01:26 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.