SLK230 Not Starting, New Battery - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 1Likes
  • 1 Post By DIYGirl
 
LinkBack Thread Tools
#1 Old 02-28-2014
Registered Users
 
Join Date: Feb 2012
Location: Orlando, FL
Vehicle: 2002 SLK32 AMG
Posts: 43
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
SLK230 Not Starting, New Battery

Hey guys,

I've done several searches to try and find some information, but nothing so far seems to fit the exact odd symptoms that I'm having, so hopefully someone will be able to help me out...

My '98 SLK230 won't start anymore. Prior to this happening, I had two successful starts, in which both times, the battery ceased to charge and resulted in the car slowly dying out. However, I did not get a battery light and my SRS light came on.

A few days later, I wanted to check the alternator just to be sure it wasn't bad, prior to ordering the relay, as M-B charges $157 for it. But, when I went to start my car, the battery and power all came on, but upon turning the key, it just clicks and will not start. Battery was re-charged 100% and is brand-new.

Does anyone have any insight into this? Id greatly appreciate any information that could help me out!
paulmb is offline  
Sponsored Links
Advertisement
 
#2 Old 02-28-2014
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,144
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
If the battery is new like you say i would check the ground wire first and all battery connections.
Livefreeordie is offline  
#3 Old 02-28-2014
Registered Users
 
Join Date: Feb 2012
Location: Orlando, FL
Vehicle: 2002 SLK32 AMG
Posts: 43
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Tested both of those with multimeter. They seem to be just fine.

I'm doing a lot of searches online...could this specific problem be a K40 or maybe an engine immobilizer problem? Also, if it were the immobilizer preventing the car from starting, what signs would it show?
paulmb is offline  
 
#4 Old 02-28-2014
Registered Users
 
Join Date: Oct 2013
Location: watford, london
Vehicle: slk 170, 1997. blue. 230. and loverly!!!!
Other Toys: sports bike and canoe
Posts: 350
Country:
Chats: 0
Mentioned: 7 Post(s)
Tagged: 0 Thread(s)
Quoted: 38 Post(s)
Thanks: 5
Thanked 26 Times in 26 Posts
Garage
after that, check starter is working.
run a wire to the terminals and see if it spins with a direct from battery connection.
also make sure engine will actually turn. ( ie. not seized. ) spanner on crank.(ignition OFF!!)
markja is offline  
#5 Old 02-28-2014
Registered Users
 
Join Date: Feb 2012
Location: Orlando, FL
Vehicle: 2002 SLK32 AMG
Posts: 43
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
(Thread Starter)
Alright, starter is good. Engine is also not seized.

Starting to look more and more like immobilizer to me. Do these go bad easily? Would I have to go to the dreaded dealership to fix that?
paulmb is offline  
#6 Old 03-11-2014
Registered Users
 
Join Date: Aug 2013
Location: Atlanta, GA
Vehicle: 2001 SLK 320
Posts: 161
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 39
Thanked 28 Times in 19 Posts
Check the threads on the CPS, crankshaft position sensor. I had intermittent cranking problems, found no issues with the battery but replaced it because it was 6 yrs old. Worked fine for a while. Then started having problem cranking again. Finally got to the point the car would not turnover. Replaced the CPS today ($40 part) and it cranked right up. Very easy DIY replacement.

If you search CPS or cranking issues, you will see all of the different symptoms.
curro101 likes this.
DIYGirl is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery Trickle Charger pre-wiring install etyu General Modifications R171 80 3 Days Ago 01:56 PM
R171 Good Practice Tips (Includes Battery Connection Checklist) DansSlk SLK R171 Class DIY 35 08-31-2018 03:16 AM
Check battery starting voltage ZASLK SLK R171 General Discussion 8 12-27-2015 06:45 AM
SLK55 starting issues: battery, starter, or alternator? ThinkRob SLK R171 General Discussion 20 09-16-2015 06:56 PM
rickfalz - 99 slk230 not starting rickfalz New Members Introduce Yourself Here 11 01-13-2012 11:47 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.