Interior dome light quit working. - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 01-24-2014
Registered Users
 
Join Date: Jan 2014
Location: Virginia Beach, Va & Port Charlotte, Fl.
Vehicle: 2005 SLK 350
Other Toys: 2007 Z06, 1965 427 AC Cobra, 2003 Z4, 2013 Yukon Denali, 2016 Harley Road King & 2018 Road King
Posts: 110
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Thanks: 10
Thanked 7 Times in 5 Posts
(Thread Starter)
Interior dome light quit working.

First, I did multiple searches and didn't find anything on my particular problem.

My overhead dome light isn't working. Everything else works, door locks, trunk light horn, I mean EVERYTHING else works. That sort of eliminates the PSE, I think?

Here's what I've checked:

fuses, #9 etc... none blown
dimmer switch.
all dome light functions.


Here's the kicker... The dome light worked till I took the car in to the upholsterer today to have the center console painted. They disconnected wiring to remove it, to enable the strip and repaint. Is there a wire/connection under the rear portion of the console they could have left disconnected?

Any suggestions would be greatly appreciated.
undy is offline  
Sponsored Links
Advertisement
 
#2 Old 01-24-2014
Registered Users
 
Join Date: Nov 2011
Location: South Carolina
Vehicle: 2001 SLK320
Posts: 393
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 26
Thanked 68 Times in 39 Posts
Garage
Quote:
Originally Posted by undy View Post
. . . Any suggestions would be greatly appreciated.
There really isn't anything else in the consoles that would normally effect the dome light. Did they do any work on the headliner? (Did they do both front and rear consoles? I am less familure about what is up under the front console.) So my list of things to check/help isolate the problem . . .

I'll make the assumption that you've checked that both bulbs are viable? (I found that they are easier to check/replace with the dome light assembly out of the car.)

So with that, have you taken the dome assembly out of the car to check it? I had the unusual experience that my dome light kept coming on! I found that there are open buss bars behind the plastic housing and while being serviced, they were bent in such a way as to be making intermittant contact with the roof, completing the circut and allowing the lights to come on. Perhaps yours were damaged in someway way preventing it from completing the circuit?

https://www.slkworld.com/slk-r170-gen...ght-issue.html

Then next thing I would check would be to take a VOM (Volt Ohm Meter) and see if you are getting the proper power out of the plug. (I don't have a diagram on this, perhaps someone else does; you should be able to look at the plug wires and make a decent guess for the ground - there are four bars in the dome assembly - usually it's a black wire.) There should be at least one ground, (and get 0+ ohms to the rest of the car) one constant on, and another working off the door circuit. If you don't get those, then the wiring must be damaged (perhaps during the upholsterering) work and all you can do is follow it around until you find the point that is damaged. If you get the power there, then your problem is in the dome light assembly.

Hope that helps to eliminate a few things for you if notheing else.

lilred320SLK is offline  
#3 Old 01-24-2014
Registered Users
 
Join Date: Jan 2014
Location: Virginia Beach, Va & Port Charlotte, Fl.
Vehicle: 2005 SLK 350
Other Toys: 2007 Z06, 1965 427 AC Cobra, 2003 Z4, 2013 Yukon Denali, 2016 Harley Road King & 2018 Road King
Posts: 110
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Thanks: 10
Thanked 7 Times in 5 Posts
(Thread Starter)
Quote:
Originally Posted by lilred320SLK View Post
There really isn't anything else in the consoles that would normally effect the dome light. Did they do any work on the headliner? (Did they do both front and rear consoles? I am less familure about what is up under the front console.) So my list of things to check/help isolate the problem . . .

I'll make the assumption that you've checked that both bulbs are viable? (I found that they are easier to check/replace with the dome light assembly out of the car.)

So with that, have you taken the dome assembly out of the car to check it? I had the unusual experience that my dome light kept coming on! I found that there are open buss bars behind the plastic housing and while being serviced, they were bent in such a way as to be making intermittant contact with the roof, completing the circut and allowing the lights to come on. Perhaps yours were damaged in someway way preventing it from completing the circuit?

https://www.slkworld.com/slk-r170-gen...ght-issue.html

Then next thing I would check would be to take a VOM (Volt Ohm Meter) and see if you are getting the proper power out of the plug. (I don't have a diagram on this, perhaps someone else does; you should be able to look at the plug wires and make a decent guess for the ground - there are four bars in the dome assembly - usually it's a black wire.) There should be at least one ground, (and get 0+ ohms to the rest of the car) one constant on, and another working off the door circuit. If you don't get those, then the wiring must be damaged (perhaps during the upholsterering) work and all you can do is follow it around until you find the point that is damaged. If you get the power there, then your problem is in the dome light assembly.

Hope that helps to eliminate a few things for you if notheing else.

Thanks for the reply lilred...

I pulled the light cover, one of the bulb light diffusers and a bulb. The bulb was fine. The odd thing is it all worked fine last night and now back from the upholsterer, zip, nada, nothing.

They did no work on the roof, only opening it to make it easier to work on the interior. I find it very, very, unlikely that all of a sudden the bus bars warped too. Although I may pull the assembly tomorrow. I could also pull the bulb again and run some voltage/ground checks with my VOM on the bayonet bulb's base (where the bulb pushes in)

The upholsterer only pulled the rear portion and masked the front. I saw it while it was off. There were several wires under there that were disconnected at the time. Maybe a ground?? I'd sure like to know what wires run under there. I hate to attempt pulling it and mess up their paint job since it hasn't cured much. I may check for a DIY for pulling it though.

What a PITA...
undy is offline  
 
#4 Old 01-25-2014
Registered Users
 
Join Date: Nov 2011
Location: South Carolina
Vehicle: 2001 SLK320
Posts: 393
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 26
Thanked 68 Times in 39 Posts
Garage
Quote:
Originally Posted by undy View Post
. . . I find it very, very, unlikely that all of a sudden the bus bars warped too. Although I may pull the assembly tomorrow. I could also pull the bulb again and run some voltage/ground checks with my VOM on the bayonet bulb's base (where the bulb pushes in)

The upholsterer only pulled the rear portion and masked the front. I saw it while it was off. There were several wires under there that were disconnected at the time. Maybe a ground?? . . .
All I can say is that I was dumfounded when I found mine, it had been several months since I had had the car repainted, then suddenly this problem and the bent bars. (That's all I can suspect anyway.)

The wires in the rear console are primarily to run the roof and mirror switches and the various phone connections. (I've disconnected the phone stuff (service & info) since it doesn't work anyway and pushed the connectors beneath the console housing.) Never had an issue there . . .

Certainly the VOM will give you the best shot at finding the problem, though unless it's obvious; it could entail a lot of hunting for the right wires.

The dome light housing is not very robust and I sort of fear it wouldn't take much bumping to make it malfunction. The plug bases in mine appear a bit loose at the connections . . . Obviously the sockets are a bit more accessible, but you are really only two screws (and some pulling/prying) to getting the assembly out. I didn't want to risk breaking the little diffusers.

Good luck, tell us what you find.
lilred320SLK is offline  
#5 Old 01-25-2014
Registered Users
 
Join Date: Jan 2014
Location: Virginia Beach, Va & Port Charlotte, Fl.
Vehicle: 2005 SLK 350
Other Toys: 2007 Z06, 1965 427 AC Cobra, 2003 Z4, 2013 Yukon Denali, 2016 Harley Road King & 2018 Road King
Posts: 110
Country:
Chats: 0
Mentioned: 2 Post(s)
Tagged: 0 Thread(s)
Quoted: 28 Post(s)
Thanks: 10
Thanked 7 Times in 5 Posts
(Thread Starter)
Go figure...

I went back out this AM to fiddle with it again. When I started pulling the cover (for the 3rd time) one of the bulbs started working. With the cover off I touched the other bulb it started glowing faintly. I went ahead and pulled out the whole assembly, as lilred suggested. I went ahead and pulled both bulb with their sockets. I cleaned all four socket contact points on the buss bars and cleaned the contacts on the sockets where they contact the buss bars. I "re-tensioned" the socket's contacts where they contact the buss bars too. I put everything together and re-tested. Everything works fine now, by the doors and the manual "on" switch.

I really don't have a warm fuzzy that this won't happen again. I looked on FleaBay and there's a ton of the light assemblies available. If it happens again I'll just buy another light assembly.

Now it's time to do a forum search on the radio antenna. The inside retainer nut has fallen down, leaving the antenna to flop around. My "Magic Johnson" sized hands are now cut-up and bleeding profusely trying to reach that darn nut. Ya gotta love used cars.

Thanks for the help lilred! It people like you that makes this forum what it is.

Dave
undy is offline  
The Following User Says Thank You to undy For This Useful Post:
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Rear brake light not working! (FIXED) Algebal SLK R170 class DIY 12 06-21-2019 10:25 AM
Rear License plate light not working!! vwroyd SLK R171 General Discussion 20 11-22-2015 05:43 PM
AC Quit Working...Very interesting symptoms... kuratsunade SLK R171 General Discussion 10 06-18-2014 07:28 AM
Electrical issue - Brake light not working rodge SLK R170 General Discussion 1 01-12-2011 05:54 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.