charging issue on slk320? new battery and alternator - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 01-19-2014
Registered Users
 
Join Date: Jan 2014
Posts: 1
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
charging issue on slk320? new battery and alternator

Hi I have a 2001 slk320 and I've been having issues out of the battery light/ charging system. I first used my mulitimeter and found the car had 12.6 volts at the battery not running so that's perfect voltage for a battery... and then while running it was only putting out 11.5-11.6 volts. So I figured it was the alternator so I took the alternator off and took it to work to test it (I work at Napa). It tested good 10 times! I did it that many times because I was kinda confused at why it was showing to be good off the car. So I put it back on and took the battery to advance since that's where it came from its a group 41 battery I know it takes a group 48 but I wouldn't think that would matter because the battery has been in there since April 2011 but the battery tested bad so I had them swap it under warranty and I reinstalled the new one

The next day I was driving it to work and the alternator died lights started going dim/out and gauges started dying also. I took the alternator off and took it back to work and it tested bad. I figured maybe the regulator was playing games or something and it finally completely went out. I replaced it with a new one from Napa and it worked fine for one day. Last night it on my way home the lights went dim and battery light came back on so I went ahead and found a parking lot before I got stranded on the side of the road. I waited maybe 5 minutes and tryed to start it, sure enough battery light never came back on all the way home.

I went out today to see what the car decided it wanted to do today and sure enough battery light on 12.3 volts not running at the battery and 11.5 volts when running.

Anyways I know it was a long story but I've heard there is a battery cut off relay or something like that, that can go bad any help would be much appreciated.
central09er is offline  
Sponsored Links
Advertisement
 
#2 Old 01-19-2014
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,929
Country:
Chats: 38
Mentioned: 473 Post(s)
Tagged: 5 Thread(s)
Quoted: 6573 Post(s)
Thanks: 3,246
Thanked 11,101 Times in 8,454 Posts
Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Please update your location/vehicle (model and year) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t already.
‘Usercp’ at the top left of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’.

We’d like you to post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already.


Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response and only once. Be patient and a knowledgeable member will address your question.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same,image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Post your vin in the Vehicle Datacard Request section to get a datacard (options on your car) free. https://www.slkworld.com/vehicle-data-card/
Also vote or enter our Ride of the Month competition: https://www.slkworld.com/rotm-submissions-voting/

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#3 Old 04-12-2015
Registered Users
 
Join Date: Apr 2015
Location: Plano, TX
Vehicle: 2001 SLK320
Posts: 2
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Well....what was it?

I have the EXACT same thing happening to my 2001 SLK320....lights on and acting like a bad battery/alternator. What was the problem with yours? Please elaborate. Thanks for your post.
homeboy981 is offline  
 
#4 Old 04-12-2015
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,929
Country:
Chats: 38
Mentioned: 473 Post(s)
Tagged: 5 Thread(s)
Quoted: 6573 Post(s)
Thanks: 3,246
Thanked 11,101 Times in 8,454 Posts
homeboy,

original poster has not been back since the date of his post Last Activity: 01-19-2014

Welcome to SLKWorld.com: The #1 Mercedes-Benz SLK Forum from Valrico, Florida!

Please update your location and vehicle (year?: 1996-2015, model?: 32, 200, 230, 250, 280, 300,320,350,55) in your profile as it helps the members answer your questions which usually are based on that information if you haven’t.
Follow exactly to update: ‘Usercp’ at the top of page, then ‘edit your details’ on the left side, ‘additional information’ near the bottom, edit your ‘location’ and ‘vehicle’. Your profile is NOT updated in your ‘personal garage’.

Your 1st thread should be your introduction so we can welcome you properly so post an introduction in the ‘New members introduce yourself here’ section, if you haven’t already. New Members Introduce Yourself Here - Mercedes Benz SLK Forum


Some tips to make your visit here more enjoyable:
If you haven’t, please use the 'search' feature at the top right of the page for your questions as they have probably been asked before. Remember, ‘Search’ is your friend.
If you wish to become PM (Private Message) capable, you need 15 posts. To get those 15 posts quickly, just go to the ‘New members introduce yourself here’ section and welcome enough new members to obtain your needed posts to PM.
Want to post a picture? Start a new thread or make a post, click ‘edit’, click on the ‘paper clip’ or ‘advanced’ and/or ‘manage attachments’ then ‘choose file’ then ‘upload’ and ‘submit’! If Iphone pics, you need to rename any additional pics as Iphone names its pics all the same, image.jpg.
Want to ‘like’ or thank’ someone’s comments? Use the ‘like’ button to the right or the ‘Thanks’ button, bottom right of any post you like. This saves you having to comment.
New members should be aware that the 'New Posts' link next to the 'Search' link top right of the info bar is a great way to see all of the posts you have missed since you were on the forum last. Remember to click 'mark forums read' under ‘quick links’ when you leave.
Post your vin in the Vehicle Datacard Request section to get a free datacard (options on your car). You must update your profile with vehicle info and your location and post an introduction first.
Also vote or enter our Ride of the Month competition: ROTM Submissions & Voting - Mercedes Benz SLK Forum

Thank you
Jeff
Moderator/Founding Member/Ride of the Month Coordinator


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
#5 Old 04-12-2015
Registered Users
 
Join Date: Sep 2014
Location: UK and Spain
Vehicle: SLK 200K 2003
Posts: 38
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
I would look at the 12v supply to the Alternator (this magnetises it). Remove the leads to Alternator and check the 12v supply with the ignition on - do not run engine with lead unplugged.
93041 is offline  
#6 Old 04-12-2015
Banned
 
DSSG's Avatar
 
Join Date: Oct 2014
Location: Cleveland, OH
Vehicle: 2010 SLK 350 with Sport Pkg
Other Toys: Model planes
Posts: 801
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 198 Post(s)
Thanks: 2
Thanked 56 Times in 53 Posts
Well you have a new battery, so it probably isn't it. I suspect the alternator is shot. Take it to a shop that specializes in automotive electrical repair. They will take it apart and check all of its components and replace any bad parts.

To test the alternator, get the battery voltage up first. You could do this with a trickle charger. Then knock the battery voltage down with a series of starts. You could also turn on all the accessories and lights for an hour or so. Make sure the voltage has dropped using a volt meter. Now run the car for a 20 minutes of so. Does the battery come back up? If the alternator is doing its job, it should come back very quickly. Also make sure the belt has the proper tension.

Anther way to do this is hook a volt meter to the battery and run the engine at a fast idle. If the alternator is OK, you should measure about 14 Volts. I like the first way, because it simulates the alternator's job.

The main drain on the battery is starting the car, so the main job of the alternator is to bring the voltage up very quickly. This is very important, since you may start the car several times in a day. The rest of the electrical need of the car generally aren't that great, so the alternator has a light load.
DSSG is offline  
#7 Old 04-15-2015
Registered Users
 
Join Date: Apr 2013
Location: Sidney, BC
Vehicle: 2001 SLK320
Other Toys: Traded them all!!
Posts: 753
Country:
Chats: 0
Mentioned: 9 Post(s)
Tagged: 0 Thread(s)
Quoted: 124 Post(s)
Thanks: 29
Thanked 46 Times in 42 Posts
Regardless of how much the battery voltage drops on starting, once running my understanding is you should be seeing 14V+.
Something is screwy here.
Alex 3 is offline  
#8 Old 04-15-2015
Banned
 
DSSG's Avatar
 
Join Date: Oct 2014
Location: Cleveland, OH
Vehicle: 2010 SLK 350 with Sport Pkg
Other Toys: Model planes
Posts: 801
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 198 Post(s)
Thanks: 2
Thanked 56 Times in 53 Posts
Quote:
Originally Posted by Alex 3 View Post
Regardless of how much the battery voltage drops on starting, once running my understanding is you should be seeing 14V+.
Something is screwy here.
The voltage regulator controls the DC current output from the alternator. Its job is to make sure the voltage of the battery is maintained at a certain level probably around 12+ volts. If the battery voltage drops, the regulator lets the alternator pump the battery up and stops the current flow when the battery is pumped.

You see the voltage regulator is the electronic counterpart of Hans & Fritz!
DSSG is offline  
#9 Old 02-02-2016
Registered Users
 
Join Date: Jan 2016
Location: Svensen
Vehicle: '98 SLK 230
Other Toys: 2 '91 Geo metro roadsters,944,CRX
Posts: 3
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Garage
My wife's '98 230 is doing the same thing. Drain at the battery while running. Seems like the charge light would come on but it doesn't. If the alt is bad, shouldn't the light come on?
J. W. H is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Battery / Alternator low voltage problems nmslk SLK R171 General Discussion 24 05-08-2016 01:06 PM
Alternator life span conleyjb SLK R170 General Discussion 6 03-13-2013 10:08 PM
99 SLK 230 Charging Problem Nanner General Discussion 1 07-30-2010 04:11 PM
Need help with alternator issue Jakub SLK R171 General Discussion 17 07-13-2009 07:25 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.