BAS/ESP light on start up - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 01-18-2014
Registered Users
 
MB Star's Avatar
 
Join Date: Jun 2013
Location: S. California
Vehicle: 2002 SLK 32 AMG
Other Toys: Montesa Cota 4RT Trials motorcycle
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 13
Thanked 0 Times in 0 Posts
Send a message via Skype™ to MB Star
(Thread Starter)
BAS/ESP light on start up

Hello everyone,
I'm getting a BAS/ESP light at start up, I can clear it with the lock to lock reset but I'm stumped as to what might trigger it as soon as I start the car. It's an '02 SLK32 with 84k on it. Thoughts?
MB Star is offline  
Sponsored Links
Advertisement
 
#2 Old 01-18-2014
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,602
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Thanks: 555
Thanked 570 Times in 502 Posts
It could be your brake light switch needs replacing.

https://www.slkworld.com/slk-r170-gen...70-issues.html


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
The Following User Says Thank You to slk320chick For This Useful Post:
#3 Old 01-18-2014
Registered Users
 
MB Star's Avatar
 
Join Date: Jun 2013
Location: S. California
Vehicle: 2002 SLK 32 AMG
Other Toys: Montesa Cota 4RT Trials motorcycle
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 13
Thanked 0 Times in 0 Posts
Send a message via Skype™ to MB Star
(Thread Starter)
Is the switch located above the brake pedal? Looking at it I don't see it, may have to remove the panel I guess...
Thanks
MB Star is offline  
 
#4 Old 01-19-2014
Registered Users
 
Join Date: Aug 2006
Location: Boca Raton,Florida
Vehicle: 2003 SLK32 AMG
Other Toys: 73 Mustang convertible
Posts: 194
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 15 Post(s)
Thanks: 1
Thanked 16 Times in 15 Posts
Send a message via MSN to adrose Send a message via Skype™ to adrose
I occasionally have this occur if I dont drive more than a couple of miles. I Never seem to have it on a long run,say 10 miles. I THINK it may be voltage related but cant confirm.Please check battery voltage /age of battery.I have had 2 brake switches replaced in 10 years,which always cured the problem!
adrose is offline  
The Following User Says Thank You to adrose For This Useful Post:
#5 Old 01-19-2014
Registered Users
 
Join Date: Apr 2013
Location: Crystal Beach, Ontario
Vehicle: 2001 SLK 3.2 V-6
Other Toys: 2012 Infiniti EX35
Posts: 280
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 29
Thanked 47 Times in 22 Posts
Send a message via Skype™ to Simprof
Had the same happening last summer this is what you need if it is the brake light swich.

It was for me..

http://www.ebay.com/itm/251322917294...#ht_823wt_1238

Simprof is online now  
The Following User Says Thank You to Simprof For This Useful Post:
#6 Old 01-22-2014
Registered Users
 
MB Star's Avatar
 
Join Date: Jun 2013
Location: S. California
Vehicle: 2002 SLK 32 AMG
Other Toys: Montesa Cota 4RT Trials motorcycle
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 13
Thanked 0 Times in 0 Posts
Send a message via Skype™ to MB Star
(Thread Starter)
I replaced the brake switch per the instructions with the proper gap, etc,
However the light came back on today.... Frustrated , any ideas?
MB Star is offline  
#7 Old 01-22-2014
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,602
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Thanks: 555
Thanked 570 Times in 502 Posts
Okay lets try some other things..

Have you been to your local auto parts store and had the codes read
recently?

In this thread the BAS was fixed by replacing the lateral acceleration sensor
https://www.slkworld.com/ask-dansslk/...ight-r170.html


This is the left to right wheel solution
https://www.slkworld.com/slk-r170-gen...g-battery.html

This suggests even more sensors
https://www.slkworld.com/slk-r170-gen...ght-comes.html


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
#8 Old 01-22-2014
Registered Users
 
MB Star's Avatar
 
Join Date: Jun 2013
Location: S. California
Vehicle: 2002 SLK 32 AMG
Other Toys: Montesa Cota 4RT Trials motorcycle
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 13
Thanked 0 Times in 0 Posts
Send a message via Skype™ to MB Star
(Thread Starter)
The only code I'm getting is a P0412 for the egr valve, nothing related to the BAS/ESP I'm fairly sure. I'll go over the other links you provided, thanks for your help!
MB Star is offline  
#9 Old 01-22-2014
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,602
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Thanks: 555
Thanked 570 Times in 502 Posts
Good luck keep us posted please


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
#10 Old 01-22-2014
Registered Users
 
MB Star's Avatar
 
Join Date: Jun 2013
Location: S. California
Vehicle: 2002 SLK 32 AMG
Other Toys: Montesa Cota 4RT Trials motorcycle
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 13
Thanked 0 Times in 0 Posts
Send a message via Skype™ to MB Star
(Thread Starter)
Question, the lock to lock reset clears the bas/eps light for a period of time, does this mean the steering position sensor is suspect, over the yaw sensor everyone mentions?
MB Star is offline  
#11 Old 01-23-2014
Registered Users
 
MB Star's Avatar
 
Join Date: Jun 2013
Location: S. California
Vehicle: 2002 SLK 32 AMG
Other Toys: Montesa Cota 4RT Trials motorcycle
Posts: 34
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 13
Thanked 0 Times in 0 Posts
Send a message via Skype™ to MB Star
(Thread Starter)
Just discovered this , I did a throttle position reset and it generated a TPS code. Could this be connected to the BAS light?
MB Star is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
2001 SLK 320 suddenly brakes and BAS/ESP light comes on RZRBACK SLK R170 General Discussion 112 01-29-2018 04:56 PM
low idle / intermittent rough idle at start up? gertie SLK R172 General Discussion 10 11-13-2012 06:03 PM
Black & Dekker simple start Dimi190E General Discussion 5 11-11-2010 07:07 PM
Check Engine Light x2! jbanks15 SLK R171 General Discussion 4 05-26-2007 08:05 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.