P0455 Check engine light, blinking gas light - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 2Likes
  • 1 Post By slk320chick
  • 1 Post By UncleE1
 
LinkBack Thread Tools
#1 Old 12-28-2013
Registered Users
 
dan2c1's Avatar
 
Join Date: Jul 2013
Location: Costa Rica
Vehicle: SLK 230 1998
Posts: 111
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 39
Thanked 5 Times in 3 Posts
Garage
(Thread Starter)
P0455 Check engine light, blinking gas light

The scanner gave me the P0455 code
it started with a blinking gasoline light and then The Check engine light was on,

a friend scanned the car and he told me it's probably just a hose and he deleted the code but i couldn't find the hose, i honestly didn't look where to look and i just forgot about it.

A couple of days ago the same thing happened and the gasoline light started to blink and then the check engine code appeared.

Any suggestions on how to fix this ?

Thanks
dan2c1 is offline  
Sponsored Links
Advertisement
 
#2 Old 12-28-2013
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,602
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Thanks: 555
Thanked 570 Times in 502 Posts
It could be any one of these-please try the search feature at the top of the forum: And it also may be something as simple as a bad gas cap. I would start there.

https://www.slkworld.com/slk-r170-gen...632-p0455.html
https://www.slkworld.com/slk-r170-gen...uel-light.html

http://www.benzworld.org/forums/r170...full-tank.html
dan2c1 likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
The Following User Says Thank You to slk320chick For This Useful Post:
#3 Old 12-30-2013
Registered Users
 
dan2c1's Avatar
 
Join Date: Jul 2013
Location: Costa Rica
Vehicle: SLK 230 1998
Posts: 111
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 14 Post(s)
Thanks: 39
Thanked 5 Times in 3 Posts
Garage
(Thread Starter)
The code went away.
It seeems like cleaning this valve took care of the issue
http://www.benzworld.org/forums/atta...urge-valve.pdf
dan2c1 is offline  
 
#4 Old 12-31-2013
Registered Users
 
Join Date: Jan 2007
Location: mayberry RFD
Vehicle: 2000 slk230
Other Toys: toyota paseo,toyota 4x4,75 triumph spitfire
Posts: 7
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 2 Times in 1 Post
This code has been bugging me since ive been out of warranty, it comes, goes, fixes and unfixes itself. Im thinking of doing a complete analysis of the system as there are about 5 different fixes that do or dont work for everybody, i have the necessary diagnostics tools and a good deal of experience. My question is, is this only the 230 or are other engine systems affected. Ive tried all the cures but in 13 yrs the problem keeps coming back.
swoop is offline  
#5 Old 12-11-2016
Registered Users
 
UncleE1's Avatar
 
Join Date: Jul 2016
Location: Louisiana
Vehicle: 1999 SLK 230
Posts: 56
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
Red face

Bringing and old post back to life.

Quote:
Originally Posted by dan2c1 View Post
The code went away.
It seeems like cleaning this valve took care of the issue
http://www.benzworld.org/forums/atta...urge-valve.pdf
Once again, this site saves the day...hopefully.

I followed these instructions and listened for the 'little drummer" and barely heard a click. I cleaned as instructed and now I hear the drumming. The engine died few times after cleaning, but that may be from excess MAF cleaner in the lines working its way out, I hope. The flashing fuel light is gone, but the check engine light remains.

Do I have to use an ODB reader to clear the check engine light?

Thanks,
UncleE1 is offline  
#6 Old 12-13-2016
Registered Users
 
UncleE1's Avatar
 
Join Date: Jul 2016
Location: Louisiana
Vehicle: 1999 SLK 230
Posts: 56
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
I flushed out the PV and flipped the gasket on my gas cap. The flashing fuel light has not re-appeared, but the check engine light is still on. Should this go out by itself or do i need to use an ODB reader to clear a code?
UncleE1 is offline  
#7 Old 01-09-2017
Registered Users
 
UncleE1's Avatar
 
Join Date: Jul 2016
Location: Louisiana
Vehicle: 1999 SLK 230
Posts: 56
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 16 Post(s)
Thanks: 1
Thanked 0 Times in 0 Posts
Garage
I'll answer my own question. I had to use an OBD reader to clear the code and make the CEL go away. Now, to see if it comes back on.
jbanks15 likes this.
UncleE1 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Check Engine Light on... Control Module Performance?!! PLEASE HELP!! ebenk SLK R171 General Discussion 12 04-25-2013 12:49 AM
Check Engine light lit, then gone away (SLK 32AMG) jonathan SLK R170 General Discussion 0 03-06-2013 08:15 AM
What that dreaded 'check engine' repair will cost you jbanks15 Off Topic 1 12-12-2012 09:32 PM
Check engine light on! rdc08 SLK R170 General Discussion 16 02-29-2012 07:30 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.