EC/Recirc/Blower fail? - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 1Likes
  • 1 Post By leapyfish
 
LinkBack Thread Tools
#1 Old 11-18-2013
Registered Users
 
cockneyrick's Avatar
 
Join Date: Nov 2013
Location: Crewe UK
Vehicle: SLK 230 03MY
Other Toys: Yoshimura GS1100, GSX1100EFE Drag bike
Posts: 267
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Thanks: 10
Thanked 23 Times in 23 Posts
Garage
(Thread Starter)
Question EC/Recirc/Blower fail?

Only had this car 1 day & bought it cheapish with a few issues. Some cluster lights out, blah blah!

Now the main issues is that the heater blower motor does not work in any position (1-6) now my experience of other cars is that if it works full on, then it the Thermister gone, but if not, then???

Also the EC & recirc buttons do not work/light up. Could all these problems be related, or are they seperate issues?

Currently the car passes warm air into the car after a fashion, however come the frost i'll be fooked! It also heavily condensates up!

Any help where to start will be appreciated
cockneyrick is offline  
Sponsored Links
Advertisement
 
#2 Old 11-18-2013
Registered Users
 
Join Date: Aug 2012
Location: KENT
Vehicle: MERCEDES SLK 171 - 09. - SLK KENT GROUP MEET - EVENT ORGANISER
Posts: 4,803
Country:
Chats: 0
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1136 Post(s)
Thanks: 52
Thanked 344 Times in 322 Posts
Garage
Quote:
Originally Posted by cockneyrick View Post
Only had this car 1 day & bought it cheapish with a few issues. Some cluster lights out, blah blah!

Now the main issues is that the heater blower motor does not work in any position (1-6) now my experience of other cars is that if it works full on, then it the Thermister gone, but if not, then???

Also the EC & recirc buttons do not work/light up. Could all these problems be related, or are they seperate issues?

Currently the car passes warm air into the car after a fashion, however come the frost i'll be fooked! It also heavily condensates up!

Any help where to start will be appreciated

Id edge my bets on the motor !!

Its how you say fooked !
Delucas is offline  
#3 Old 11-18-2013
Registered Users
 
cockneyrick's Avatar
 
Join Date: Nov 2013
Location: Crewe UK
Vehicle: SLK 230 03MY
Other Toys: Yoshimura GS1100, GSX1100EFE Drag bike
Posts: 267
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Thanks: 10
Thanked 23 Times in 23 Posts
Garage
(Thread Starter)
Cheers, will check fuses first, then strip the motor out. Unfortunately work is calling first
cockneyrick is offline  
 
#4 Old 11-18-2013
Registered Users
 
Join Date: Apr 2013
Location: North Carolina
Vehicle: 2001 SLK320
Posts: 48
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 2
Thanked 7 Times in 6 Posts
Pull the center bezel and make sure the connector is in place.
Randy
randy993 is offline  
#5 Old 11-18-2013
Registered Users
 
cockneyrick's Avatar
 
Join Date: Nov 2013
Location: Crewe UK
Vehicle: SLK 230 03MY
Other Toys: Yoshimura GS1100, GSX1100EFE Drag bike
Posts: 267
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Thanks: 10
Thanked 23 Times in 23 Posts
Garage
(Thread Starter)
Quote:
Originally Posted by randy993 View Post
Pull the center bezel and make sure the connector is in place.
Randy
How do you mean?
cockneyrick is offline  
#6 Old 11-18-2013
Premium Member
 
leapyfish's Avatar
 
Join Date: May 2009
Location: Oahu, Hawaii
Vehicle: Daily driver 1998 SLK230 243,xxx miles
Posts: 3,505
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 39 Post(s)
Thanks: 960
Thanked 527 Times in 415 Posts
Garage
The lights on the a/c controls are behind the control dials http://www.benzworld.org/forums/r170...ml#post3789738
In case you do need to remove the a/c controls,
here is a how to http://www.benzworld.org/forums/r170...ml#post2897396
Dolau likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Vario roof
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

R170 & R171
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
SLK 230 320 32AMG
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
&
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
leapyfish is offline  
#7 Old 11-24-2013
Registered Users
 
cockneyrick's Avatar
 
Join Date: Nov 2013
Location: Crewe UK
Vehicle: SLK 230 03MY
Other Toys: Yoshimura GS1100, GSX1100EFE Drag bike
Posts: 267
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 34 Post(s)
Thanks: 10
Thanked 23 Times in 23 Posts
Garage
(Thread Starter)
Talking

Right, today i re-assembled it using the old motor that worked fine on a battery test. Then fitted a new Thermistor (Resistor) Ebay Ł21.45p & tried it out.....
Hey presto it all works! Also the EC/Recirc buttons & lights now work too, so they are also controlled by the Thermistor curcuitry & wiring

So all in all, under Ł22 for a relatively easy fix!

As an aside, whilst under the passenger footwell panel, i dropped the Air cleaner filter out, it was soaking wet & filthy. So new one of them ordered too.
cockneyrick is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can you identify the part? Vario Roof Fail lexl SLK R171 General Discussion 37 04-25-2018 04:20 PM
CPS fail... adrose SLK R170 General Discussion 1 08-02-2013 07:48 PM
Katana Fail Compilation leapyfish Off Topic 0 02-22-2013 05:33 PM
SLKs prevail where motorcycles fail! Santamonica SLK32 Off Topic 16 04-20-2010 10:20 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.