Im just have no idea whats up with her! - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 
LinkBack Thread Tools
#1 Old 11-14-2013
Registered Users
 
Join Date: Aug 2012
Location: Essex
Vehicle: Automatic, 230 SLK, Blue, 1998
Posts: 37
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 10 Times in 3 Posts
Send a message via Skype™ to Algebal
(Thread Starter)
Im just have no idea whats up with her!

A little wile ago now my car use to splutter when trying to accelerate too fast and have problems changing gear, just felt like it was starting and stopping (rev counter going crazy).... I got it booked in for a transmission oil change and that seemed to sort out the problem...

6 months down the line I am having the same sort of problem once again, however once the car has warmed up (been running for 20Min it will run perfect).... and it is worse when the weather is colder....

I booked it into a garage and they said he threw up alot of codes all relating to the cylinders 2 and 3 misfiring and a couple of sensors being clogged, they cleaned it all and it seemed to run perfect...

As soon as i drove away however... the same spluttering happened and even a slight clunking noise underneath the car.

Now I will take it back to the garage but am wondering whether any of you guys could help me narrow down what this could be as i originally thought this was down to my gear box but now wonder whether it has anything to do with the Coil packs.

Just weird how it will run perfectly fine one time i go to drive and another.... splutter when try to pull away to quick.... losing all power and then starting again!

Just want to have my fun car back!

Any help would be amazing....
Algebal is offline  
Sponsored Links
Advertisement
 
#2 Old 11-14-2013
Registered Users
 
Cheezhd's Avatar
 
Join Date: Jul 2013
Location: Maryland
Vehicle: 1998 SLK 230 Kompressor
Other Toys: '66 GTO, '06 Charger
Posts: 148
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 4 Post(s)
Thanks: 3
Thanked 5 Times in 5 Posts
Garage
Define sputter a little better. Can you link the problem to a specific throttle range? Since it happens when the engine is hot it sounds like a failing sensor that doesn't like heat. Is it still an issue with gear changes or did that go away with the transmission service? I ask because a transmission issue should not throw engine codes. It sounds like you are describing two problems. My '98 is having shifting issues under heavy throttle also. I bought transmission filter and fluids to change and fix that issue. Please keep us informed as to what you find. It may benefit me too! Good luck!
Cheezhd is offline  
#3 Old 11-14-2013
Registered Users
 
Join Date: Aug 2012
Location: Essex
Vehicle: Automatic, 230 SLK, Blue, 1998
Posts: 37
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 7
Thanked 10 Times in 3 Posts
Send a message via Skype™ to Algebal
(Thread Starter)
Quote:
Originally Posted by Cheezhd View Post
Define sputter a little better. Can you link the problem to a specific throttle range? Since it happens when the engine is hot it sounds like a failing sensor that doesn't like heat. Is it still an issue with gear changes or did that go away with the transmission service? I ask because a transmission issue should not throw engine codes. It sounds like you are describing two problems. My '98 is having shifting issues under heavy throttle also. I bought transmission filter and fluids to change and fix that issue. Please keep us informed as to what you find. It may benefit me too! Good luck!
It happens when the engine is cold, once it has been running for awhile it seems to run fine!

When I acelerate it gets to around 2/3000 revs and starts sputtering (engin seems to cut out and then kick back in over and over again, clunking sound from under the car and sputtering from the exhaust...
It use to only happen for the first ten or so yards of driving and with my foot heavy on the accelerator peddle it seemed to clear itself up and run smooth... but as the weather has got colder it is taking longer and longer and sometimes not clearing up at all.

That's why i thought i might have something to do with the transmission fluid as it had never been changed in the cars life.. and when they changed it they only changed 4l! not 8 like i read.

If I find anything out i will keep this post updated.... I cant see that anyone has had any problems like this on any SLK forum
Algebal is offline  
 
#4 Old 11-14-2013
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,116
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
Check into the CPS (crank position sensor), they have been an issue in the past for people.
Livefreeordie is offline  
#5 Old 11-14-2013
Registered Users
 
Join Date: Aug 2012
Location: KENT
Vehicle: MERCEDES SLK 171 - 09. - SLK KENT GROUP MEET - EVENT ORGANISER
Posts: 4,800
Country:
Chats: 0
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1135 Post(s)
Thanks: 52
Thanked 343 Times in 321 Posts
Garage
Quote:
Originally Posted by Livefreeordie View Post
Check into the CPS (crank position sensor), they have been an issue in the past for people.
CPS would cause starting issues or car would cut out and not start etc but giving half hour or so would start again etc

Best bet elliminate all codes from engine first .

Poss air flow / throttle unit ..

Needs diagnostic reader and a good one .
Delucas is offline  
#6 Old 11-14-2013
Administrator
 
Livefreeordie's Avatar
 
Join Date: Oct 2007
Location: Rochester,NH USA
Vehicle: 2002 SLK230K
Other Toys: 1986 560SL, 2012 VW Tiguan, 2017 Ram laramie 1500
Posts: 17,116
Country:
Chats: 27
Mentioned: 83 Post(s)
Tagged: 0 Thread(s)
Quoted: 105 Post(s)
Thanks: 1,097
Thanked 1,292 Times in 1,143 Posts
Garage
A bad cps will also throw a misfire code and go into limp mode if you get on the throttle to hard. Had this problem last year.
Livefreeordie is offline  
#7 Old 11-15-2013
Registered Users
 
Join Date: May 2013
Location: northeast uk
Vehicle: 1999 slk 230 kompressor
Other Toys: vfr400 nc30 fletcher arrowflash 15
Posts: 274
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 11 Post(s)
Thanks: 4
Thanked 46 Times in 43 Posts
Garage
check for splits in the pipe between maf and airbox sounds like it could be running lean. when cold the affects would be more pronounced
beerbelly is offline  
#8 Old 11-15-2013
Premium Member
 
Wheels52's Avatar
 
Join Date: Apr 2012
Location: Central Queensland
Vehicle: 1998 SLK Black Opal
Other Toys: 2010 SV6 Commodore 210kw, 4.7 Mtr Runnabout
Posts: 166
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 22
Thanked 28 Times in 20 Posts
Garage
Check your Codes.
My 98 SLK Kom started to stutter under acceleration.
Codes read toxic Cat's.
Replaced now no problems.

[SIGPIC]Old but not broken!!
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Wheels52 is offline  
#9 Old 01-10-2014
Premium Member
 
Join Date: Dec 2013
Location: Kitchener ON
Vehicle: 1999 SLK 230 automatic
Other Toys: Old Honda's CB 350/CB 750
Posts: 123
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 8
Thanked 14 Times in 9 Posts
Garage
I'm have the same issue. Drove home at 20 km/hr with people honking at me. Engine light on, sputtering light it wasn't getting enough fuel and clunking noise under the transmission area. Thanks for the post.
legendary620 is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Projector Headlights. Good Idea? PersianPride101 SLK Parts Wanted 2 07-05-2012 12:04 PM
Just a little idea for MB parts DansSlk General Discussion 26 04-12-2007 09:28 PM
New mod idea for SLK's SLKman General Discussion 4 04-07-2007 07:00 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.