My car won't start - Mercedes Benz SLK Forum

SLK R170 General Discussion SLK 200, SLK 230K, SLK 320, SLK32 AMG

 4Likes
Reply
 
LinkBack Thread Tools
#1 Old 11-11-2013
Registered Users
 
andro333's Avatar
 
Join Date: Nov 2013
Location: Romania
Vehicle: 2002 SLK 200 Kompressor
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 22
Thanked 0 Times in 0 Posts
(Thread Starter)
My car won't start

Hello everyone,

I'm facing a strange persistent problem, my car has been in about 5 shops, for over 1 and a half months now.

My car: a 2002 SLK 200 Kompressor

I parked it one evening and when I tried to start it, the engine started for like a second then stopped suddenly, afterwards I couldn't start the car at all and I got an "Start Error" on the board computer.

What I've tried:

1. Tried to use the spare key
2. Checked the battery (varta, 1 year old), although it seemed to give the full voltage (I think it was 12V)
3. Changed the electronic motor
4. Checked the wiring of the entire ignition, everything looks intact and perfect, never been opened before
5.I tried to pull the car with another to force it to start, it started and after that I was able to start it using the key every time. I left it for about 15 minutes then tried to start it again, same problem.
6. The guys at the last shop tried to program the computer but it doesn't respond and they don't know what component is causing the problem.
7. The guys from the shop found a kit ignition (keys, ignition coil, modulator, computer) from an SLK 230, they tried to install the SLK200 software on it but they couldn't

The car is in a very good condition, 50,000 km, and has never been tampered with, I'm losing my mind here.

Any advice is appreciated.
Attached Files
File Type: pdf 1704441F277405.pdf (6.7 KB, 7 views)
andro333 is offline  
Sponsored Links
Advertisement
 
#2 Old 11-11-2013
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,141
Country:
Chats: 38
Mentioned: 458 Post(s)
Tagged: 5 Thread(s)
Quoted: 6492 Post(s)
Thanks: 3,232
Thanked 11,022 Times in 8,381 Posts
battery...seemed to give full charge? I would definately have the battery fully checked.
andro333 likes this.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is offline  
The Following User Says Thank You to jbanks15 For This Useful Post:
#3 Old 11-11-2013
Registered Users
 
andro333's Avatar
 
Join Date: Nov 2013
Location: Romania
Vehicle: 2002 SLK 200 Kompressor
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 22
Thanked 0 Times in 0 Posts
(Thread Starter)
Quote:
Originally Posted by jbanks15 View Post
battery...seemed to give full charge? I would definately have the battery fully checked.
I changed it, it's not the problem
andro333 is offline  
 
#4 Old 11-11-2013
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,602
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Thanks: 555
Thanked 570 Times in 502 Posts
In and out of 5 shops and no one was able to diagnose it? Wasn't there a post earlier about a crankshaft sensor going bad? I would stop messing with the every day mechanic and bring it into a real dealership. But that's just me. I hope others have more suggestions.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
#5 Old 11-12-2013
Registered Users
 
andro333's Avatar
 
Join Date: Nov 2013
Location: Romania
Vehicle: 2002 SLK 200 Kompressor
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 22
Thanked 0 Times in 0 Posts
(Thread Starter)
They were not day to day mechanics, they were electricians with a good reputation, the last shop was known through Romania, they specialize in these things and they have a lab just for programming electronics

Going to the dealership in Romania is a bad thing to do, they have a horrible reputation, they will change everything and they will change parts on the car with older ones and steal parts which I won't notice, then top it off with a 2000 Euro bill.
andro333 is offline  
#6 Old 11-12-2013
Registered Users
 
Join Date: Aug 2012
Location: KENT
Vehicle: MERCEDES SLK 171 - 09. - SLK KENT GROUP MEET - EVENT ORGANISER
Posts: 4,800
Country:
Chats: 0
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1135 Post(s)
Thanks: 52
Thanked 343 Times in 321 Posts
Garage
Dont muck about find someone with a good diagnostic machine and pull some codes off it .

One thing i would elliminate is the CPS first.
Delucas is offline  
The Following User Says Thank You to Delucas For This Useful Post:
#7 Old 11-12-2013
Registered Users
 
ajberrow's Avatar
 
Join Date: Sep 2013
Location: Nant-y-moel, S Wales
Vehicle: 2001 R170 230K
Other Toys: 1953 BSA B31 motorcycle, Spirit TA kit car age unknown
Posts: 734
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 143
Thanked 75 Times in 67 Posts
Garage
Quote:
Originally Posted by Delucas View Post
Dont muck about find someone with a good diagnostic machine and pull some codes off it .

One thing i would elliminate is the CPS first.
^^^^^^^^^^^^ What he said

Old Alfa I had some time ago had same symptoms. Was CPS. Nasty to change on that car - hidden between block and firewall. Barely room to get a finger in there, let alone a hand full of spanner.
ajberrow is offline  
The Following User Says Thank You to ajberrow For This Useful Post:
#8 Old 11-12-2013
Registered Users
 
Join Date: Aug 2012
Location: KENT
Vehicle: MERCEDES SLK 171 - 09. - SLK KENT GROUP MEET - EVENT ORGANISER
Posts: 4,800
Country:
Chats: 0
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1135 Post(s)
Thanks: 52
Thanked 343 Times in 321 Posts
Garage
Quote:
Originally Posted by ajberrow View Post
^^^^^^^^^^^^ What he said

Old Alfa I had some time ago had same symptoms. Was CPS. Nasty to change on that car - hidden between block and firewall. Barely room to get a finger in there, let alone a hand full of spanner.
Ive done many V6 mercs im lucky i have small hands as such .
ajberrow likes this.
Delucas is offline  
#9 Old 11-13-2013
Registered Users
 
andro333's Avatar
 
Join Date: Nov 2013
Location: Romania
Vehicle: 2002 SLK 200 Kompressor
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 22
Thanked 0 Times in 0 Posts
(Thread Starter)
Quote:
Originally Posted by ajberrow View Post
^^^^^^^^^^^^ What he said

Old Alfa I had some time ago had same symptoms. Was CPS. Nasty to change on that car - hidden between block and firewall. Barely room to get a finger in there, let alone a hand full of spanner.
Actually I've cleaned that sensor at the beginning just to be sure, didn't pay too much attention to it.

Just to be sure we have the same symptoms, the car doesn't even try to start right? But it can be started when dragged by another car?

Thanks
andro333 is offline  
#10 Old 11-13-2013
Registered Users
 
Join Date: Aug 2012
Location: KENT
Vehicle: MERCEDES SLK 171 - 09. - SLK KENT GROUP MEET - EVENT ORGANISER
Posts: 4,800
Country:
Chats: 0
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1135 Post(s)
Thanks: 52
Thanked 343 Times in 321 Posts
Garage
Quote:
Originally Posted by andro333 View Post
Actually I've cleaned that sensor at the beginning just to be sure, didn't pay too much attention to it.

Just to be sure we have the same symptoms, the car doesn't even try to start right? But it can be started when dragged by another car?

Thanks
Cleaning the sensor wont acomplish anything !

Its internal that is breaking down !

That is it it's the sensor .

So your saying the engine turns over but will not fire up.??

Yes .
Delucas is offline  
#11 Old 11-13-2013
Registered Users
 
andro333's Avatar
 
Join Date: Nov 2013
Location: Romania
Vehicle: 2002 SLK 200 Kompressor
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 22
Thanked 0 Times in 0 Posts
(Thread Starter)
No the engine doesn't turn, but there is a very low clicking sound when I turn the key.
andro333 is offline  
#12 Old 11-13-2013
Registered Users
 
Join Date: Aug 2012
Location: KENT
Vehicle: MERCEDES SLK 171 - 09. - SLK KENT GROUP MEET - EVENT ORGANISER
Posts: 4,800
Country:
Chats: 0
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1135 Post(s)
Thanks: 52
Thanked 343 Times in 321 Posts
Garage
Clicking noise as in coming from starter motor ???

Get someone to listen to stater motor / solenoid

If clicking noise is coming from that .
Sounds like faulty starter motor .

Need to get engine turning over effieciently first .

Thats if its the noise is coming from starter .
ajberrow likes this.
Delucas is offline  
#13 Old 11-13-2013
Registered Users
 
andro333's Avatar
 
Join Date: Nov 2013
Location: Romania
Vehicle: 2002 SLK 200 Kompressor
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 22
Thanked 0 Times in 0 Posts
(Thread Starter)
I've already changed the electric motor. Besides, the computer of the car is not responding to the tester.
andro333 is offline  
#14 Old 11-13-2013
Registered Users
 
Join Date: Aug 2012
Location: KENT
Vehicle: MERCEDES SLK 171 - 09. - SLK KENT GROUP MEET - EVENT ORGANISER
Posts: 4,800
Country:
Chats: 0
Mentioned: 190 Post(s)
Tagged: 0 Thread(s)
Quoted: 1135 Post(s)
Thanks: 52
Thanked 343 Times in 321 Posts
Garage
You do get faulty new starter motors !

So noise not coming from starter motor then . ?

I take it you mean the diagnostic reader is not pulling codes off the car ??

Yes
Delucas is offline  
#15 Old 11-13-2013
Registered Users
 
ajberrow's Avatar
 
Join Date: Sep 2013
Location: Nant-y-moel, S Wales
Vehicle: 2001 R170 230K
Other Toys: 1953 BSA B31 motorcycle, Spirit TA kit car age unknown
Posts: 734
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 143
Thanked 75 Times in 67 Posts
Garage
Quote:
Originally Posted by andro333 View Post
Actually I've cleaned that sensor at the beginning just to be sure, didn't pay too much attention to it.

Just to be sure we have the same symptoms, the car doesn't even try to start right? But it can be started when dragged by another car?

Thanks
Sorry, my mistake. I thought it was cranking and cutting out after a while and eventually cranking but failing to start. Must have got two threads confused.
ajberrow is offline  
#16 Old 12-05-2013
Registered Users
 
andro333's Avatar
 
Join Date: Nov 2013
Location: Romania
Vehicle: 2002 SLK 200 Kompressor
Posts: 12
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 22
Thanked 0 Times in 0 Posts
(Thread Starter)
I will continue to post about this subject, hopefully it will help others who will be in my situation

I changed the immobilizer, it was taken off an A-Class and it was successfully programmed with the key, the only problem is that the car's computer doesn't respond to it and doesn't start the engine.

after all I think I will remove the immobilizer all together until I find one specially for my model.
andro333 is offline  
#17 Old 12-05-2013
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,602
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Thanks: 555
Thanked 570 Times in 502 Posts
Instead of trying to diagnose it yourself at this point, are you able to take it to the dealer and let them run a full diagnostic on it?


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
#18 Old 12-05-2013
Registered Users
 
ajberrow's Avatar
 
Join Date: Sep 2013
Location: Nant-y-moel, S Wales
Vehicle: 2001 R170 230K
Other Toys: 1953 BSA B31 motorcycle, Spirit TA kit car age unknown
Posts: 734
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 143
Thanked 75 Times in 67 Posts
Garage
Quote:
Originally Posted by slk320chick View Post
Instead of trying to diagnose it yourself at this point, are you able to take it to the dealer and let them run a full diagnostic on it?
Chicky, the OP doesn't want to take the car to his local MB dealer because they have a bad reputation for fitting old parts, even stealing newish parts and replacing with old AND being very expensive.

I think I can empathise with him in not wanting to go near them
andro333 likes this.
ajberrow is offline  
The Following User Says Thank You to ajberrow For This Useful Post:
#19 Old 12-05-2013
Registered Users

 
Gbarringer100's Avatar
 
Join Date: May 2009
Location: Little River, SC
Vehicle: 2007 SLK350 BLK/BLK
Other Toys: 2016 GLA250
Posts: 2,309
Country:
Chats: 0
Mentioned: 6 Post(s)
Tagged: 0 Thread(s)
Quoted: 99 Post(s)
Thanks: 12
Thanked 404 Times in 350 Posts
Garage
Quote:
Originally Posted by andro333 View Post
Just to be sure we have the same symptoms, the car doesn't even try to start right? But it can be started when dragged by another car?

Thanks
You say you can get it running by dragging it by another car, is this correct. If so it sounds more like you are not getting enough power to the starter or bad starter as it will no start using the key and will run via what you call dragging by another car.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
Gbarringer100 is offline  
#20 Old 12-05-2013
Minion

 
slk320chick's Avatar
 
Join Date: Apr 2013
Location: Chicago, IL
Other Toys: 2015 Jeep Grand Cherokee
Posts: 5,602
Country:
Chats: 0
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 148 Post(s)
Thanks: 555
Thanked 570 Times in 502 Posts
Quote:
Originally Posted by ajberrow View Post
Chicky, the OP doesn't want to take the car to his local MB dealer because they have a bad reputation for fitting old parts, even stealing newish parts and replacing with old AND being very expensive.

I think I can empathise with him in not wanting to go near them
ahhhhhh now I understand, thanks


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.




To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
|
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.
slk320chick is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 General Discussion

Bookmarks

Tags
ignition, won't start, wont start

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
App claims to reveal secret prices used car dealers pay for vehicles jbanks15 Off Topic 1 03-03-2017 10:46 AM
car wont start Jjaro SLK R170 General Discussion 8 10-03-2010 03:57 PM
I give you a dedicated thread to the CLK GTR AMG,built to prove AMG's dominance alroumi AMGs 0 05-04-2008 02:17 AM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.