R170 Service Indicator won't reset - Mercedes Benz SLK Forum

 4Likes
  • 1 Post By sokoloff
  • 2 Post By lilred320SLK
  • 1 Post By lilred320SLK
 
LinkBack Thread Tools
#1 Old 05-24-2011
Registered Users
 
Join Date: May 2011
Location: UK
Vehicle: SLK 320 (R170)
Posts: 3
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
R170 Service Indicator won't reset

Hi all,

I'm trying to reset the service indicator on my MY2001 UK spec R170 (320). I've followed the instructions in the manual very carefully, and all seems to go fine, but the indicator just won't reset.

It's displaying a negative number of days, meaning it's past its service. It has of course been serviced, but the indicator hasn't been reset.

Any information on how to reset it?
G Howlerson is offline  
Sponsored Links
Advertisement
 
#2 Old 05-24-2011
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,235
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6498 Post(s)
Thanks: 3,232
Thanked 11,034 Times in 8,392 Posts
Welcome from Valrico, Florida!
And welcome to this great forum!

Please update your location/vehicle (model and yr) in your profile as it helps the members answer any questions you might have based on locale and model and year.
Usercp at the top of page, edit your details, location/vehicle.


If you haven’t, please post an introduction in the ‘new members introduce yourself here’ section.

Do a search to reset fss

If you haven’t, please use the 'search' feature at the top of the page for your questions as they have probably been asked before.
In addition, if you haven’t, please post your question in the appropriate discussion forum for a quicker response. Be patient and a knowledgeable member or guest will address your question.




Thank you,
Jeff
Sergeant-at Arms


To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#3 Old 05-24-2011
Founding Member #2

 
etyu's Avatar
 
Join Date: Jun 2006
Location: Orange County, CA
Vehicle: 2008 SLK 55
Posts: 19,391
Country:
Chats: 11
Mentioned: 77 Post(s)
Tagged: 0 Thread(s)
Quoted: 345 Post(s)
Thanks: 4,571
Thanked 3,141 Times in 2,269 Posts
Garage
I thought if one is past service due date, it will display + and not - ; Correct me if I am wrong (not familiar with R170).

Eddy



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Pewter(cubanitsilber metallic)/Beige, PIII package, Airscarf, Hands-Free Communication System, Lighting package; Designo Black Leather Cover on e-brake handle(Thank you Bill T), SmartTop v3.x, John's 3BFM, M113 AMG OEM air filters, Modified R170 ant., clear side-markers & front parking lamps w/error-free LEDs, chromed front & rear turn indicator lamps, steel mesh at battery bay cover & cabin air intake, sock-over-seatbelt buckles, belt-loop guide protectors, Lamin-X fog lamp protectors, bilateral rear fog lamps enabled, AMG crest on gear shift knob
etyu is offline  
 
#4 Old 05-26-2011
Registered Users

 
sokoloff's Avatar
 
Join Date: Jun 2009
Location: Ocean Isle Beach, NC
Vehicle: 2003 SLK320 31,000 miles
Posts: 1,314
Country:
Chats: 3
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Thanks: 27
Thanked 231 Times in 161 Posts
Garage
I would say that 99% of the time the problem is operator error. Clear your mind of what you think they want you to do, get in, close the door and follow the instructions exactly.

Len
Idiot101 likes this.

Len
2003 SLK320 40,000 miles - now lives in Tucson with my daughter
1959 220S Cabriolet - sold - now lives in Malta
1983 240D 351,000 miles original owner - sold
1999 E300D 215,000 miles
2014 Smart electric 17,000 miles
2014 Smart electric 9,000 miles
sokoloff is offline  
#5 Old 06-14-2011
Registered Users
 
Join Date: May 2011
Location: UK
Vehicle: SLK 320 (R170)
Posts: 3
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Quote:
Originally Posted by etyu View Post
I thought if one is past service due date, it will display + and not - ; Correct me if I am wrong (not familiar with R170).
Thanks for the reply. If that were the case, why is the negative number increasing every day?
G Howlerson is offline  
#6 Old 06-14-2011
Registered Users
 
Join Date: May 2011
Location: UK
Vehicle: SLK 320 (R170)
Posts: 3
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
(Thread Starter)
Quote:
Originally Posted by sokoloff View Post
I would say that 99% of the time the problem is operator error. Clear your mind of what you think they want you to do, get in, close the door and follow the instructions exactly.

Len
Thank you for the suggestion. While I agree with you that this is the most obvious answer, I have tried (again!), with the same result.

Maybe I am misunderstanding a step.
G Howlerson is offline  
#7 Old 06-14-2011
Registered Users

 
sokoloff's Avatar
 
Join Date: Jun 2009
Location: Ocean Isle Beach, NC
Vehicle: 2003 SLK320 31,000 miles
Posts: 1,314
Country:
Chats: 3
Mentioned: 3 Post(s)
Tagged: 0 Thread(s)
Quoted: 66 Post(s)
Thanks: 27
Thanked 231 Times in 161 Posts
Garage
Quote:
Originally Posted by G Howlerson View Post
Thank you for the suggestion. While I agree with you that this is the most obvious answer, I have tried (again!), with the same result.

Maybe I am misunderstanding a step.
Yeah, I had the same problem on my 210 chassis when I first tried it. Went through the steps a couple of times until it worked and I remember thinking to myself, "Oh, so that's what the Germans meant by that."

Len

Len
2003 SLK320 40,000 miles - now lives in Tucson with my daughter
1959 220S Cabriolet - sold - now lives in Malta
1983 240D 351,000 miles original owner - sold
1999 E300D 215,000 miles
2014 Smart electric 17,000 miles
2014 Smart electric 9,000 miles
sokoloff is offline  
#8 Old 10-12-2015
Registered Users
 
Join Date: Nov 2011
Location: South Carolina
Vehicle: 2001 SLK320
Posts: 393
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 26
Thanked 68 Times in 39 Posts
Garage
Quote:
Originally Posted by G Howlerson View Post
Thanks for the reply. If that were the case, why is the negative number increasing every day?
An older thread, but I was still looking for the answer to this . . .

Normally the indicator is counting down to the expected service (certainly in miles, I would assume that days would follow the same pattern) so it is saying 500 miles to go, 400 to go, 300, 200, 100, 0. Then, the only way they could differentiate it once past that point was to go negative -100, -200, -300 etc. meaning past due. Certainly they could have chosen either direction, but I haven't seen any indication that it is user selectable.


I had the same issue with trying to get mine to reset but I JUST got mine to work. You really do have to follow the instructions exactly. (At least that is how mine worked. I just reset it though, I didn't change modes!)


So, to review:
1) Turn the key to position 2,
2) Quickly press the odometer reset stalk in twice. (In no more than 4 seconds.)
The current setting will show,
3) Then quickly turn the key back to off. (In no more than 10 seconds.)
Now,
4) Press the odo reset stalk in and hold it.
5) Turn the key to position 2,
6) Wait for a bit and the display will turn to 10000. (For US miles.)


I can't remember hearing the beep . . . I was just surprised that it now showed 10000. When I cycled the key back to 0 and then restarted the car, no more indicator! (I'll see in 9000 miles or so if it worked properly.)


Hope that helps.
jbanks15 and tich65a like this.
lilred320SLK is offline  
#9 Old 10-12-2015
Administrator/Founding Member

 
jbanks15's Avatar
 
Join Date: Jun 2006
Location: Tampa, Florida
Vehicle: 2009 SLK 55 AMG Kleemann Supercharger, ECU tune, Headers and LSD, CF Diffuser
Posts: 91,235
Country:
Chats: 38
Mentioned: 459 Post(s)
Tagged: 5 Thread(s)
Quoted: 6498 Post(s)
Thanks: 3,232
Thanked 11,034 Times in 8,392 Posts
Thanks! but yes, an old thread as
G Howlerson has not been back on since: Last Activity: 06-14-2011



To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Jeff, US Army Master Sergeant Retired
Administrator/Founding Member
2009 SLK 55 AMG Black/Black
Kleemann Supercharger thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Kleemann ECU Tune, headers and downpipes thread here:

To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

Albums:
To view links or images in signatures your post count must be 0 or greater. You currently have 0 posts.

ClearBra
OEM MB Plexiglass Draught Stop
Smarttop version 3.22
Previous - 02 SLK 320, 05 SLK 350
jbanks15 is online now  
#10 Old 10-13-2015
Registered Users
 
Join Date: Nov 2011
Location: South Carolina
Vehicle: 2001 SLK320
Posts: 393
Country:
Chats: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 6 Post(s)
Thanks: 26
Thanked 68 Times in 39 Posts
Garage
Quote:
Originally Posted by jbanks15 View Post
Thanks! but yes, an old thread as
G Howlerson has not been back on since: Last Activity: 06-14-2011


I saw the dates . . . just didn't see an answer!! Ok,maybe I should have said . . "Hope that helps someone . . . anyone . . . (Bueller? Bueller?) else!"
jbanks15 likes this.
lilred320SLK is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R170 SLK Class Cars > SLK R170 class DIY

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Service query nakulan7 SLK R171 General Discussion 10 03-09-2011 08:35 PM
Can't reset FSS at Service A level (oil/filter change) Alan Lukes General Discussion 6 02-05-2011 05:48 PM
Service message reset LudoMcGurk United Kingdom Region 4 04-06-2010 07:56 AM
Help - I Think I Reset the Service Indicator Twice! mizzerd SLK R171 General Discussion 3 06-29-2009 12:04 AM
Reset Service Indicator BrianS SLK R171 General Discussion 1 04-21-2008 05:21 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.