HID failed on passenger side..What are my options - Mercedes Benz SLK Forum

Performance MODS for the R171 Tuning and Performance modifications for your SLK

 
LinkBack Thread Tools
#1 Old 07-15-2014
Registered Users
 
Join Date: May 2014
Location: Midwest, USA
Vehicle: 2007 SLK55 AMG R171
Posts: 94
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 17
Thanked 5 Times in 4 Posts
(Thread Starter)
HID failed on passenger side..What are my options

I have the Spyder aftermarket headlights, and I don't want to keep paying for Benz parts... Will an aftermarket kit fit the Spyder headlights? Anyone have experience with this?

thanks

Last edited by Boris_Balkan; 07-21-2014 at 03:45 PM.
Boris_Balkan is offline  
Sponsored Links
Advertisement
 
#2 Old 07-16-2014
Premium Member
 
Join Date: Nov 2009
Posts: 1,384
Chats: 0
Mentioned: 81 Post(s)
Tagged: 0 Thread(s)
Quoted: 316 Post(s)
Thanks: 63
Thanked 175 Times in 166 Posts
Garage
If it's the ballast you can get them easily on ebay around 40-50 EUR. The bulb can also be replaced. Only bugger with these spyders is there is no room to work.

The ballast is mounted on the bottom and the clip holding the bulb in cannot be seen (maybe through a mirror, but than your hands get in the way). And trust me the clip WILL set itself completely free making it almost impossible to get it back in place. At that time the unit has to come out meaning the bumper has to get off.

Maybe the ballast can be reached from the wheel well. When the liner is loosened/removed there may be just enough room to get under the unit and unscrew the ballast. Two or three parkers if I remember right.
JudgeMing is offline  
#3 Old 07-16-2014
Registered Users
 
Join Date: May 2014
Location: Midwest, USA
Vehicle: 2007 SLK55 AMG R171
Posts: 94
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 17
Thanked 5 Times in 4 Posts
(Thread Starter)
Quote:
Originally Posted by JudgeMing View Post
If it's the ballast you can get them easily on ebay around 40-50 EUR. The bulb can also be replaced. Only bugger with these spyders is there is no room to work.

The ballast is mounted on the bottom and the clip holding the bulb in cannot be seen (maybe through a mirror, but than your hands get in the way). And trust me the clip WILL set itself completely free making it almost impossible to get it back in place. At that time the unit has to come out meaning the bumper has to get off.

Maybe the ballast can be reached from the wheel well. When the liner is loosened/removed there may be just enough room to get under the unit and unscrew the ballast. Two or three parkers if I remember right.
Thanks, I went through the wheel-well on install too, much easier.

What size bulb are these HID's? H7? I'm interested if anyone can chime in about installing an aftermarket HID kit, especially because I'd like to find a whiter-light kit than the the factory bulbs. (I don't like any bluish tint)
Boris_Balkan is offline  
 
#4 Old 07-16-2014
Premium Member
 
Join Date: Nov 2009
Posts: 1,384
Chats: 0
Mentioned: 81 Post(s)
Tagged: 0 Thread(s)
Quoted: 316 Post(s)
Thanks: 63
Thanked 175 Times in 166 Posts
Garage
The spyder HID's are equipped with the OEM HID bulbs (for low beam). They look different than traditional H7. The fitting is almost the same though. High beam has the traditional H7.

Ebay link:
http://www.ebay.de/itm/Mercedes-2x-D...item2333e7551a
JudgeMing is offline  
The Following User Says Thank You to JudgeMing For This Useful Post:
#5 Old 07-16-2014
Premium Member
 
Durkatlon's Avatar
 
Join Date: Nov 2009
Location: San Diego, CA
Vehicle: 2009 SLK55
Posts: 4,886
Country:
Chats: 0
Mentioned: 48 Post(s)
Tagged: 0 Thread(s)
Quoted: 270 Post(s)
Thanks: 390
Thanked 1,322 Times in 790 Posts
Garage
The bulbs for the HID version are D2. These are over $100 from the dealer, but can be had much cheaper online as aftermarket parts.

The most likely cause of failure is the bulb itself. When I've had this in the past, I usually swap the left/right bulbs, to see if the problem moves. If not, then switch the ignitors (the square blocks mounted on the back of the bulbs). Both of these swaps can be done easily through the wheel well. If the ignitor swap also doesn't make the problem move to the other side, it's likely the ballast.
Durkatlon is offline  
The Following User Says Thank You to Durkatlon For This Useful Post:
#6 Old 07-16-2014
Registered Users
 
Join Date: May 2014
Location: Midwest, USA
Vehicle: 2007 SLK55 AMG R171
Posts: 94
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 17
Thanked 5 Times in 4 Posts
(Thread Starter)
Well, I replaced the bulb.... worked, then went out. I'm thinking ignitor now. What bugs me is they both worked just fine until I switched to the Spyder headlights.

Thank you to those who chimed in, I really hope it's not a ballast, as I would imagine it is more expensive than the ignitor! Anyone else had a ballast fail on this car?
Boris_Balkan is offline  
#7 Old 07-16-2014
Premium Member
 
Durkatlon's Avatar
 
Join Date: Nov 2009
Location: San Diego, CA
Vehicle: 2009 SLK55
Posts: 4,886
Country:
Chats: 0
Mentioned: 48 Post(s)
Tagged: 0 Thread(s)
Quoted: 270 Post(s)
Thanks: 390
Thanked 1,322 Times in 790 Posts
Garage
The ignitors are unfortunately also crazy expensive...
Durkatlon is offline  
#8 Old 07-16-2014
Registered Users
 
Join Date: May 2014
Location: Midwest, USA
Vehicle: 2007 SLK55 AMG R171
Posts: 94
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 17
Thanked 5 Times in 4 Posts
(Thread Starter)
Quote:
Originally Posted by Durkatlon View Post
The ignitors are unfortunately also crazy expensive...
Yes, quoted $250 for one ignitor. But, it's an AMG, I knew the rules going in LOL

Last edited by Boris_Balkan; 07-21-2014 at 03:51 PM.
Boris_Balkan is offline  
#9 Old 07-21-2014
Registered Users
 
Join Date: May 2014
Location: Midwest, USA
Vehicle: 2007 SLK55 AMG R171
Posts: 94
Country:
Chats: 0
Mentioned: 1 Post(s)
Tagged: 0 Thread(s)
Quoted: 5 Post(s)
Thanks: 17
Thanked 5 Times in 4 Posts
(Thread Starter)
OK Fantastic! Mercedes took really great care of me on this whole situation.

They spent 3+ hours completely uninstalling BOTH headlights, swapping ballasts, igniters etc to find the problem. It simply ended up being a bad connection, they fixed it, re-installed and charged me......

$0.00

I'm still in shock. I typically avoid dealerships and have always used independent Euro shops and Tuning shops for my cars to avoid being 'gouged,' but wow... I am really pleased with this particular Benz Dealer.
Boris_Balkan is offline  
Sponsored Links
Advertisement
 
Reply

  Lower Navigation
Go Back   Mercedes Benz SLK Forum > Mercedes Benz R171 SLK Class Cars > Performance MODS for the R171

Bookmarks

Quick Reply
Message:
Options
Upload your files to MEGAUPLOAD
Upload your images to ImageShack

Register Now



In order to be able to post messages on the Mercedes Benz SLK Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in











Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
User Tag List

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page



Similar Threads
Thread Thread Starter Forum Replies Last Post
Seat Heater Failure List Cookiecrew SLK R171 General Discussion 100 10-01-2018 10:31 PM

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome
 

Clubs, Garage Plus vBulletin Plugins by Drive Thru Online, Inc.